Incomplete php in pacman

To use the php pdo_mysql library, I un-commented the line in php.ini


To use the graphics library I likewise un-comment the line


That worked fine on earlier installation of php.
Alas I had to reinstall after recent update and now when I start httpd server it logs an error (None of the graphics functions are recognized, but the pdo_mysql ones do work).

PHP Warning: PHP Startup: Unable to load dynamic library ‘gd’ (tried: /usr/lib/php/modules/gd (/usr/lib/php/modules/gd: cannot open shared object file: No such file or directory), /usr/lib/php/modules/ (/usr/lib/php/modules/ cannot open shared object file: No such file or directory)) in Unknown on line 0

Perhaps this library needs to be added back in to the distribution package
Meanwhile I am hoping someone can help me get hold of it.

Note I did find a libgd on github but building that doesn’t appear to produce a library that works with php.

There is a package php-gd in the repo.


1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.