Incompatible libdevmapper on update from today


#1

Hello,

today after update my system., i get this Message:

(3/5) Updating Grub-Bootmenu
GRUB-Konfigurationsdatei wird erstellt …
Thema gefunden: /usr/share/grub/themes/manjaro/theme.txt
Linux-Abbild gefunden: /boot/vmlinuz-4.19-x86_64
initrd-Abbild gefunden: /boot/intel-ucode.img /boot/amd-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
/dev/mapper/control: open failed: Kein passendes Gerät gefunden
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.152 (2018-10-30) and kernel driver (unknown version).
Command failed.
/dev/mapper/control: open failed: Kein passendes Gerät gefunden
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.152 (2018-10-30) and kernel driver (unknown version).
Command failed.
/dev/mapper/control: open failed: Kein passendes Gerät gefunden
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.152 (2018-10-30) and kernel driver (unknown version).
Command failed.
Windows Boot Manager auf /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi gefunden
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: Warnung: Unbekannter Gerätetyp nvme0n1.
erledigt
(4/5) Creating temporary files...
(5/5) Arming ConditionNeedsUpdate...

So i find a Thread , like this:

so i will send the command and get this Message:

[egle@NUC8i7HVK ~]$ sudo modinfo dm-mod
[sudo] Passwort für egle: 
modinfo: ERROR: Module alias dm-mod not found.

Now I’m afraid to switch off my computer, that it won’t start my Manjaro anymore.

Can anybody help?

My system is:

[egle@NUC8i7HVK ~]$ inxi -Fxxz         
System:    Host: NUC8i7HVK Kernel: 4.19.8-2-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.4 
           tk: Qt 5.11.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Intel product: NUC8i7HVK v: J71485-501 serial: <filter> Chassis: type: 3 v: 2.0 
           serial: <filter> 
           Mobo: Intel model: NUC8i7HVB v: J68196-401 serial: <filter> UEFI: Intel v: HNKBLi70.86A.0048.2018.0725.1749 
           date: 07/25/2018 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K540/K545 serial: <filter> 
           charge: 100% (should be ignored) status: Discharging 
           Device-2: hidpp_battery_1 model: Logitech M570 serial: <filter> charge: 40% status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-8809G bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 49552 
           Speed: 1500 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 1499 2: 1500 3: 1500 4: 1501 5: 1500 6: 1500 7: 1500 
           8: 1500 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Polaris 22 [Radeon RX Vega M GH] vendor: Intel driver: amdgpu v: kernel 
           bus ID: 01:00.0 chip ID: 1002:694c 
           Display: x11 server: X.Org 1.20.3 driver: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 2560x1440~60Hz 
           OpenGL: renderer: AMD VEGAM (DRM 3.27.0 4.19.8-2-MANJARO LLVM 7.0.0) v: 4.5 Mesa 18.2.6 compat-v: 4.4 
           direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 
           Device-2: Advanced Micro Devices [AMD/ATI] vendor: Intel driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 1002:ab08 
           Sound Server: ALSA v: k4.19.8-2-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 chip ID: 8086:15b7 
           IF: eno1 state: down mac: <filter> 
           Device-2: Intel I210 Gigabit Network driver: igb v: 5.4.0-k port: b000 bus ID: 05:00.0 chip ID: 8086:157b 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-3: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: b000 bus ID: 06:00.0 chip ID: 8086:24fd 
           IF: wlp6s0 state: down mac: <filter> 
Drives:    Local Storage: total: 4.09 TiB used: 254.01 GiB (6.1%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> 
           ID-2: /dev/sda type: USB vendor: Seagate model: ST4000DM000-1F2168 size: 3.64 TiB serial: <filter> 
Partition: ID-1: / size: 245.08 GiB used: 29.83 GiB (12.2%) fs: ext4 dev: /dev/nvme0n1p5 
           ID-2: swap-1 size: 16.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 46.0 C mobo: 29.8 C gpu: amdgpu temp: 42 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 239 Uptime: 21m Memory: 15.62 GiB used: 3.02 GiB (19.4%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: bash v: 4.4.23 running in: yakuake inxi: 3.0.28 
[egle@NUC8i7HVK ~]$ 



[egle@NUC8i7HVK ~]$ screenfetch

 ██████████████████  ████████     egle@NUC8i7HVK
 ██████████████████  ████████     OS: Manjaro 18.0.1 Illyria
 ██████████████████  ████████     Kernel: x86_64 Linux 4.19.8-2-MANJARO
 ██████████████████  ████████     Uptime: 21m
 ████████            ████████     Packages: 1304
 ████████  ████████  ████████     Shell: bash 4.4.23
 ████████  ████████  ████████     Resolution: 2560x1440
 ████████  ████████  ████████     DE: KDE 5.52.0 / Plasma 5.14.4
 ████████  ████████  ████████     WM: KWin
 ████████  ████████  ████████     GTK Theme: Breath [GTK2/3]
 ████████  ████████  ████████     Icon Theme: maia
 ████████  ████████  ████████     Font: Noto Sans Regular
 ████████  ████████  ████████     CPU: Intel Core i7-8809G @ 8x 4.2GHz [54.0°C]
 ████████  ████████  ████████     GPU: AMD VEGAM (DRM 3.27.0, 4.19.8-2-MANJARO, LLVM 7.0.0)
                                  RAM: 3003MiB / 15991MiB


#2

Are you using dm-crypt for an encrypted device?

If not, reboot.

If so, create an installer medium in case you have problems.

Actually - just create an installer medium and then you’re ready no matter what.