Inadyn does only update my IP the first time


I don’t know in which community/board/topic to post, so I try it here. I am open for hints where I should place such questions in the www at all.

I have running a server at home. I use the tool “inadyn” in version 2.7. to update regularly my local ip at my dynamic-dns-provider. The problem is, that inadyn only updates the ip the first time, when I start inadyn. When the ip address changes (e.g. reconnect to the internet on my router), inadyn recognizes, but does not update the ip (/or sends a request).

In the status of the inadyn service you see:

  1. at 19:47:21 the system started and the ip was send to my dyn-dns-provider and was updated. so this is the prove everything regarding the request to my dyn-dns-provider is working correctly.
  2. at 20:27:25 the new ip was recognized, also the cache-file is updated, but no request was send to my dyn-dns-provider.
wolf@wolf-desktop:~$ sudo systemctl status snap.inadyn.daemon.service
[sudo] Passwort für wolf: 
● snap.inadyn.daemon.service - Service for snap application inadyn.daemon
     Loaded: loaded (/etc/systemd/system/snap.inadyn.daemon.service; enabled; vendor preset: disabled)
     Active: active (running) since Wed 2021-12-29 19:47:21 CET; 1h 7min ago
   Main PID: 5463 (inadyn)
      Tasks: 1 (limit: 9402)
     Memory: 4.7M
        CPU: 184ms
     CGroup: /system.slice/snap.inadyn.daemon.service
             └─5463 /snap/inadyn/335/usr/sbin/inadyn -n -s -f /var/snap/inadyn/335/inadyn.conf --cache-dir=/var/snap/inadyn/335/cache -P /var/snap/inadyn/335/

Dez 29 19:47:21 wolf-desktop systemd[1]: Started Service for snap application inadyn.daemon.
Dez 29 19:47:21 wolf-desktop inadyn[5463]: In-a-dyn version 2.7 -- Dynamic DNS update client.
Dez 29 19:47:21 wolf-desktop inadyn[5463]: Update forced for alias, new IP#
Dez 29 19:47:21 wolf-desktop inadyn[5463]: Updating cache for
Dez 29 20:27:25 wolf-desktop inadyn[5463]: Update needed for alias, new IP#
Dez 29 20:27:26 wolf-desktop inadyn[5463]: Updating cache for

I tried this configuration on Ubuntu Server and Manjaro. Same result. On both system inadyn is installed via snap.

Can anybody help where I try to start to search for the problem?

If it’s the same on Ubuntu, it ia not a Manjaro specific error and something with the program itself.

The Github repo seems active: GitHub - troglobit/inadyn: Dynamic DNS client with SSL/TLS support