In Cinnamon & xfce openrc Unstable updates

unstable
cinnamon
xfce

#1

The openrc updates this afternoon have broken permissions in “manjaro-settings manager” and the “printer” applet.
Adding gksu to start these works.

Have used your 17.01 xfce openrc iso after 255 updates and installing manjaro-printer & manjaro-pulse print-applet worked.
Changing from stable to unstable has caused the problem detailed above. This suggests it was something in the last updates that is causing the problem.

upgraded expat (2.2.0-2 -> 2.2.1-1)
[2017-06-30 19:59] [ALPM] upgraded libelogind (229.6-1 -> 231.3-1)
[2017-06-30 19:59] [ALPM] upgraded dbus-elogind (1.10.18-1 -> 1.10.18-2)
[2017-06-30 19:59] [ALPM] upgraded libutil-linux-nosystemd (2.29.2-2 -> 2.30-2)
[2017-06-30 19:59] [ALPM] upgraded elogind (229.6-1 -> 231.3-1)
[2017-06-30 19:59] [ALPM] upgraded llvm-libs (4.0.0-3 -> 4.0.1-1)
[2017-06-30 19:59] [ALPM] upgraded xkeyboard-config (2.21-1 -> 2.21-2)
[2017-06-30 19:59] [ALPM] upgraded util-linux-nosystemd (2.29.2-2 -> 2.30-2)
[2017-06-30 19:59] [ALPM] upgraded exo (0.10.7-2 -> 0.11.3-1)
[2017-06-30 19:59] [ALPM] upgraded git (2.13.1-1 -> 2.13.2-1)
[2017-06-30 19:59] [ALPM] upgraded libgtop (2.36.0-1 -> 2.36.0+2+ge0f97e7d-1)
[2017-06-30 19:59] [ALPM] upgraded libgcrypt (1.7.7-1 -> 1.7.8-1)
[2017-06-30 19:59] [ALPM] upgraded gksu (2.0.2-5 -> 2.0.2-6)
[2017-06-30 19:59] [ALPM] upgraded libnl (3.2.29-2 -> 3.3.0-1)
[2017-06-30 19:59] [ALPM] upgraded hplip (3.17.6-1 -> 3.17.6-2)
[2017-06-30 19:59] [ALPM] upgraded inxi (2.3.20-1 -> 2.3.23-1)
[2017-06-30 19:59] [ALPM] upgraded iso-codes (3.74-1 -> 3.75-1)
[2017-06-30 19:59] [ALPM] upgraded lib32-libgcrypt (1.7.7-1 -> 1.7.8-1)
[2017-06-30 19:59] [ALPM] upgraded lib32-llvm-libs (4.0.0-1 -> 4.0.1-1)
[2017-06-30 19:59] [ALPM] upgraded libevent (2.0.22-4 -> 2.1.8-1)
[2017-06-30 19:59] [ALPM] upgraded libx264 (2:148.20170519-1 -> 2:148.20170521-1)
[2017-06-30 19:59] [ALPM] upgraded mkinitcpio-busybox (1.25.1-2 -> 1.26.1-1)
[2017-06-30 19:59] [ALPM] upgraded linux49 (4.9.34-1 -> 4.9.35-1)
[2017-06-30 19:59] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2017-06-30 19:59] [ALPM] upgraded linux49-nvidia (1:375.66-8 -> 1:375.66-9)
[2017-06-30 19:59] [ALPM] upgraded linux49-r8168 (8.044.02-9 -> 8.044.02-10)
[2017-06-30 19:59] [ALPM] upgraded nano (2.8.4-1 -> 2.8.5-1)
[2017-06-30 19:59] [ALPM] upgraded nfs-utils (2.1.1-3 -> 2.1.1-4)
[2017-06-30 19:59] [ALPM] upgraded opus (1.2-1 -> 1.2.1-1)
[2017-06-30 19:59] [ALPM] upgraded texinfo (6.3-2 -> 6.4-1)
[2017-06-30 19:59] [ALPM] upgraded wpa_supplicant (1:2.6-6 -> 1:2.6-7)
[2017-06-30 19:59] [ALPM] upgraded xarchiver (0.5.4.10-1 -> 0.5.4.11-1)
[2017-06-30 19:59] [ALPM] upgraded xfce4-screenshooter (1.8.2-3 -> 1.9.1-1)
[2017-06-30 19:59] [ALPM] upgraded xfdesktop (4.12.3-3 -> 4.12.4-1)

list of packages updated

@philm @artoo


Manjaro OpenRC 17.0.2 Xfce ISO [beta]
#2

There’s an elogind update in unstable now (231.4) that sounds like it fixes some permissions issues: https://github.com/elogind/elogind/issues/20

See if it solves this for you…


#3

Yes the update of elogind and libelogind have fixed the problem.


closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.