In a Manjaro dual booted with Windows why is grub not displaying at startup?

No - the bootorder in the BIOS is relevant in your case.
The Disk containing Manjaro must be the “first boot device” in BIOS

.
.
The trick is: GRUB on the manjaro partition starts manjaro OR windows,
starting the Windows-partition ignores manjaro completely.
→ boot option #1 Manjaro
→ boot option #2 Windows

means: BootCurrent is manjaro - this will boot first.
But only, if the BIOS starts the GRUB entry - this is on another partition as windows!
===> Your BIOS-BootOrder starts Windows first. There is no GRUB on this Partition,
only Windows-Loader.
.
If Manjaro is the first BIOS-Boot-Order, the System finds GRUB and obeys to efibootmgr entries…
.
EFI of windows and EFI of Manjaro - you probably have two efi Partions
– BUT Windows does not like “no-windows” entries afaik may complain about or delete silently…
So starting the PC from Linux bootloader is the easier way.

My understanding is that you have Windows and Manjaro installed onto a single disk. The problem is choosing the boot OS and you are asking if having 2 EFI partitions can be the problem that you are experiencing. AND how to fix it.

The wiki for Manjaro UEFI install uses a single EFI partition. Try it if you are able to. Instead of creating new efi on sda8 just set the mount point to sda2 during installation.

**note** If you are re-using your EFI partition (that was created by Windows previously (or any other OS), then there is no need to format. Formatting will wipe the previous bootloader. Only mounting the EFI partition as **/boot/efi** is required in that case.

https://wiki.manjaro.org/index.php/UEFI_-_Install_Guide

Check this: https://unix.stackexchange.com/questions/659828/grub-selection-menu-is-working-but-not-visible

For available video drivers: cat /boot/grub/x86_64-efi/video.lst

2 Likes

SOLVED

I tried all the provided solutions but, nothing was working. Then I lost all hope and just went ahead, deleted all partitions, installed Manjaro over the whole drive and got rid of windows.

To my horror, grub still did not open. Luckily, I found this link: https://askubuntu.com/questions/182248/why-is-grub-menu-not-shown-when-starting-my-computer

And following the link I added

echo "videoinfo"

to the top of my /etc/grub.d/00_header

This seems to have solved the issue and the grub opens normally. Now, I’m not sure if the same solutions would’ve worked when in dual boot but, anyways, there you have it!

Thanks a lot @maycne.sonahoz , @zbe , @FeB , @GaVenga , @scorpp13 for your help. You guys were very helpful.

2 Likes

There are many solutions in the Forum, the Search Function will help…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.