Impossible installation on HP 455 G7, AMD Renoir 4500u

Hi @megavolt I would like to thank you for trying helping me, but I’m close to give-up.
It seems to be too early for this notebook. On the other side I’m lacking to get the right logs, while manjaro-chroot is not available to be used via Architekt installer. Manjaro is repeatedly not starting (neither graphic installaller USB nor installed Manjaro on notebook) whatever GRUB settings and parameters have been set. I gave a try to endeavorOS (Arch based) with same result. The only Linux so far with limited success ist Xubuntu, which at least is presenting a desktop beside many many error messages due to old kernel and whats most important: its not rolling. Maybe I should wait for 12 month or so, or at least until linux-hardware indicates some level of maturity.

My experience with installing Manjaro (KDE) on this hardware on a friends new laptop was quite different from yours. Manjaro was among the few distributions* that worked flawless.
If I remember correctly I did an architect-installation and definitely chose kernel 5.8.
You want the newest available stable kernel and firmware for this new hardware.

Installing alongside Windows 10, I had to hack the windows bootmanager as described in the dual-boot-tutorial (mentioned above):
bcdedit /set {bootmgr} path \EFI\manjaro\grubx64.efi
Otherwise Win10 messed up the boot-configuration regularly.

*I tried several, before settling down with Manjaro and MX-KDE-AHS as a second choice.

Hi @Friedrich1,
this is good news, means there should be a way …

The Dual-boot setup works fine, no errors during installation wth Architect (which performs basically fine). GRUB is working fine as well, just out of the box wth no malnual adjustments required: Windows starts no problem and performs like a charm, Manjaro shows the usual “drive/partition data” in the first line and then goes black. I assume just after graphic is initialized. It’s not possible to interact anymore (no other TTY etc.). The Architect is as well only starting through with GRUB parameter “nomodeset”, w/o that it hangs already when starting Architect in my case.

If you could get some information about the friends machine, I would love to verify some details:

  • Which model precisely?
  • Intel or AMD?
  • BIOS Version?
  • any specific BIOS settings (beside secure-boot off)
  • Any boot parameter nessecary?
  • what GPU?
  • dual boot setup wth windows?

I started to setup as a Manjaro only system. Above mentioned problems appeared an I just wanted to confirm what the problem is. So I installed Win10Pro with really no issues at all.

Still I’m lost and about givin up… loosing my daiy driver because Win is only for few games and programs which require Windows only.

  • Which model precisely?

Same as yours, I think:

  • Intel or AMD?

AMD 4500U

  • BIOS Version?

The latest (the previous (first one) worked as well)

  • any specific BIOS settings (beside secure-boot off)

Nothing that I remember. Apart from disabling wake up by LAN, USB,
which probably does not matter.

  • Any boot parameter nessecary?

This parameter is in the /boot/grub.cfg:
linux […] quiet udev.log_priority=3
But I am pretty sure not having added that myself.

  • what GPU?

Same as yours

  • dual boot setup wth windows?


I started to setup as a Manjaro only system.

I started with the win10 installation and let win10 do its default partitioning (3 partitions)

*(checked directly on my friends laptop via an anydesk connection)

Thats really weired. You are right, thats identically beside the BIOS update which was performed as one initial idea to fix the problems… After havin no success installing Manjaro as first step, I build the system then first with Win10 and Manjaro as the second, similar to your setup. The Grub parameter are the default ones. If Windows wouldnt run so smoothly, I would expect a hardware error on my machine as everything seems really same, beside the difference that my machine is rejecting any kind of linux beside poor running xubuntu.
Thank you for checking and confirming! Any idea or recommendation?

The nessecity of “nomodeset” indicates to me that here are issues with the graphics. But what?

Probably right.
I checked again on the friends laptop and you might want to check if these packages are installed:
linux-firmware (at the moment: 20200901)
linux-latest (kernel; at the moment: 5.8.1)

Good luck!
Bedtime for now…

Encouraged by your postings I deleted the existing Manjaro partition to make a clean reinstall (leaving the running Windows). As well I didnt put the “nomodeset” as additional start parameter in the Grub setting of Architect. The result ist again that by already by booting Architect it hangs at this well known position:

Maybe by setting “nomodeset” again I could perform an installation, which mostlikely again will not work.

One idea came to my mind: Is there recently a new version of Architect out, which you may have used?

I just noticed, that you mentioned above you had problems starting the “normal” live-media.
That should not be the case, as far as i can see.
They worked without any problem here (KDE and KDE_minimal).
I installed Manjaro using architect, but by starting architect from a running live session!
So if this does not work for you, the laptop hardware is probably not the cause of it.
Maybe try another USB-stick (Thats what I guess you use) or even a different USB-port.
Or check if you correctly wrote the iso to the USB-stick.

Hi again,
yes you are right: The probs appear already starting the “normal” live-media.
That the laptop hardware is probably not the cause of it is my believe as Win10 performs wth no problems. I tried your recommendations:

  • Maybe try another USB-stick : used new one
  • different USB-port : used different one
  • correctly wrote the iso to the USB-stick : This time used Rufus(Win) instead of dd(old machines Manjaro)

Additionally I included manually the packages

  • mhwd-amdgpu
  • xf86-video-amdgpu
  • linux-firmware (at the moment: 20200901)
  • linux-latest (kernel; at the moment: 5.8.1)

As a result, after below message again (presumably after changing the graphic mode) the usual black screen and humming vent. No improvement unfortunately. :disappointed_relieved:

just came to my mind that there are maybe 2 differences:

  1. I try to use XFCE (but KDE failed earlier on as well)
  2. I’m no partitioning SWAP (no need, Flashmem doesnt like)

I dont know that makes a difference? Shouldnt, but…

have added on boot param kernel ( from grub (e) )

have also try to get TTY ( Ctrl + Alt + F2 to F7 )

Hi @stephane, interesting ideas.
I thought IOMMU=pt helps for virtualisation? I have problems to get the system itself up.
As mentioned above its not possible to get anything, also TTY is not available.

Do you use MBR or GPT partitioning?
Maybe it is because this was my first GPT/UEFI setup, but I remember to having had considerable difficulties to set up the install media AND Bios correctly for UEFI/GPT mode.
Does it matter if the install medium is started in UEFI mode?
In case of win10 it seems to be required for an GPT/UEFI installation.

Hi @Friedrich1, its GPT/UEFI. This offers flexibility on the number of partitions. My previous system was based on a 1TB HDD and I had to shuffle with extended Partitions. GPT/UEFI is nice and really usable, much better than I expected. The Windows has no issues at all wth the machine and even Manjaro/Grub did anything right - as far as I can see. I just made a (frustrated) comment at the website of the dealer, since the 2 weeks legal return time is gone, but I really dint expect such harsh problems. In the meantime I setup already 2 different Notebooks (friends) wth Manjaro(the same version & stick), all fine and smoothly. One was a dualboot as well. Maybe something really weired with my machine as Win10 still is OK.

Hi citaron, I used GPT/UEFI as well.
At some points I had the feeling the Bios acted a bit strange, like not showing all bootmanagers that efibootmgr found, but maybe that was due to some mess I made on the way.
I don’t remember though ever having had the symptoms that you experienced during installation.
So I hope its not a problem with your particular machine.
The biggest problem I had was Win10* interfering with the linux bootloader, resulting in GRUB finding no OS or booting directly into Win10.
But that was finally, -after 2 weeks not finding a solution-, fixed with the bcdedit-hack from the dual boot tutorial.

How is the state of affairs now?

*Apart from that it works flawless.

Hi @Friedrich1, I hesitate to dare to say it’s done. I experienced too many funny things, but situation is that I spent again some hours trying to figure out some useful Grub parameters. To make the long story short: Useless. Then I started to investigate the BIOS default settings one by one (this one has lot of options/not like Acer). After changing this from “all legacy” to “all UEFI” all started to work fine. Installation and booting system repeatedly.

Frankly speakin, I never looked at this “option rom” page. All I verified beforehand was Securuty (secure boot off), Boot, Options like that…
I first hesitated to set this as fixed, maybe I shoud have waited another day for that. BUT it looks great!!!
Now the work starts to put the data back tweak the system to the scheme I’m used to, as well as I hesitate here…
It was a great motivation @Friedrich1 as w/o your statement that it shoud run, I would not spent so much effort to find out whats wrong. Thank you!
Thanks as well to @megavolt and @stephane for ideas and guidance digging the problems

Glad your persistence paid off for you in the end… :slight_smile:

Yes and it’s still up an running :grinning:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.