Imac (mid 2011) Radeon HD 6750M backlight control

Hello,

I have mid 2011 Apple Imac A1311 (Full specs) with Radeon HD 6750M

$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]e

I have acpi_video0 (and nothing else) but it ignores all my changes in /sys/class/backlight/acpi_video0/brightness
I tried all of those grub options but still nothing

acpi_backlight=video
acpi_backlight=vendor
acpi_backlight=native

I tried solutions from https://forum.manjaro.org/t/solved-imac-27-mid-2011-radeon-hd-6770m-brightness-control/88672/5 too, didn't work for me (because of different GPU, I guess).

any ideas ?
thanks!

Hello,
Try the one from here
https://wiki.archlinux.org/index.php/IMac_Aluminum#Brightness_control_on_a_2011_27_inch_iMac

Or try to use acpi_backlight=none as KBP. You need powerdevil installed if you are on KDE Plasma and you installed id different than the official ISO.

Thanks for reply,

I tried acpi_backlight=none a minute ago and then I have nothing in /sys/class/backlight/, even acpi_video0 is gone.

I'm running openbox and official arch install.

I read that arch imac wiki page, my problem is that I never got radeon_* appear in /sys/class/backlight and I'm using GRUB2 (non Legacy). Wonder if there is any way to control that backlight booting from GRUB2

Then please remove my suggestion from KBP and reboot, then from terminal provide
cat /sys/class/backlight/acpi_video0/max_brightness
Also, what backlight utility are you using?

$ cat /sys/class/backlight/acpi_video0/max_brightness
15

I just do # echo 5 /sys/class/backlight/acpi_video0/brightness , but sadly no effect.

Because you have to use:
echo 5 | sudo tee /sys/class/backlight/acpi_video0/brightness
Is that working?

nope, still not effect on screen brightness
thanks for your help

Ok, but now we are back to your linked topic here

If you did not used the proper command when you tried it, then it failed. Now the proper command failed because you did not had the proper kernel boot parameter.
See the issue now?

No problem.

I understand what you mean, I tried radeon.dpm=0 acpi_backlight=vendor now + correct way to change brightness value but there is nothing in /sys/class/backlight/

Will try
acpi_backlight=video acpi_backlight=vendor acpi_backlight=native those one-by-one now.
thanks

But just to make sure, are both in the correct place ?

I add it in grub menu by editing the line (adding the text) with root=UUID=* and then press F10 to boot with those settings. is it correct way ?

Sounds ok, yes, when you just want to test it. Then i'm afraid there must be something else i can't guess right now. Have you also tried with different kernels?

No, i didn't try different kernels.
My only guess would be Legacy Grub as it's written here https://wiki.archlinux.org/index.php/IMac_Aluminum#Brightness_control_on_a_2011_27_inch_iMac
but i really would like to avoid it :expressionless:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by