iMac 5.1 (Late 2006)



Check if all amdgpu stuff is removed.


Hi Eugen,

Thank you for your attention.

What do you mean?

Last time it was fresh installation.
With default (automatic) settings it freezes at switching from 32bit EFI framebuffer to 64bit radeon fb (as it seems to me).
Just replacing video-ati with video-vesa or disabling radeon kernel module with ‘nomodeset’ (or radeon.modeset=0’) helps to unfreeze booting but LDM fails to start in that case.

So where should I look for ‘amdgpu stuff’?

BTW, I’ve tried to run ‘mkinitcpio’ with and without MODULES="amdgpu radeon’, the result is the same.
Also I’ve tried the debian kernel 4.7.something the result is the same with one exception. There is no need to install something additional to start X after disabling modesetting. It loads Gallium module as in the case of Virtualbox VM.
(One more exception they use simplefb instead of efifb, maybe it’s just a different names)

Seems the problem somewhere in switching between fb with different ‘bit size’ because in the Legacy mode the fb switching works painless.


Read my post as "… if any amdgpu settings were applied or any amdgpu packages were installed."
pacman -Ss amdgpu | grep installed
grep -r -i "amdgpu" /etc
But from your description it shouldn’t be the case.


‘mhwd-amdgpu’ installed but it’s required by ‘mhwd-db’ which is required by 'mhwd’
Should I remove all of them?

btw, while boot with “nomodeset 3” I’ve tried manually unload/load modules:

$sudo modprobe -rv drm radeon   
    (drm failed to unload)
$sudo modprobe -v drm debug=1     
$sudo modprobe -v radeon modeset=1 
   ( freeze on insmod ...)

On next boot found the following error messages:

kernel: radeon 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xa3a3
kernel: radeon 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0x2323
kernel: [drm:radeon_get_bios [radeon]] *ERROR* Unable to locate BIOS ROM
kernel: radeon 0000:01:00.0: Fatal error during GPU init


No no, don’t remove that one.


See here for that error. You are near solution.
You’ll need a bootloader other than grub the giant.


Thanks, I’ll check.
BTW, somewhere in the KaOS forum I saw the solution to create an empty space of 32Mb at the beginning of the hdd. I suppose for the legacy boot of Linux



Seems I’ve found out the solution.
See p. 13 (convert the Master Boot Record (MBR) to a hybrid)