iMac 5.1 (Late 2006)

uefi
radeon

#1

Hello,

I’ve tried to install Manjaro XFCE on the iMac 5.1 (2006 Late) without success.
iMac 5.1 supports 64bit kernel but has 32bit EFI (yes, this is Apple).

When I tried to boot from 64bit edition (USB stick) I’ve got the following error message:

Starting bootx64.efi
Error: Unsupported while loading bootx64.efi

BTW ‘option’ key does not work with 64-bit edition USB stick, only rEFIt

With 32bit edition USB stick I can boot with ‘option’ key, but not far than grub menu.
While starting the ‘Live Manjaro’ the process stops at the following stage:

GPU free selected
[ 6.791283] Failed to find cpu0 device node
starting version 234

GPU nonfree selected
[ OK ] Started TLP system startup/shutdown.

I’ve tried to repack 64bit edition ISO image by adding ‘bootia32.efi’ to the efi/boot directory, but seems I missed some keys for mkisofs command. The system didn’t recognize image as bootable.

Any suggestions?

brg,
Serhiy.


Installing on Mac Mini 2006 Core Solo
#2

There was a time when netkas used to have some solution for different models of apple desktops/laptops and there was something about a firmware for iMac 4,1 to iMac 5,1 to unlock some features. Seems like you have a late model of iMac 5,1 2006 and this should have at least core 2 duo with the latest 1.2 firmware.
If you follow this https://mattgadient.com/2016/07/11/linux-dvd-images-and-how-to-for-32-bit-efi-macs-late-2006-models/
where the ARCH is mentioned, there is an iso to download. It might help.
Also some people use to make the older apple desktops boot from uefi32 using PLOP, for any linux in 64bit. You will need 2 boot medias: one with the linux distro you want to install, and one with PLOP from here https://www.plop.at/
Once in PLOP you select the linux install USB and all should be as a normal install.


#3

Thanks, I’ll study links provided by you.


#4

I already saw the first link. No luck with it.
May be because of USB stick and I should try to use the CD/DVD.
On the other side I had boot the grub (32bit edition of manjaro iso) but the kernel is failed to boot.


#5

I was having this problem just yesterday. I never did get a flash drive to work, but a disk works fine if you apply the fix mentioned in the first post.
The way I understand it, the manjaro iso’s have both EFI and BIOS modes to boot from. EFI on late-2006 macs don’t understand that format. However, when it asks you to choose one, there is no keyboard driver, so it can’t get the input from the user. The C program that guy provides simply removes the EFI boot, and then the Mac 32-bit EFI will boot it in BIOS compatibility mode just fine.


#6

There is a post over here with someone else also making an attempt.


#7

Hi,

How do you boot Manjaro after installation complete?
I stuck with ‘no boot device’ after selecting ‘Boot Linux from HD’ in the rEFIt menu.
Also I’ve tried to grub-install --target=i386-efi but got an error about missing some files somewhere under /usr.
My try to install grub2-i386-efi-git also has failed.


#8

Could you post the error? My guess is that if you fix that you’ll be closer to fixing your problem.

It’s also likely that I’ll end up with this problem once I get my RAM upgrade complete…


#9

Yes, I can :slight_smile:

$ yaourt -S grub2-i386-efi-git

grub_reboot in reboot is duplicated in kernel
make[1]: *** [Makefile:45149: moddep.lst] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp-sadmin/aur-grub2-i386-efi-git/src/build-i386-efi/grub-core’
make: *** [Makefile:24968: all] Error 2
==> ERROR: A failure occurred in build().
Aborting…
==> ERROR: Makepkg was unable to build grub2-git.
==> Restart building grub2-i386-efi-git ? [y/N]

Which files the grub-install places to /boot/efi/ ?
May be it’s not a bad idea to copy them manualy from the 32bit ISO image?


#10

Did you manual partition?
Even though its EFI, this funny machine probably wants MBR not GPT.

(That guide above is specifically for setting up a 64 bit install.
In that case the machine is 64 bit so you want 64 iso … its just that the EFI is in 32 :flushed: .
But here we actually have a 32 bit cpu so it doesnt necessarilly apply to you samwise)


#11

Okay, let me try to make all stuff clear :wink:

We have two type of the original Manjaro Live CD (MLCD) - 32 and 64 bit, and two modified by ‘isomacprog’ prog.
I have an old imac 5,1 (2006 Late) with 32 bit EFI and 64 bit cpu (Core2Duo).

Attempts to boot:

  1. Original 32bit MLCD and EFI: grub is okay, but when you try to load the kernel it says something like ‘Failled to find cpu0 node’
  2. Original 32bit MLCD and Legacy BIOS: it asks to chose CD type (‘1’ or ‘2’, under some conditions - more precisely ‘1 BIOS’ or ‘2 EFI’) but you can not chose because keyboard does not work no that stage.
  3. Original 64bit MLCD and EFI: it says something like usupported grubx64.efi
  4. Original 64bit MLCD and Legacy BIOS: see ‘2’
  5. Modified 64bit MLCD and Legacy BIOS: success, grub is okay and kernel is okay. So we have the possibility to start installation, chroot the system and so on.
  6. Modified 32bit MLCD and Legacy BIOS: to be honest I do not remember what the result was, I assume that similar to ‘1’

So I installed the system but I can not boot it nor under EFI neither Legacy BIOS mode.
But I can ‘chroot’ it under MLCD.

(Next I am writing on memory because I do not have access to the system at this time)

/dev/sda partitions:
1 EFI (Apple origional)
2 OS X
3 Recovery

  • 128 MB gap
    4 fat32 /boot
    5 linux swap
    6 ext4 /(root)
    7 ext4 /home

I’m not sure whether it the correct way but I’ve chose to use the following partitions mount scheme:

/dev/sda4 to /boot
/dev/sda1 to /boot/efi

I realize that I have to install 32bit bootloader (or whatever you call it) but it’s missing at the 64bit MLCD, so I chrooted the system under MLCD and tried to install ‘grub2-i386-efi-git’ from the AUR. No luck (see my prev. post).
After that I manually copied ‘/boot’, /boot/efi’ from the 32bit MLCD accordingly to /dev/sda partitions and completed ‘grub-update’ in the ‘chroot’ environment.

And now

  • when I try to boot from the Legacy BIOS mode (from the MLCD’s grub or rEFIt or with ‘option’ key: hd0,gpt6) it says `No bootable device, please insert…’
  • when I try to boot from EFI grub goes to the ‘rescue>’ cli whith error about filesystem (unrecognized or unsupported…)

I assume that something wrong with the ‘grub’ configuration.

That’s all folks :slight_smile:


#12

I’m going to study the following doc:
http://www.rodsbooks.com/refind/installing.html#nolinux


#13

I have some progress :slight_smile:
I replaced rEFIt with rEFInd. Chrooted to the installed manjaro from the live cd and copied ‘i386-efi’ directory from the ‘manjaro-xfce-17.0.5-stable-i686.iso’ to the '/usr/lib/grub’
After that the following commands were completed:

sudo grub-install --target=i386-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
sudo update-grub
(grub-mkconfig -o /boot/grub/grub.cfg - on the next reboot)

Regadless of messages:

efibootmgr -v
EFI variables are not supported on this system.

rEFInd recognized the .efi files and grub successfully booted. That’s all :wink:
When I tried to boot the kernel I’ve got the following error messages:

starting version 234
ERROR: resume: hibernation device 'UUID=a831ff69-773b-44dc-a822-deacfd692510' not found
ERROR: device 'UUID=900b982e-53e9-4ebd-8c46-c7749ced8707' not found. Skipping fsck.
mount: /new_root: can't find UUID=900b982e-53e9-4ebd-8c46-c7749ced8707.
You are now being dropped into an emergency shell.
sh: can't access tty; job control turned off
[rootfs ]#

blkid shows nothing or /dev/sr0 when Live CD is inserted.
Seems grub or systemd or whatever lacks of driver and can’t find the hdd

Any ideas?

Outputs from the chrooted env.:

$ lsblk -f
NAME   FSTYPE  LABEL        UUID                                 MOUNTPOINT
sda          x`                                                    
├─sda1 vfat    EFI          4646-150A                            /mnt/boot/efi
├─sda2 hfsplus Macintosh HD 4eb080fd-b4a2-335f-bd94-acf56cd73c44 
├─sda3 hfsplus Recovery HD  7b12469b-ca32-33b7-a9f9-9b31df5f5381 
├─sda4 ext4                 23cb51f7-25aa-4a59-8b85-b312b3b1263a /mnt/boot
├─sda5 swap                 a831ff69-773b-44dc-a822-deacfd692510 [SWAP]
├─sda6 ext4                 900b982e-53e9-4ebd-8c46-c7749ced8707 /mnt
└─sda7 ext4                 1a4d64bf-402f-4805-90e9-38a8c8075e99 
$ ls -1 /sys/firmware/
acpi
dmi
memmap
# grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found Intel Microcode image
Found linux image: /boot/vmlinuz-4.9-x86_64
Found initrd image: /boot/initramfs-4.9-x86_64.img
Found initrd fallback image: /boot/initramfs-4.9-x86_64-fallback.img
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Found Mac OS X on /dev/sda2
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

#14

Update.
Tried to run ‘pacman -S linux’ in the chrooted env., does not help. Still have ‘device not found’.


#15

Update.
After googling awhile I did the following:

  1. Chrooted again.
  2. Updated the system:
    pacman -Syy
    pacman -Syu
  3. Installed a couple of packages:
    pacman -S udev
    pacman -S mkinitcpio
  4. Edited ‘/etc/mkinitcpio.conf’ by placing ‘block’ to the 3rd positions among hooks:
    HOOKS=“base udev block …”
  5. Executed:
    mkinitcpio -p linux49
  6. Just in case upgraded grub:
    update-grub
  7. Reboot.

Yes, the ‘device no found’ errors has gone, but booting stops at the following stage:

starting version 234
/dev/sda6: clean, 244504/1572864 files, 1463139/6291459 blocks

That’s it, nothing else :wink:

And what am I supposed to do?
I’m even not sure what I have to Google ask :wink:


#16

I think it stopped there because there’s no driver to boot up with. Can you check driver do you have installed with this command?

mhwd -li

While at it, can you post the content of /var/log/pacman.log from your main system?


#17

Okay, I’ll post it.
Meanwhile I added ‘amdgpu radeon’ to the MODULE section of the /etc/mkinitcpio.conf and ‘/dev/sda/…’ disappeared, only ‘starting version…’ stay in place :slight_smile:

Also I’ve tried to boot with addition ‘pci=nomsi’ and ‘noapic’ to /etc/default/grub


#18

Installed drivers:

Live CD:

$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
             video-ati            2017.03.24                true            PCI


Warning: No installed USB configs!

Chrooted env.:

# mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
   network-broadcom-wl            2015.12.13                true            PCI
             video-ati            2017.03.24                true            PCI


Warning: No installed USB configs!

/var/log/pacman.log (chrooted env.):

[2017-09-28 22:21] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /opt/pacman-mhwd.conf --root / --needed -Sy linux49-broadcom-wl'
[2017-09-28 22:21] [PACMAN] synchronizing package lists
[2017-09-28 22:21] [ALPM] transaction started
[2017-09-28 22:21] [ALPM] installed linux49-broadcom-wl (6.30.223.271-41)
[2017-09-28 22:21] [ALPM] transaction completed
[2017-09-28 22:21] [ALPM] running 'systemd-update.hook'...
[2017-09-28 22:21] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /opt/pacman-mhwd.conf --root / --needed -Sy xf86-video-ati libva-mesa-driver libva-vdpau-driver mesa-vdpau lib32-libva-vdpau-driver lib32-mesa-vdpau'
[2017-09-28 22:21] [PACMAN] synchronizing package lists
[2017-09-28 22:22] [ALPM] transaction started
[2017-09-28 22:22] [ALPM] installed xf86-video-ati (1:7.10.0-1)
[2017-09-28 22:22] [ALPM] installed libva-mesa-driver (17.2.0-2)
[2017-09-28 22:22] [ALPM] installed libva-vdpau-driver (0.7.4-2)
[2017-09-28 22:22] [ALPM] installed mesa-vdpau (17.2.0-2)
[2017-09-28 22:22] [ALPM] installed lib32-libva (1.8.3-1)
[2017-09-28 22:22] [ALPM] installed lib32-libvdpau (1.1.1-2)
[2017-09-28 22:22] [ALPM] installed lib32-libva-vdpau-driver (0.7.4-5)
[2017-09-28 22:22] [ALPM] installed lib32-mesa-vdpau (17.2.0-1)
[2017-09-28 22:22] [ALPM] transaction completed
[2017-09-28 22:22] [ALPM] running 'systemd-update.hook'...
[2017-09-29 19:34] [PACMAN] Running 'pacman -S mtools os-prober'
[2017-09-29 19:34] [PACMAN] Running 'pacman -Sy'
[2017-09-29 19:34] [PACMAN] synchronizing package lists
[2017-09-29 19:34] [PACMAN] Running 'pacman -S mtools os-prober'
[2017-09-29 19:35] [ALPM] transaction started
[2017-09-29 19:35] [ALPM] upgraded manjaro-keyring (20170603-1 -> 20170919-1)
[2017-09-29 19:35] [ALPM-SCRIPTLET] ==> Appending keys from manjaro.gpg...
[2017-09-29 19:35] [ALPM-SCRIPTLET] key 5BD96CC4247B52CC:
[2017-09-29 19:35] [ALPM-SCRIPTLET] 1 signature not checked due to a missing key
[2017-09-29 19:35] [ALPM-SCRIPTLET] key CAA6A59611C7F07E:
[2017-09-29 19:35] [ALPM-SCRIPTLET] 3 signatures not checked due to missing keys
[2017-09-29 19:35] [ALPM-SCRIPTLET] key 363DFFFD59152F77:
[2017-09-29 19:35] [ALPM-SCRIPTLET] 1 signature not checked due to a missing key
[2017-09-29 19:35] [ALPM-SCRIPTLET] key 2B80869C5C0102A6:
[2017-09-29 19:35] [ALPM-SCRIPTLET] 2 signatures not checked due to missing keys
[2017-09-29 19:35] [ALPM-SCRIPTLET] key 8934292D604F8BA2:
[2017-09-29 19:35] [ALPM-SCRIPTLET] 1 signature not checked due to a missing key
[2017-09-29 19:35] [ALPM-SCRIPTLET] key 2C089F09AC97B894:
[2017-09-29 19:35] [ALPM-SCRIPTLET] 1 signature not checked due to a missing key
[2017-09-29 19:35] [ALPM-SCRIPTLET] key 137C934B5DCB998E:
[2017-09-29 19:35] [ALPM-SCRIPTLET] 1 signature not checked due to a missing key
[2017-09-29 19:35] [ALPM-SCRIPTLET] key 62443D89B35859F8:
[2017-09-29 19:35] [ALPM-SCRIPTLET] 1 signature not checked due to a missing key
[2017-09-29 19:35] [ALPM-SCRIPTLET] key DAD3B211663CA268:
[2017-09-29 19:35] [ALPM-SCRIPTLET] 1 signature not checked due to a missing key
[2017-09-29 19:35] [ALPM-SCRIPTLET] key 8DB9F8C18DF53602:
[2017-09-29 19:35] [ALPM-SCRIPTLET] 1 signature not checked due to a missing key
[2017-09-29 19:35] [ALPM-SCRIPTLET] key 17C752B61B2F2E90:
[2017-09-29 19:35] [ALPM-SCRIPTLET] 1 signature not checked due to a missing key
[2017-09-29 19:35] [ALPM-SCRIPTLET] key 8238651DDF5E0594:
[2017-09-29 19:35] [ALPM-SCRIPTLET] 1 signature not checked due to a missing key
[2017-09-29 19:35] [ALPM-SCRIPTLET] ==> Locally signing trusted keys in keyring...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 75C1B95A4D9514A57EB2DAE71817DC63CD3B5DF5...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 16DC688DF3EECC72323954237EC47C82A42D53A2...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 76C6E477042BFE985CC220BD9C08A255442FAFF0...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 2D14560CDCE6A75BB186DB758238651DDF5E0594...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key B4663188A692DB1E45A98EE95BD96CC4247B52CC...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 04BB537F5BC2D399BFA72F8F17C752B61B2F2E90...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 35B4FF23EA9477582C2A0AF12B80869C5C0102A6...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 77DC01C9971AC3C39A0626F72C089F09AC97B894...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 39F0EC1AE50B37E5F3196F09DAD3B211663CA268...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 7C89F4D439B2BFACF425107B62443D89B35859F8...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 22C903DE964E6FE321656E318DB9F8C18DF53602...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 5A97ED6B72418199F0C22B23137C934B5DCB998E...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 1E7908935AAB9A00D6B47503363DFFFD59152F77...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Locally signing key 74C2F2CC05A0AB7D859839938934292D604F8BA2...
[2017-09-29 19:35] [ALPM-SCRIPTLET] ==> Importing owner trust values...
[2017-09-29 19:35] [ALPM-SCRIPTLET] gpg: setting ownertrust to 4
[2017-09-29 19:35] [ALPM-SCRIPTLET] ==> Disabling revoked keys in keyring...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Disabling key FAA6840E8C3FC7F89BEE0DC8AC7AB10BCB6CDD17...
[2017-09-29 19:35] [ALPM-SCRIPTLET]   -> Disabling key 540DE7083B89314CF70EA6F0C1B1AD0DA80EBF3E...
[2017-09-29 19:35] [ALPM-SCRIPTLET] ==> Updating trust database...
[2017-09-29 19:35] [ALPM-SCRIPTLET] gpg: marginals needed: 3  completes needed: 1  trust model: pgp
[2017-09-29 19:35] [ALPM-SCRIPTLET] gpg: depth: 0  valid:   1  signed:  22  trust: 0-, 0q, 0n, 0m, 0f, 1u
[2017-09-29 19:35] [ALPM-SCRIPTLET] gpg: depth: 1  valid:  22  signed:  73  trust: 0-, 0q, 0n, 22m, 0f, 0u
[2017-09-29 19:35] [ALPM-SCRIPTLET] gpg: depth: 2  valid:  72  signed:  10  trust: 72-, 0q, 0n, 0m, 0f, 0u
[2017-09-29 19:35] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2017-10-20
[2017-09-29 19:35] [ALPM] transaction completed
[2017-09-29 19:35] [ALPM] running 'systemd-update.hook'...
[2017-09-29 19:35] [ALPM] transaction started
[2017-09-29 19:35] [ALPM] installed mtools (4.0.18-4)
[2017-09-29 19:35] [ALPM] reinstalled os-prober (1.76-1)
[2017-09-29 19:35] [ALPM] transaction completed
[2017-09-29 19:35] [ALPM] running 'systemd-update.hook'...
[2017-09-29 19:35] [ALPM] running 'texinfo-install.hook'...
[2017-09-29 19:40] [PACMAN] Running 'pacman -S efibootmgr dosfstools grub'
[2017-09-29 19:40] [ALPM] transaction started
[2017-09-29 19:40] [ALPM] reinstalled efibootmgr (15-1)
[2017-09-29 19:40] [ALPM] reinstalled dosfstools (4.1-1)
[2017-09-29 19:40] [ALPM] reinstalled grub (2.02.0-3)
[2017-09-29 19:40] [ALPM] transaction completed
[2017-09-29 19:40] [ALPM] running 'systemd-update.hook'...
[2017-09-29 19:40] [ALPM] running 'texinfo-install.hook'...
[2017-09-29 20:09] [PACMAN] Running 'pacman -S tree'
[2017-09-29 20:09] [ALPM] transaction started
[2017-09-29 20:09] [ALPM] installed tree (1.7.0-2)
[2017-09-29 20:09] [ALPM] transaction completed
[2017-09-29 20:09] [ALPM] running 'systemd-update.hook'...
[2017-09-30 10:30] [PACMAN] Running 'pacman -S linux'
[2017-09-30 10:31] [ALPM] transaction started
[2017-09-30 10:31] [ALPM] upgraded linux49 (4.9.50-1 -> 4.9.51-1)
[2017-09-30 10:31] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2017-09-30 10:31] [ALPM] transaction completed
[2017-09-30 10:31] [ALPM] running '90-linux49.hook'...
[2017-09-30 10:31] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'default'
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64.img
[2017-09-30 10:31] [ALPM-SCRIPTLET] ==> Starting build: 4.9.51-1-MANJARO
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-09-30 10:31] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-09-30 10:31] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64.img
[2017-09-30 10:31] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-09-30 10:31] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'fallback'
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64-fallback.img -S autodetect
[2017-09-30 10:31] [ALPM-SCRIPTLET] ==> Starting build: 4.9.51-1-MANJARO
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-09-30 10:31] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-09-30 10:31] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-09-30 10:31] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64-fallback.img
[2017-09-30 10:31] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-09-30 10:31] [ALPM] running '99-grub.hook'...
[2017-09-30 10:31] [ALPM-SCRIPTLET] Generating grub configuration file ...
[2017-09-30 10:31] [ALPM-SCRIPTLET] Found background: /usr/share/grub/background.png
[2017-09-30 10:32] [ALPM-SCRIPTLET] Found Intel Microcode image
[2017-09-30 10:32] [ALPM-SCRIPTLET] Found linux image: /boot/vmlinuz-4.9-x86_64
[2017-09-30 10:32] [ALPM-SCRIPTLET] Found initrd image: /boot/initramfs-4.9-x86_64.img
[2017-09-30 10:32] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.9-x86_64-fallback.img
[2017-09-30 10:32] [ALPM-SCRIPTLET] Found Mac OS X on /dev/sda2
[2017-09-30 10:32] [ALPM-SCRIPTLET] Found memtest86+ image: /boot/memtest86+/memtest.bin
[2017-09-30 10:32] [ALPM-SCRIPTLET] done
[2017-09-30 10:32] [ALPM] running 'systemd-update.hook'...
[2017-09-30 11:18] [PACMAN] Running 'pacman -Syy'
[2017-09-30 11:18] [PACMAN] synchronizing package lists
[2017-09-30 11:19] [PACMAN] Running 'pacman -Syu'
[2017-09-30 11:19] [PACMAN] synchronizing package lists
[2017-09-30 11:19] [PACMAN] starting full system upgrade
[2017-09-30 11:20] [ALPM] transaction started
[2017-09-30 11:20] [ALPM] upgraded boost-libs (1.64.0-4 -> 1.65.1-1)
[2017-09-30 11:20] [ALPM] upgraded device-mapper (2.02.173-1 -> 2.02.174-1)
[2017-09-30 11:20] [ALPM] upgraded exiv2 (0.26-1 -> 0.26-2)
[2017-09-30 11:20] [ALPM] upgraded fontconfig (2.12.5-1 -> 2.12.6-1)
[2017-09-30 11:20] [ALPM-SCRIPTLET] Rebuilding fontconfig cache... done.
[2017-09-30 11:20] [ALPM] upgraded fuse-common (3.1.1-1 -> 3.2.0-1)
[2017-09-30 11:20] [ALPM] upgraded fuse2 (2.9.7-3 -> 2.9.7-4)
[2017-09-30 11:20] [ALPM] upgraded libksba (1.3.4-2 -> 1.3.5-1)
[2017-09-30 11:20] [ALPM] upgraded gnupg (2.2.0-1 -> 2.2.1-1)
[2017-09-30 11:20] [ALPM] upgraded gsfonts (20170727-1 -> 20170829-1)
[2017-09-30 11:20] [ALPM] upgraded gstreamer (1.12.2-1 -> 1.12.3-1)
[2017-09-30 11:20] [ALPM] upgraded gst-plugins-base-libs (1.12.2-1 -> 1.12.3-1)
[2017-09-30 11:20] [ALPM] upgraded libpulse (11.0-1 -> 11.1-1)
[2017-09-30 11:20] [ALPM] upgraded llvm-libs (4.0.1-5 -> 5.0.0-1)
[2017-09-30 11:20] [ALPM] upgraded mesa (17.2.0-2 -> 17.2.1-3)
[2017-09-30 11:20] [ALPM] upgraded gst-libav (1.12.2-1 -> 1.12.3-1)
[2017-09-30 11:20] [ALPM] upgraded gst-plugins-bad (1.12.2+27+g2b8edd9c0-1 -> 1.12.3-1)
[2017-09-30 11:20] [ALPM] upgraded gst-plugins-base (1.12.2-1 -> 1.12.3-1)
[2017-09-30 11:20] [ALPM] upgraded jasper (2.0.13-2 -> 2.0.14-1)
[2017-09-30 11:20] [ALPM] upgraded gst-plugins-good (1.12.2-1 -> 1.12.3-1)
[2017-09-30 11:20] [ALPM] upgraded gst-plugins-ugly (1.12.2-1 -> 1.12.3-1)
[2017-09-30 11:20] [ALPM] upgraded imagemagick (6.9.9.13-1 -> 6.9.9.14-1)
[2017-09-30 11:20] [ALPM] upgraded inxi (2.3.38-1 -> 2.3.39-1)
[2017-09-30 11:20] [ALPM] upgraded lib32-libgcrypt (1.7.8-1 -> 1.8.1-1)
[2017-09-30 11:20] [ALPM] upgraded lib32-libpulse (11.0-1 -> 11.1-1)
[2017-09-30 11:21] [ALPM] upgraded lib32-llvm-libs (4.0.1-1 -> 5.0.0-1)
[2017-09-30 11:21] [ALPM] upgraded lib32-mesa (17.2.0-1 -> 17.2.1-1)
[2017-09-30 11:21] [ALPM] upgraded lib32-mesa-vdpau (17.2.0-1 -> 17.2.1-1)
[2017-09-30 11:21] [ALPM] upgraded libcdr (0.1.3-3 -> 0.1.4-1)
[2017-09-30 11:21] [ALPM] upgraded libcmis (0.5.1-6 -> 0.5.1-7)
[2017-09-30 11:21] [ALPM] upgraded libixion (0.12.2-2 -> 0.12.2-3)
[2017-09-30 11:21] [ALPM] upgraded libnm (1.8.3dev+18+gf43222d41-1 -> 1.8.4-1)
[2017-09-30 11:21] [ALPM] upgraded libnm-glib (1.8.3dev+18+gf43222d41-1 -> 1.8.4-1)
[2017-09-30 11:21] [ALPM] upgraded liborcus (0.12.1-2 -> 0.12.1-3)
[2017-09-30 11:21] [ALPM] upgraded libva-mesa-driver (17.2.0-2 -> 17.2.1-3)
[2017-09-30 11:21] [ALPM] upgraded linux49-broadcom-wl (6.30.223.271-41 -> 6.30.223.271-42)
[2017-09-30 11:21] [ALPM] upgraded lvm2 (2.02.173-1 -> 2.02.174-1)
[2017-09-30 11:21] [ALPM] upgraded man-pages (4.12-1 -> 4.13-1)
[2017-09-30 11:21] [ALPM] upgraded mesa-vdpau (17.2.0-2 -> 17.2.1-3)
[2017-09-30 11:21] [ALPM] upgraded nm-connection-editor (1.8.2-1 -> 1.8.4-1)
[2017-09-30 11:21] [ALPM] upgraded network-manager-applet (1.8.2-1 -> 1.8.4-1)
[2017-09-30 11:21] [ALPM] upgraded networkmanager (1.8.3dev+18+gf43222d41-1 -> 1.8.4-1)
[2017-09-30 11:21] [ALPM] upgraded pamac (6.0.0-1 -> 6.0.2-1)
[2017-09-30 11:21] [ALPM] upgraded pulseaudio (11.0-1 -> 11.1-1)
[2017-09-30 11:21] [ALPM] upgraded pulseaudio-bluetooth (11.0-1 -> 11.1-1)
[2017-09-30 11:21] [ALPM] upgraded pulseaudio-zeroconf (11.0-1 -> 11.1-1)
[2017-09-30 11:21] [ALPM] upgraded python-setuptools (1:36.4.0-1 -> 1:36.5.0-1)
[2017-09-30 11:21] [ALPM] upgraded s-nail (14.9.3-1 -> 14.9.4-1)
[2017-09-30 11:21] [ALPM] upgraded xf86-input-libinput (0.25.1-1 -> 0.26.0-1)
[2017-09-30 11:21] [ALPM] transaction completed
[2017-09-30 11:21] [ALPM] running '90-linux49.hook'...
[2017-09-30 11:21] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'default'
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64.img
[2017-09-30 11:21] [ALPM-SCRIPTLET] ==> Starting build: 4.9.51-1-MANJARO
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-09-30 11:21] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-09-30 11:21] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64.img
[2017-09-30 11:21] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-09-30 11:21] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'fallback'
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64-fallback.img -S autodetect
[2017-09-30 11:21] [ALPM-SCRIPTLET] ==> Starting build: 4.9.51-1-MANJARO
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-09-30 11:21] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-09-30 11:21] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-09-30 11:21] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64-fallback.img
[2017-09-30 11:21] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-09-30 11:21] [ALPM] running 'detect-old-perl-modules.hook'...
[2017-09-30 11:21] [ALPM] running 'fontconfig.hook'...
[2017-09-30 11:21] [ALPM] running 'glib-compile-schemas.hook'...
[2017-09-30 11:21] [ALPM] running 'gtk-update-icon-cache.hook'...
[2017-09-30 11:21] [ALPM] running 'systemd-update.hook'...
[2017-09-30 11:21] [ALPM] running 'texinfo-install.hook'...
[2017-09-30 11:21] [ALPM] running 'update-desktop-database.hook'...
[2017-09-30 11:21] [ALPM] running 'update-mime-database.hook'...
[2017-09-30 11:21] [ALPM] running 'xorg-mkfontdir.hook'...
[2017-09-30 11:21] [PACMAN] Running 'pacman -Syy'
[2017-09-30 11:21] [PACMAN] synchronizing package lists
[2017-09-30 11:22] [PACMAN] Running 'pacman -Syu'
[2017-09-30 11:22] [PACMAN] synchronizing package lists
[2017-09-30 11:22] [PACMAN] starting full system upgrade
[2017-09-30 11:22] [PACMAN] Running 'pacman -S udev'
[2017-09-30 11:22] [ALPM] transaction started
[2017-09-30 11:22] [ALPM] reinstalled systemd (234.11-8)
[2017-09-30 11:22] [ALPM-SCRIPTLET] Running in chroot, ignoring request.
[2017-09-30 11:22] [ALPM] transaction completed
[2017-09-30 11:22] [ALPM] running '90-linux49.hook'...
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'default'
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64.img
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Starting build: 4.9.51-1-MANJARO
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64.img
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'fallback'
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64-fallback.img -S autodetect
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Starting build: 4.9.51-1-MANJARO
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64-fallback.img
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-09-30 11:22] [ALPM] running 'systemd-hwdb.hook'...
[2017-09-30 11:22] [ALPM] running 'systemd-sysusers.hook'...
[2017-09-30 11:22] [ALPM] running 'systemd-tmpfiles.hook'...
[2017-09-30 11:22] [ALPM] running 'systemd-update.hook'...
[2017-09-30 11:22] [PACMAN] Running 'pacman -S mkinitcpio'
[2017-09-30 11:22] [ALPM] transaction started
[2017-09-30 11:22] [ALPM] reinstalled mkinitcpio (23-2)
[2017-09-30 11:22] [ALPM] transaction completed
[2017-09-30 11:22] [ALPM] running '90-linux49.hook'...
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'default'
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64.img
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Starting build: 4.9.51-1-MANJARO
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64-fallback.img
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-09-30 11:22] [ALPM] running 'systemd-hwdb.hook'...
[2017-09-30 11:22] [ALPM] running 'systemd-sysusers.hook'...
[2017-09-30 11:22] [ALPM] running 'systemd-tmpfiles.hook'...
[2017-09-30 11:22] [ALPM] running 'systemd-update.hook'...
[2017-09-30 11:22] [PACMAN] Running 'pacman -S mkinitcpio'
[2017-09-30 11:22] [ALPM] transaction started
[2017-09-30 11:22] [ALPM] reinstalled mkinitcpio (23-2)
[2017-09-30 11:22] [ALPM] transaction completed
[2017-09-30 11:22] [ALPM] running '90-linux49.hook'...
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'default'
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64.img
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Starting build: 4.9.51-1-MANJARO
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64.img
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'fallback'
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64-fallback.img -S autodetect
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Starting build: 4.9.51-1-MANJARO
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-09-30 11:22] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-09-30 11:22] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64-fallback.img
[2017-09-30 11:23] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-09-30 11:23] [ALPM] running 'systemd-tmpfiles.hook'...
[2017-09-30 11:23] [ALPM] running 'systemd-update.hook'...
[2017-09-30 16:43] [PACMAN] Running 'pacman -S xf86-video-amdgpu'
[2017-09-30 16:44] [ALPM] transaction started
[2017-09-30 16:44] [ALPM] installed xf86-video-amdgpu (1.4.0-1)
[2017-09-30 16:44] [ALPM] transaction completed
[2017-09-30 16:44] [ALPM] running 'systemd-update.hook'...

#19

From the looks of the logs, it seems you are trying to install xf86-video-amdgpu but you didn’t do it in using mhwd and removed video-ati with it causing video-ati still stuck from mhwd -li output…

Please try the following :

sudo pacman -Rns xf86-video-amdgpu
sudo mhwd -r pci video-ati
sudo mhwd -i pci video-ati

#20

Unfortunately does not helped.