I'm in Skype hell.

I have tried git, snap, AUR, and no matter what I do I cannot get Skype to execute. It installs fine, but that is it.

When I try to execute it from the CLI, it tells me nothing. In the case of sskype, it asks for my password and then executes. Nothing.

Please help me trouble shoot this. I have an interview tomorrow.

3 Likes

I have skypeforlinux-stable-bin from AUR and it works fine. The command to launch is skypeforlinux

1 Like

Thanks. That's what I'm saying. Nothing works. skypeforlinux at the cli certainly doesn't work.

Normally, I install skypeforlinux-stable-bin and secure-skype from the AUR repository and there are no problems.

I have no idea what is going on and I'm at a total loss on how to troubleshoot it.

I know this is an idiot suggestion, but have checked the system tray? Also, check if a skype process is running through a system tool (ex.: htop).

1 Like

Well i just installed skypeforlinux-stable-binused the menu entry fired up instantly plus icon in tray, shut it down and fired up again instant.
So i would look at @mbb reply before going on.

Hi. Thanks for the reply. I used htop, searched, and it's not running.

I did look at the system tray many times, including right after you suggested it: Nothing.

I've also restarted twice: Nothing. The Skype icon is sitting in my brisk menu: Internet. But nothing is working, including removing and installing again. (uninstalling and installing are not a problem. It simple won't execute no matter what.)

It's really weird and I can't figure it. Need expert help over here! :slight_smile:

  • Uninstall all of them properly.
  • Delete local folders of the program (user HOME and .config and .cache).
  • Install the AUR version (as others verify it's working fine).
  • Start program.

If you try another way, always clear local program files.

2 Likes

Given that this is time critical, how about you install Skype on your phone as a backup plan?
Should help piece of mind :slight_smile:

1 Like

Okay. Let me try that...

You can also download skype from here (RMP), unpack it to a folder and run. I used skype like this for a long time and it worked fine.

1 Like

are you sure? I'm not able to find it in my AUR...

1 Like

Sorry. skype-secure.

Okay. I've used mlocate to manually delete all skype files (except the icons). I'm going to reboot.

I will try the rpm way first.

If that fails, I'll build again from the "software center".

Here goes.

have you tried another user on this machine, and are you sure you are running it as root ? with your system updated?

I don't have another machine. Yes, I've tried with sudo and by logging in with su.

One thing that I remember is that last Friday I updated to the latest version of Skype and when I rebooted I've been in hell ever since. I've had to reinstall Manjaro like 5 times, each time checking sha1sum. But ever since then, I can't get Skype to execute and my weekend has been spent swearing.

Let me reboot and try again. I'll be back.

i mean... create another user on the same pc/laptop, then log in to that. and see if skype starts

and check for updates again after skype installation

this might be something else then. :worried:

2 Likes

I just tried skype stable and skype preveiw they appear to build but wont boot.

and i just tried with snap it downloads but wont boot

that also is not in my AUR, probably you downloaded from somewhere else,
do the cleaning as suggest by @AgentS and install the bin from AUR, should work unless

received an update today too, works fine here

@rbrick49 thats odd

@notageek i see that skype-secure in AUR

@marcbo as a last resort, prepare a different distro installer (install it side by side with manjaro), just in case, and use it for the interview and keep working on this skype later.

Never do this if it boots and runs. It can be harder to fix the problem because you loose the package history and logs.

1 Like

Forum kindly sponsored by