iGPU multi-monitor help

Hello!

I have an i3 8100 and a GTX 1060 6gb and I need help with iGPU multi-monitor. I have the option enabled in the BIOS and it works fine on Windows. However, I don't know how to set this up in Manjaro. And no, I don't have a notebook, I have a desktop.

Thanks.

Please provide the output from terminal of inxi -Fxxxz. Please be sure to use 3 ``` before and after the pasted content so it's easier to read. Or you can highlight the test and click the </> button. Thanks!

To get both working on desktop, you might have to remove the
/etc/X11/xorg.conf.d/90-mhwd.conf
and
/etc/X11/mhwd.d/nvidia.conf
files, if you installed the video-nvidia from MHWD
probably (not sure) you will have to use nomodeset kernel boot parameter.

There you go.

  Host: kitsune-pc Kernel: 4.19.62-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.1.0 Desktop: Budgie 10.5 info: budgie-panel wm: budgie-wm 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME B360M-A v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 0403 date: 04/18/2018 
CPU:
  Topology: Quad Core model: Intel Core i3-8100 bits: 64 type: MCP 
  arch: Kaby Lake rev: B L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 800 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
Graphics:
  Device-1: Intel 8th Gen Core Processor Gaussian Mixture Model 
  vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e91 
  Device-2: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Gigabyte 
  driver: nvidia v: 430.26 bus ID: 01:00.0 chip ID: 10de:1c03 
  Display: x11 server: X.Org 1.20.5 driver: nvidia compositor: budgie-wm 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 430.26 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Device-2: NVIDIA GP106 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f1 
  Sound Server: ALSA v: k4.19.62-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.047.02-NAPI port: 3000 bus ID: 04:00.0 
  chip ID: 10ec:8168 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.20 TiB used: 73.16 GiB (6.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST500LM012 HN-M500MBB 
  size: 465.76 GiB speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 0001 scheme: GPT 
  ID-2: /dev/sdb vendor: Samsung model: HD502HI size: 465.76 GiB 
  speed: 3.0 Gb/s serial: <filter> rev: 1118 scheme: MBR 
  ID-3: /dev/sdc vendor: Seagate model: ST320LM001 HN-M320MBB 
  size: 298.09 GiB speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 0002 scheme: GPT 
Partition:
  ID-1: / size: 283.46 GiB used: 73.16 GiB (25.8%) fs: ext4 dev: /dev/sdc2 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdc3 
Sensors:
  System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia temp: 31 C 
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0% 
Info:
  Processes: 209 Uptime: 4m Memory: 7.63 GiB used: 1.28 GiB (16.7%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.7 
  running in: gnome-terminal inxi: 3.0.35 ```

How do I do that? I'm totally noob.

Any help?

Some basics should be considered. Without you can end up with an unusable install/system.

The answer was somehow given already ...
There are two ways to alter system files. Because we talked about

You can navigate to that folder and Open as Administrator

Better keep a backup of the files by renaming them. nvidia.conf becomes nvidia.conf.BCK and 90-mhwd.conf becomes 90-mhwd.conf.BCK ... so in case something gets wrong, you can restore them.

Another way is from terminal:

sudo mv /etc/X11/xorg.conf.d/90-mhwd.conf /etc/X11/xorg.conf.d/90-mhwd.conf.BCK

and

sudo mv /etc/X11/mhwd.d/nvidia.conf /etc/X11/mhwd.d/nvidia.conf.BCK

Reboot after that.
In case you are not happy how that worked, or the system doesn't boot, you will have to restore the files from TTY, to get the system back as it was. To do that, at boot grub menu press e to edit. To the linux line you replace quiet with 3 then you press F10 to save and continue booting. It will drop you in TTY where you enter your name and password then run:

sudo mv /etc/X11/xorg.conf.d/90-mhwd.conf.BCK /etc/X11/xorg.conf.d/90-mhwd.conf

and

sudo mv /etc/X11/mhwd.d/nvidia.conf.BCK /etc/X11/mhwd.d/nvidia.conf

Now you have restored the files back to original state. Then run:
systemctl reboot
and that will bring you back to the system working as is now.

My suggestion is to disable the iGPU from BIOS, and use only the dGPU (Nvidia GPU) active, and connect your both monitors to your GeForce GTX 1060.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by