If using qt5gtk2 and/or qt6gtk2, Qt programs can't run after a version increase of Qt

After updating my packages just now and rebooting, I get the following output when trying to run qbittorrent:

[alex@alex-pc ~]$ qbittorrent
Cannot mix incompatible Qt library (6.2.2) with this library (6.2.3)
Aborted (core dumped)

I am using the official qbittorrent package and all Qt-related packages are also official; none from the AUR.

Edit: I figured it out. This is because I have qt5gtk2 and qt6gtk2 installed, using the qt5gtk2 platform theme. The fix is to clean-build qt5gtk2 and qt6gtk2. After doing so, qbittorrent opens as usual.

That are from AUR, so … But why going that road tho, what is the advantage of using something that was barely touched/updated in 2 years? And you will always have to rebuild those packages when Qtx will get updated …

The advantage is being able to use their functionality. Why else would someone use particular software?

In this case, I don’t know of other software that does exactly what this software does, which is accurately replicate the GTK theme in Qt. My various windows are themed consistently whether they’re using GTK or Qt, and it looks great.

Didn’t your post just proved that actually do not work? Also, you missed the point:

This days fot Qt5 applications is better to use qt5ct and for Qt6 applications the qt6ct with compatible and updated themes …

No. I think you must have misread something. After rebuilding after a Qt update, they work just fine.

I disagree. I tried that extensively for a couple weeks, experimenting with different themes and couldn’t find themes which matched correctly. Nothing else I tried could make the Qt widgets match my GTK theme in XFCE.

Don’t just put a facepalm emoji. Believe me. My desktop looks correct, is not broken, and rebuilding was the solution. It doesn’t make sense to disagree with that. qt6gtk2 is even mentioned on the Arch wiki, and research showed that it works with the QT_QPA_PLATFORMTHEME=qt5gtk2 variable, which is also used by qt5gtk2.

All the announcements have the “AUR packages” need a rebuild after a major update, of course that worked. Totally out of the point i was actually making. On you go on your way.