Identify W10 boot partition to overwrite it with GRUB

Hi,

Sorry to bother you again with GRUB problems, but I could not use my old topic for this problem.

So, my 250GB Samsung SSD is my Windows 10 and that Kingston 120GB is my Manjaro. This Kingston disk only have 1 partition, the manjaro. No swap, etc.
I formated my Windows 10 (so, the entire SSD, where was GRUB) and I need to reinstall GRUB. I think that /dev/sda2 is where I need to install GRUB, so I tried following this tutorial, but I got those error in this image:

I’m on live USB.
Thanks!

Right, since it’s formatted, the mbr is gone.
But you’ve now made your Samssung sda into a gpt disk.
The method in old links won’t work because your Manjaro Kingston (sdd1?) is on msdos and bios-legacy while your (old) sda is now in gpt and windows (most likely) in uefi.

Er…can you provide text output, not screen shots. Its’ difficult to … refer and copy and …

You have a 2 options.

  1. Convert your Kingston to gpt . But you will need to reinstall your Manjaro in uefi.
  2. Have a new Manjaro installation in your Samsung sda, this time in uefi.
    There is no benefit in having different distros in different disks (despite popular belief); in fact, for non-expert users, it can create more hassles. Reuse your Kingston as you see fit as your windows games, for example or a data store. Suggest you re-partition the Kingston as gpt, though not mandatory.
  3. Let your Kingston remain as is, in msdos with your Manjaro in it. And set a new mbr in that Kingston disk. Not in your Samsung drive. But…
    a. You will need to go to boot-setup (F8~F12) each time you want to boot up Manjaro (or windows - depending on how you set up your boot priority in bios-setup)
    b. Your grub will not be able to boot up your windows.

Let us know what you decide. But entirely up to you and it’s okay to go with what you want.

  1. Please be absolutely sure your windows is in uefi/gpt or not.
    Go to windows command as admin and type in …er…“msinfo32” - go from there. I’m not familiar myself. If confirmed it is uefi/gpt, while there, disable hiberfile and fastboot and secure boot.
    Er… I think windows command “powercfg /h off”.
  2. Boot up manjaro livecd in the mode (uefi/bios-legacy) you want (in your decision) and provide the following as text output (not screen shots). Remove unnecessary external extra drives. Remember since you have so many drives, always check if the mapping is what it is each time you boot up.
    test -d /sys/firmware/efi && echo UEFI || echo BIOS
    sudo parted -l
    sudo blkid
    efibootmgr -v
    Go to the livecd file manager and print out installed Manjaro OS /etc/fstab
  3. Let us know if your Kingston is an internal drive or an external drive (and any other internal drives). I assume your Samsung is internal. If not, shout out, it’s very important if it is not.

Oh, no bother, a beer is fine. Or a small donation to Manjaro. :grinning:
Cheers.

1 Like

Hi, thanks so much for your help, @gohlip. I’ll try my best to aswer your questions.
I have no problem reinstalling Manjaro, so I’ll go with this.

Using the msinfo32 command in Windows, I could see it was UEFI.
Here’s the output from those commands and here is the screenshot from Manjaro OS /etc/fstab (it is in the installed Manjaro [not live USB]).

The Kingston is an internal SDD drive. They all are internal drives (expect the flashdrive with Manjaro).

Thanks again.
I’ll for sure tip the Manjaro Team (not so much [poor student :frowning:]) . You guys were always so helpful and kind.

Since you said you’d reinstall, just go ahead.
Remember to boot up install media in uefi select $esp as mount point /boot/efi, do not format $esp
and good luck.

Oh, as to the donation part, I was just being light-hearted. As the head honcho himself said…

Manjaro was and always is an open project. We never asked for money and we are open for people to help us in any way. A donation is only an option to say thank you or support if that is the way the person wants to do so.

Cheers.

Pardon my ignorance, @gohlip, but I don’t know what you mean by “$esp as mount point /boot/efi, do not format $esp”. I use the Gnome version with the graphical installer. I don’t remember those settings.

If I try to start the Manjaro-USB in UEFI mode, the BIOS won’t let me boot because secure boot, I guess. I’ll try to delete the secure boot keys to see if the Secure Boot Options becames switchable (now is greyed out).

Thanks!

Edit: This is my boot menu and this is what it happens if I choose the UEFI Data Travaler option. After disabling secure boot mode, I choose the UEFI option and I get an unknown file system error. I tried installing Manjaro with the non-UEFI mode like usual, but the GRUB don’t show the Windows option.

Correct. if you install Manjaro in bio-legacy, it won’t show windows.

As said (and the screen says), you will need to disable secure boot.

So go to your bios-set-up (F2) and disable secure-boot.

It means you are going to reinstall Manjaro in uefi/gpt.

Let’s start again, but I cannot see your link (error: {“success”:false,“error”:404,“message”:“Not Found”}) where you suppose to provide command outputs.
Just copy and paste, okay here, not on links, please. No screen shots too. BTW, your screenshot of /fstab is from the livecd, not manjaro installed. Since I don’t have your partition layout (I cannot see) but you are going to reinstall anyway. I’ll put in my points here without knowing much about your partition set-up.

###################### START HERE #####################

  1. Disable secure boot
    Go to bios-set-up (F2), Find out how to disable ‘secure boot’ in your system. It should be in “Boot” or “Security” tabs. You may need to navigate around to find it. Either in “UEFI Boot” and see there is any place to “Disable Secure Boot”.
    If you cannot find, go to your computer website, google it and see how.
    If you cannot go past this step 1, you cannot install Manjaro in UEFI.
  2. Prepare partitions.
    Boot up Manjaro Gnome livecd, go to gparted.
    Choose your Kingston Drive.
    Then at “Device” tab on top of gparted gui, Click "Create Partition Table"
    At drop down menu, select "gpt"
    This will wipe all data in your Kingston.
    (I note you said both your Samsung and Kingston are internal drives - if wrong, shout now)
  3. Make partitions in Kingston as follows (in gparted).
    partition 1 - 150 MB, format as fat32.
    partition 2 - 60 GB, format as ext4
    partition 3 - 4 GB, select as swap partition.
    partition 4 - balance, format as ext4.
    Exit gparted.
  4. Boot up Manjaro livecd in UEFI.
    When booted up to livecd, ensure it is booted up in UEFI. At terminal,
    test -d /sys/firmware/efi && echo UEFI || echo BIOS
    If output says “BIOS”, you have booted up in bios-legacy. Reboot your livecd in UEFI.
    If output says “UEFI”, continue below.
  5. Start installation.
    Begin installation, at the part where we select disk, select your Kingston disk.
    Be very sure Kingston disk is selected.
    Then at the part to select mount points, select Kingston partitions as follows.
    partition 2 as “root” (/)
    partition 1 as “ESP” (/boot/efi)
    Be very sure ‘/boot/efi’ is selected as mount point, not ‘/boot’.
    partition 3 as “swap”
  6. Complete installation.
  7. Boot up Manjaro OS
    Boot up to Manjaro and at terminal,
    sudo pacman-mirrors -f 5
    sudo pacman -Syyuu
    sudo update-grub

########################## finish #######################

Ask if you have more questions.
Good luck. Cheers. (Beer on you).

2 Likes

Thanks again @gohlip, but I still can’t boot in UEFI and my Secure Boot is disabled and I still get this error. I went back to the Rufus software and change some settings to write the Manjaro ISO again. Here’s what it looked like before I hit READY. These are the Rufus options.

I was able to boot Manjaro-USB in non-UEFI mode and did the part 3.

Thanks again and sorry for the bother. :slight_smile:

I believe with rufus you need to set “Create a bootable disk using” to DD Image (not iso image). The newer versions of Manjaro isos require this for the bootable USB to work properly.

1 Like

Do you really want to continue installing Manjaro in bios-legacy (non-UEFI)?
If so, remember,

If you want to keep trying to install Manjaro in UEFI, others can help you with rufus. Oh… @cimarronline just did. Good of him. But if you can " I was able to boot Manjaro-USB in non-UEFI mode" it should not be a rufus problem, right @cimarronline ? but a secure boot problem.

@NeoFahrenheit, please be clear what you want to do. If you really want to install in bios-legacy, it’s fine with us, just remember the constraints above.

1 Like

@gohlip I wanted the most easy way to dual-boot Manjaro with my Windows. I was not concerned about anything else than that. :slight_smile:

Luckily, with your help and the amazing tip from @cimarronline, I was able to boot Manjaro into UEFI and achieve just that. :smiley:

The one thing to say is that I was unable to set the ESP flag in the installer. Now matter how many times I seletected, it was telling me it was no set. I was trying to select just the esp, the esp with boot as well, but it was like the installer was forgetting my changes despite I was clicking OK. I solved this deleting the partition and creating another one right there on the installer, with the configuration you said, and everything ran fine. The Manjaro, somehow, even managed to put my Kingston with Manjaro (which is in SATA slot n°4) in the top of the boot priority in my BIOS. Amazing.

Thanks again all of you, specially @gohlip and @cimarronline for the help. I’ll be dropping a couple of bucks into Manjaro. :smiley:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark