Ideapad 300 laptop freezes randomly in XFce and OpenBox

Recently tried to install Manjaro into an “old” Lenovo ideapad …
( 2Gb RAM + Emmc64 device, no dedicated GPU)
System is updated to the latest packages and with kernel 5.7.17-2 Manjaro .

Initially tried the Gnome ISO … But it locked at 95% of the install …
Then tried Xfce ISO with sucess but …
If try to change some settings it glitches visually ( flickers and rando visual artifacts ) …
Sometimes it recover from such events but not always…

Tried to install ( keeping XFCE ) , OpenBox…
More stable but sitll sometimes using the menu it glitchs the same way …

All the other components behave properly …

lspci reports :

00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 

in the Manjaro Settings - Hardware I have :
video-linux installed

Where can I start to solve this ?
Any ideas ?

After the intial entry checked all the entrys :
video-linux X
video-modesetting X
video-vesa X

and now the system does not boot …
Accessed the grub menu but still no ttys …
How can I recover ?

Re-installed XFCE again …
And apparently selected via shell and mhwd video-modesetting …

Seemed more stable but after some more tries it glitched again …

We need more information:
inxi -Fazy
ls /etc/X11/xorg.conf.d/

It is difficult to say - but some of the cheap win books is not designed for Linux.

All Manjaro ISO are created using the same base system - and in that regard they are all equal. But it is well know that some systems is more demanding than others. Your system is not a racing car - it is more like a family car - and it can get the job done - just not as fast.

But I think you could benefit from the following change

Edit /etc/mkinitcpio.conf to include i915


Rebuild initrd

sudo mkinitcpio -P

Also create the following file to /etc/X11/xorg.conf.d/20-intel.conf with this content

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "TearFree" "true"

No matter what I try , ( editing this post) , I am not able to paste here the Full inxi -Fazy result…
( I am getting the "you can not include links in your post " annoying message … )
After several text edits I still can not figure it out correctly why some parts are being considered “links”…

Nonetheless here are the partly edited and most relevant part:

Kernel: 5.7.17-2-MANJARO x86-64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT-IMAGE=|boot|vmlinuz-5.7-x86-64

Type: Laptop System: LENOVO product: 80M1 v: Lenovo Yoga 300-11IBR
Topology: Dual Core model: Intel Celeron N3050 bits: 64 type: MCP
arch: Airmont family: 6 model-id: 4C (76) stepping: 3 microcode: 368
L2 cache: 1024 KiB
Speed: 480 MHz min|max: 480|2160 MHz Core speeds (MHz): 1: 528 2: 480

Device-1: Intel Atom Celeron Pentium Processor x5-E8000 J3xxx N3xxx Integrated Graphics
vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:22b1
Message: Advanced graphics data unavailable in console. Try -G --display

I added the i915 formally but it did not change anything …
( and by the result of the inxi idno it is already being used …

Sometimes the visual Xfce glitch becomes an image lock, so the screen is locked but the audio keesp being active …