I3lock pam_oath

i3

#1

When I try to log in i3lock doesn’t ask for my oath pass and just shows me a message that says “Wrong”

the way I setup pam_oath
https://wiki.archlinux.org/index.php/Pam_oath

I added to my /etc/pam.d/system-auth
auth required pam_oath.so usersfile=/etc/users.oath window=30 digits=6

How can I enable pam_oath with i3lock ?

thanks


#2

I think you should have a look at
https://www.mankier.com/1/i3lock
and
https://www.mankier.com/1/xautolock.1x
plus
http://oath-toolkit.nongnu.org/pam_oath.html

or simply man i3lock and man xautolock from terminal should give you some hints.

By default it should use your username password to unlock. Does you user have a password? What exactly are you trying to accomplish or avoid?