[i3] Window artifacts when resizing

xfce
i3
i3wm
#1

I'm using i3 version 4.16.1 on Manjaro XFCE with XCompMGR as the compositor.
Why does this happens when I resize a window in i3? It doesn't seem to be a compositing issue since this appears even with the compositor disabled. Could the window be updating too fast? Or too slowly? I don't know.
By the way, this never happened on the default XFCE interface.

I tried asking this on the i3wm subreddit, but apparently people there don't know either.

#3

I have exactly the same issues, when running Manjaro with free (mesa) drivers, using an nvidia card.
Try installing non-free drivers, that fixes it for me.

#4

Not an option with Intel

#5

If is an intel GPU, then start here
https://wiki.archlinux.org/index.php/Intel_graphics

#6

What would I be looking for there? If the problem was with my intel GPU, it would have happened outside i3, but that's not the case

#7

You should be the one knowing best what the issue is. If is not the iGPU then have a look at the compositor. Compton related ... but then i915.enable_execlists=0 might be required even tho is not showing any artifact outside i3. Maybe you have to use other kernel boot parameters like:

acpi_osi=Linux
acpi_osi="!Windows 2012"
acpi_osi=

Probably you have to change from SNA to UXA if using the xf86-video-intel
Option "AccelMethod" "uxa"

Should i mention all the possibilities ? :slight_smile:

#8

I'll try, thanks.

I just don't understand why I would be modifying anything on my intel driver for this. I'm not an advanced user, I don't know what these changes might do to my system and this sounds too extreme of a fix.

1 Like
#9

Well, i only can hope that nobody will follow blindly whatever someone on the forum suggests, but rather read that documentation. After that anyone could take an informed decision if to make or not some modifications to the configs. Sadly there is no "one click / one solution 4 all". :slight_smile:

#10

Okay, I read the Arch Wiki article on Intel and changed the acceleration method to UXA, I think. My 20-intel.conf file is looking like this:

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "TearFree" "true"
  Option      "AccelMethod"  "uxa"
EndSection

I rebooted and the problem persists. I would try the other two options you gave me, but I really don't understand at all what to do with those.