i3 touchpad MacBook 5,1

Hi,

Trying to disable tap to click on my i3 install, running on a MacBook Air 5,1.
Read all relevant posts, but can't seem to find a solution. I'm able to do it on Gnome, and a bunch of other distros, but can't seem to do it on i3.

Already tried messing with the .config files, following instructions found here and other places online, but nothing seems to work.

Ideas ? Thanks

I know this yours is 5,1 - have checked this section on touchpad?

https://wiki.archlinux.org/index.php/MacBook5,2_(early-mid_2009)#Touchpad

Manjaro uses libinput - as I recall it - tap to click is specifically enabled in /etc/X11/xorg.conf.d using the relevant identifier.

If you are using Synaptics - please note that package is not maintained and in any case you should use libinput.

1 Like

Yes, yes, yes!
Thank you so much! I had gone down this road before but (newbie) forgot to restart x server, so I just assumed it wasn't working, and returned the file to original state, afraid I'd brake something.
This time, with the server restarted, it worked. Problem solved, thank you so much for taking the time to solve this.

1 Like

Forum kindly sponsored by