I3 Nvidia screen tear | SOLVED

Hello!
I have manjaro i3 fresh install. I have nvidia m960 and screen tear. I found YT video for screen tear fix - i should enable force full composition pipeline under advanced settings but when i press advanced settings button, nothing happens - there is no box to check to enable pipeline. What now?
This is how my mhwd -li looks like:
https://pastebin.com/VDn5VAWu

your using bumblebee so the way you would run nvidia-settings is different from that video. but first, what that video describes is not screen tearing, it actually sounds more like compositor issues, compton in your situation.
also that forcefullcompositionpipeline should not be necessary, it also negatively effects performance.

if your intention is gaming, you should really consider getting away from bumblebee anyway. i have the same video card in this laptop and it works perfectly fine. for now though, can you describe exactly whats happening? trails or tearing?

No, I am not really a gamer although CS 1.6 once in a while would be awesome. What would you recommend for a driver and maybe you could paste a command? This is my 4th manjaro i3 install today… I just keep breaking it up by trying new things related to this screen tear problem and I end up breaking it some way or another…
You said it’s compositor issues. Could you elaborate and share some tips and steps to resolve this?

It really is just classical tearing. When you type screen tear test on YT. The very first video proves my issue perfectly. Those lines tears appart, they split in blocks if you will… I had a same issue on ubuntu till I moved to wayland. Just about every video is tearing. But I really want to stay with manjaro i3.

ok, if gaming isnt a main priority, bumblebee should be fine for you. run the nvidia settings with this command

sudo optirun -b none nvidia-settings -c :8 

add the forcecompositionpipline options as described and save to your xorg configuration.

something else i should of asked you, when your watching video are you using optirun to run the browser? or just running the browser?

if this happens when your not using optirun then this can probably just be fixed with an added option to intel.conf

Well, in my very first post i already wrote that I can’t do that. When i press advanced options button, nothing happens. I can’t check pipeline option box. It does not show up.

does this tearing happen even when not using optirun? or only when using optirun?

if this happens even when not using the nvidia card (optirun) then the tearing is on the intel side and can be easily fixed adding TearFree to it’s xorg configuration.
for example:

#/etc/X11/mhwd.d/intel.conf
# xorg configuration for use with intel driver.

    Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "DRI" "3"          
        Option      "TearFree" "true"  #<-------this line
     EndSection

but just to be sure which file is what, please post:

ls -laR /etc/X11/
3 Likes

Oh, the fix was so easy omg… Adding the line you provided fixed it! Thank you very much. Anyway, which driver you recommend if I want to play some games?

the proprietary nvidia drivers setup with either PRIME or optimus-switch

both use prime, but optimus-switch allows for switching between nvidia prime mode (intel/nvidia gpu’s both powered on at all times) and intel-only mode (nvidia gpu disabled/powered down, extending battery life).

here’s a small comparison of options for optimus laptops.

welcome to the forum. glad that worked out for you.

Thank you very much!

1 Like