I3 fonts magnified after last update


#1

Ahoy!

As of today’s update, the fonts for i3 seem to be “magnified,” in the sense that in addition to the fonts appearing larger, if I adjust to make the font size smaller in my i3 config, the text still look slightly “blurry” in a way that I don’t recall it being previously. So, if I just make the font smaller to try to get it back to its original size, they are a bit hard to read now.

So far, no other text outside of i3 seems any different, at least that I have been able to tell.

If anyone has any guesses as to what may have caused the change, I would be very appreciative to hear them. My own searching has been fruitless so far.


`i3pystatus` got twice as big after system upgrade and reboot
#2

What exactly is your font line ?


#3

font xft:Noto Sans 10

(also font xft:Noto Sans 10.5 for the bar)


#4

Hm strange. I have the exact same and for me everything is looking normal and as it always used to be.
Is there a ~/.config/fontconfig/fonts.conf for your user?


#5

There is nothing in ~ that includes ‘fonts’.


#6

Oberon probably meant ~/.config/fontconfig/fonts.conf. I had the same issue with i3pystatus and I think it was due to DPI setting in that file after GPU upgrade and resolution change. Not sure, though. Maybe something else solved it, I was fiddling a bit.


#7

I did! :wink: thanks.


#8

I actually don’t have a ~/.config/fontconfig/fonts.conf file either (or any local.conf in /etc/fonts/). All I’ve done is change the font to a smaller size in my I3 config, and that has effectively solved the problem for me. I think I might have been looking too hard at the text when I decided that it was blurry (or maybe I can’t remember how it used to look anymore).