[i3 Edition] [ThinkPad E480] Touchpad works but can't toggle natural scrolling

Hello, (sorry for my english)

Reinstalled Manjaro i3 Comunity Edition and once again wanted to reverse scrolling.

Went to bmenu ($mod+Shift+b) -> Hardware and drivers (1) -> Configure touchpad (6) -> Toggle natural scrolling (6).

And received the messages:

unable to find device
unable to find device
unable to find device
Something vent wrong

Didn't remenber that happenig the last time but anyway lets just edit some config file.

Added the line Option "Natural Scrolling" "true" to /etc/X11/xorg.conf.d/30-touchpad.conf but that still doesn't do it.

Searching to solve this has not been easy becuase it's not that the touchpad dosn't work or that I don't know how to set natural scrolling (maybe it was not the best way it should have worked right?)...it just doesn't happen.

Any help is greatly apreciated.

Install libinput and remove synaptic

https://wiki.archlinux.org/index.php/Libinput

Thanks for the reply!

libinput was already installed and I didn't remove synaptics but messing around with things mentioned in the archwiki page eventually solved it.

But, quite embarrassingly, I don't know exactly what solved it...bmenu still says unable to find device [...] Something vent wrong.

Forum kindly sponsored by