I3 (and gnome will not install) issue


I have just moved to manjaro and would like to have the ability to mostly use i3 but ‘pop’ into gnome every now and again

so I installed i3 manjaro and have it setup and thought I could just pacman -S gnome and then add the theming bits

unfortunately it tells me that it cannot due to a conflict

warning: removing ‘gdm’ from target list because it conflicts with ‘gdm-dev’
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: gdm-dev and libgdm-dev are in conflict

Any advice/help would be appreciated
thanks paul

I’ve only run i3 alongside xfce, but I would recommend installing i3 on top of another DE, since i3 is ‘just’ a window manager and less complex than the gnome environment (and doesn’t have gdm as a dependency).

EDlT: Welcome to the forum! :slightly_smiling_face:

You installed by some reason, previously, the dev versions. Remove them first and then install gdm and libgdm

thanks, I did try that but found the config if i3 more difficult than thought, specifically around uninstalled tools, e.g function/media keys but if you have any advice I might give that another go

Hi, I am not sure how that can be as it was a fresh install of i3 and using the Qi option shows me that I do not have either, or any gdm packages installed, could you give me a suggestion on how to troubleshoot further please?

You could simply make a backup of your current ~/.i3/config, and use that after manually installing i3’s componants and for referencing which componants (e.g. “blurlock”). You will want to install i3-gaps instead of i3-wm (it’s basically the same, but i3-gaps has additional features/is being used for the community edition).

If you decide to stick with the current install, check which apps depend on ‘libgdm-dev’:
pactree -r libgdm-dev
in order to give you an idea how to proceed…

thanks again (and I forgot to say thank you for the warm welcome :smile:)

I am going to copy the config and start again as it would not be a bad learning opportunity, its just that the i3 spin is so good (the Fn keys especially) but it all must be possible!

I did also try the pactree command but the package is not installed so it just returned an error

I will see you here on the other side!

For what it’s worth, try:
pactree -r gdm-dev :upside_down_face:

package not found :thinking:

as I said I have only installed nvim, vscode, sublime and some fonts (I am not sure how I messed up!)

pactree -r gdm ?

$pactree -r gdm
error: package ‘gdm’ not found

For the fun of it:
pactree -r libgdm

$ pactree -r libgdm
error: package ‘libgdm’ not found

Ok, I’m at a loss regarding your package conflict from the opening post, maybe @bogdancovaciu will step in…

thanks, no problem, I am new to manjaro but have been using linux for a while, and it was a bit odd

I did a fresh install, added a few packages and then thought I can simply add gnome now that I have i3 where I want it but :grin:

I really do light i3 but did take the shortcut so this probably serves me right, I will start with gnome as you said and then see how long it takes me to get back here!

thanks again for you help, really appreciated

1 Like

i can always ask more questions!

1 Like

Right, but the issue is what does the OP to trigger the gdm-dev dep error ? By no means
sudo pacman -S gnome
and even selecting all from that group will NOT render that error. Just made a test with an i3 install.

And who is going to answer them ? :upside_down_face:
This is the only warning you should have got:

warning: removing 'nautilus' from target list because it conflicts with 'nautilus-typeahead'
warning: removing 'libnautilus-extension' from target list because it conflicts with 'libnautilus-extension-typeahead'

1 Like

I am currently having the same problem. Although, as of now I am on KDE, but wanted to try out gnome.
I get same error and OP and I don’t have gdm-dev or libgdm-dev.

1 Like

I’m having the same error here I can’t install gnome with the exact same error, I’m on XFCE

1 Like

I’m having the same issue as described. I switched to KDE and uninstalled gnome, now I can’t seem to go back.

1 Like