I want to understand and fix my issue with intel + nvidia discrete graphic card on my laptop

Hello all,

I’m trying to fix my issue regarding my Acer Aspire V15 Nitro Laptop and its Hybrid Intel/Nvidia graphics (Geforce GTX 860M), as I can’t seem to run any game with Steam/Proton at the moment, and the main reason is that I think my system is only using the intel GPU and not my nvidia discrete graphics card. I’ve been trying to access former forum topics addressing this problem, but I think they are not accessible because of the new forum. So I’m at a loss at the moment.

Basically, my laptop is always plugged in at home, and at this point, I don’t care if I only use the nvidia card at all time if it’s more practical. I’m looking at the simplest, easiest way possible to only use the Nvidia card on the system.

At the moment, when I run "glxinfo | grep “server glx vendor string”, I get SGI, which means the Intel gpu is running. I don’t know how to permanently switch to nvidia. I have used the guidance on the wiki regarding Optimus hardware configuration (Optimus Manager - Manjaro Linux), but I always get stuck somewhere in the process.

This is where I am at the moment:

In hwcm, under Display Controller > GM107M [Geforce GTX 860M] (nVidia Corporation), “video-hybrid-intel-nvidia-440xx-prime” driver is installed, along with “video-linux”. Then, further down, Another Display Controller > 4th Gen Core Processor Integrated Graphics Controller (Intel Corporation), “video-hybrid-intel-nvidia-440xx-prime” is there again, along with “video-linux” once again, and “video-modesetting”.

I have followed the wiki, installed optimus-manager, and enabled the service. After rebooting, if I run “systemctl status optimus-manager.service”, I see that the daemon is loaded and active. I also checked to make sure I did not have any residual configuration which could conflict with what is generated by optimus-manger (/etc/X11/xorg.conf, and other files mentioned on the wiki). I also ran “optimus-manager --cleanup”, which does not return any error.

However, even if I run “optimus-manager --set-startup nvidia”, I get the following error:

[tommy@AspireV15NitroArch ~]$ optimus-manager --set-startup nvidia
ERROR: a GPU setup was initiated but Xorg post-start hook did not run.
Log at /var/log/optimus-manager/switch/switch-20200818T191753.log
If your login manager is GDM, make sure to follow those instructions:
If your display manager is neither GDM, SDDM nor LightDM, or if you don't use one, read the wiki:

The argument --set-startup is deprecated. Set startup_mode through the configuration file at /etc/optimus-manager/optimus-manager.conf instead

The exact same error happens if I use “optimus-manager --switch nvidia”.

This is where I am at the moment. The error mentions GDM and also states that --set-startup is deprecated, and this is where I’m at a loss. I don’t know where to go from here.

Any kind/knowledgeable soul would care to help or point towards a way to fix this? I’d be much grateful.

I’m coming from Linux Mint 19.3 / 20 and running most games under Steam/Proton used to be seamless, meaning that I don’t recall making any tweak to make it work. Games just launched and used the nVidia card. If I can get this issue fixed, I will definitely stick with Manjaro as I love the distro, but it’s been bugging me for quite some time now, spending many hours on the wiki and github FAQS referenced in the error messages, to no avail.

Thank you!

Asus notebook with

  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: ASUSTeK 
  driver: nvidia v: 440.100 bus ID: 01:00.0 chip ID: 10de:1c8c 
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia 
  resolution: 1920x1080~120Hz s-dpi: 96 
  OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 
  direct render: Yes 

I had followed the wiki and has issues to.

Solved installing video-nvidia-440xx and video-linux instead of video-hybrid-intel-nvidia-440xx-prime.

1 Like

Hi rovovav982,

Thanks for your extremely quick reply, I’m impressed! I have tried to switch drivers, I wanted to remove the hybrid one and just move on to video-nvidia-440xx, but at the moment it does not work. Here is what happens when I try to uninstall the prime driver:

> Removing video-hybrid-intel-nvidia-440xx-prime...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-hybrid-intel-nvidia-440xx-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-440xx-utils breaks dependency 'nvidia-utils' required by cuda
Error: pacman failed!
Error: script failed!

Done ...

If I try to install the video-nvidia-440xx driver, I get the following error:

Waiting for user input...


Error: config 'video-nvidia-440xx' conflicts with config(s): video-hybrid-intel-nvidia-440xx-prime

Done ...

As I’m just beginning with Manjaro, I don’t know what to do to fix this issue and try your option. Any clue?

Forget the manager for now.
Revert everything and select a prime profile in mhwd/MSM (ex ’ video-hybrid-intel-nvidia-440xx-prime')

From then on just launch things with prime-run
for example, to check … do

glxinfo | grep 'renderer string'
prime-run glxinfo | grep 'renderer string'

EDIT…I see that during your previous activities you installed other things.
cuda is blocking your change … remove it first.


Thank you cscs for your input.

I have removed cuda. I don’t remember installing it, but it might be the result of a drunken night trying multiple solutions without using timeshift in the first place. I’m an idiot.

So, cuda is removed, I was able to remove the hybrid (prime) driver, and now installing the video-nvidia-440xx driver only. As mentioned earlier, I don’t care about using the intel card at all, I want to be able to launch my games as simply as possible for the time being, so if the nvidia card can always run from boot and manage everything, that’s fine with me at the moment. I will probably install another instance of Manjaro and tinker with the prime driver eventually when I have more time, but for now, all I want is for my games to launch and use the nvidia card by default. Will reboot and update you guys soon. Thanks a lot for the incredible support so far! I’m impressed!

But … there isnt really any tinker needed … just install the profile then use prime-run.
(in the case of steam add prime-run %command% to game launch options)

in any case cheers - have fun.

1 Like

What are you using to play games with ? In lutris there’s an option to launch all games with prime-run so they all automatically run on nvidia rather than intergrated

1 Like

Ok, seems like I need to take a few steps back then. Have never used Lutris before, Steam + Proton ran all my games fine with the nvidia gpu under Mint, so didn’t see the need for Lutris at all. Will look into it now.

After removing the prime driver and installing the nvidia only driver, I still boot to an X session with the intel gpu, so I will do as you recommended and try the prime-run %command% prefix, as well as trying the Lutris option, which would suit me better if I can manage to make it work.

Really appreciate your help. I wasn’t expecting support so quickly on these forums. Mindblowing!

Will report once I have exhausted the recommendations here. Thanks again!

Lutris will launch steam games for you but another way is to right click a steam game select properties and then select set launch options. Once you have done that type

prime-run %command %

And save it. The game will then launch in prime-run and use your dedicated gpu

1 Like