I want to Remove Windows 10 without re-installing Manjaro

Thanks for the advice! The funny thing is that the important files I have there are only family photos, so I don’t really need ntfs for that, you think it would be a good idea to backup everything and re-format it to something like ext4 or even ntfs-3g for the security sake?
Also I will do a update-grub just in case :crazy_face:

Yepp, better use a filesystem which fully compatible with linux like ext4 for the daily tasks. Btw… ntfs-3g is the name of the driver for the ntfs filesystem: NTFS-3G - Wikipedia

Ok I’m going to do that then, thanks for the advice! Going to update you in case I get stuck again :sweat_smile:

So I re-formated the partition and this is the path: /run/media/fernando/Disco Principal/
The commad should be:

sudo chown -R $USER:$USER /run/media/fernando/Disco\ Principal/


sudo chmod -R 777 /run/media/fernando/Disco\ Principal/

Is that right?
Never mind just tried it and it worked :crazy_face:

Anyway thank you very much for your help, I can’t thank you enough!
I am going to mark your response as the solution now.
Also everytime I boot I have to manually mount the drives on the file manager, is there a way to make them be mounted on boot?

Glad i could help you :wink:

  1. Open /etc/fstab as root.
  2. Look up the UUID of the partition. For example:
sudo blkid /dev/sdY1
  1. Type in a new line like this:
UUID=<UUID> /path/to/mountpoint     ext4   defaults,noatime   0      1
  1. The folder to the mountpoint must exist/have to be created before mounting.
  2. Now mount with: sudo mount /path/to/mountpoint
    Now this is permanent and already active.

More information here: https://wiki.archlinux.org/index.php/Fstab

Ok so fstab is like this now:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=9d137ceb-f57c-4775-b73e-bf4d98d12a91 /              ext4    defaults,noatime,discard 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=82916290-6660-4a03-af8e-86875ea57b9d /run/media/fernando/Disco de Coisas/     ext4   defaults,noatime   0      1
UUID=47a993c2-3795-40b1-b5ba-af2e5a0076ef /run/media/fernando/Disco Principal/     ext4   defaults,noatime   0      1

Is that correct? The spacing between each item doesn’t seem right.
Edit: I edited the file in the file manager, not in the terminal, just in case

I would not use /run/media/fernando/ for permanent mount, because it is mostly used for temporary mount. Choose another folder. It can be anywhere you want. And better user “_” instead of space at the folders. If you are the only user who uses it, choose /home/fernando/Disco_de_Coisas, or maybe /mnt/Disco_de_Coisas or at root: /Disco_de_Coisas. Of course you have to create the folder first.

For example:

sudo mkdir /Disco_de_Coisas

Then just add the folder to your favorites at your file manager.

That’s interesting, because /run/media/ was the default mountpoint that Gparted created when mounting, so I can change that now even after mounting and setting up the permissions?

While @megavolt’s answer is perfect and nothing wrong with, I advise you to also look at the tutorial about [root tip] Use systemd to mount ANY device

Gparted has nothing to do with the default mountpoint. Your file manager have done this. After mounting it through fstab, the partition will not be listed there like before. It will mounted in the background and act like a normal folder. And the permission you have set are saved on the filesystem. Nothing have to be changed there if already set.

And yes, you can change the mountpoint anytime.

Ok, just mounted on root, and everything worked, all of the files are on the folders that I created, however when going to the partition on the file manager, it still appears as /run/media/fernando, maybe it updates after a reboot?
Also I didn’t unmount it before mounting it on root

No problem on reboot it will be away definitely. Try restarting the file manager? At least on thunar or pcmanfm it disappears immediately.

I umounted it on the file manager and on Gparted, and mounted it again on root, it disapeared on the file manager, but I can’t see the full space of the partiton, it just looks like a folder, with only counting the space that i already used.
On thunar root in the devices section it shows up but on the normal file manager it doesn’t

mh… maybe choose /media/Disco_de_Coisas instead. I guess this the correct one to be compatible with the file manager.

Ok so I just unmount it again on Gparted, edit fstab and do the mounting on the terminal again?

One thing, there is no /media/ only /run/media

Then just create it :slight_smile:

sudo mkdir -p /media/Disco_de_Coisas

Edit: pcmanfm works. It displays me the partition as mounted.

There we go, after mounting on /media/ it worked it shows up now on devices, thank you so much for your help, I can’t say this enough :smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.