I tried to install something from AUR that I shouldn’t have and it messed up GNOME

I tried to install something from AUR that I shouldn’t have and it messed up Gnome. I managed to get Manjaro hello to work, and thus and able to post here. How can I repair gnome? Terninmal and Manjaro Hello are the only things working right now. The system says something went wrong, try to log out and try again. If I do ctrl+shift f2 or such I can get a terminal.

Remove what you installed from AUR?

past that point afraid. And it failed to install, it broke gnome. plus I can’t remember what it is without the gui. Do you know how I can completely nuke gnome and rebuild it? Or maybe can I install another instance of manjaro and copy over the good files to the broken install would that work?

I think I know what might be broken, but not how to fix it. GDM seems to be broken, any idea how to fix?

remove what it was you installed - if it failed to install as you said then nothing has actually changed and it is very unlikely the reason for your problem

… it could also give a hint if you revealed what it was that you attempted to install
and how you did that

Try providing some information.

how do I save the logs from terminal? I’ve never tried to fix a linux issue like this. I normally just reformat and start over but I’m trying to learn more so I’m trying to fix this instead of nuking it.

I’m able to launch the file manager it seems to upload directly from this computer but gdm won’t load.

try running first:
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu
then try reinstalling gdm:
sudo pacman -S gdm
to check install history:
open add/remove software, click the hamburger menu, select view history; using command to view history:
sudo nano /var/log/pacman.log press ctrl + end to go at the end of the log

There should be a file with a history of what was installed, uninstalled and when. You can read it with nano, however, I don’t recall the location of that file. Anyone?




and you better read it with cat or tac and pipe the output through less

cat /var/log/pacman.log | less
will start from the top of the file

tac /var/log/pacman.log | less
will start from the bottom/end of the file - most recent events first

search for keywords with CTRL + /

1 Like

I’m trying to export the pacman logs right now but while I wait. systemctl status gdm states. Gdm: Child process -1294 was already dead. and GdmDisplay: Session never registered, failing

did you try to run those commands i posted above? if yes and it didnt work, then log out, enter into tty Ctrl+Alt+F2 and run them from there