I seem to have broken my system

I installed mesa drivers to an ASUS X540SA with Intel n3050 and I seem to have broken the system, c desktop environment doesn’t load up and neither does TTY. this is strange given that I have done it before and it doesn’t affect the system this bad, would using an ISO help? I have a bootable disk with me

Either the driver or ksuperkey and I’m guessing it’s the drivers

if you have a manjaro liveusb then boot it up and come back and provide relevant information and then you can chroot into your installation and fix it at the same time as having a graphical desktop to troubleshoot from.


please post:

inxi -Fxxxz
mhwd -li
grep -v ^# /etc/X11/xorg.conf.d/*.conf
grep -v ^# /etc/X11/mhwd.d/*.conf
cat /var/log/Xorg.0.log | grep -E "(EE)|\(WW)|\error|\failed|\Time"
journalctl -b0 -p4
1 Like

really sorry but i don’t know that much about the terminal, can’t even chroot, but i am now on the live session

If your in the live session, open up the terminal and type

manjaro-chroot -a

hen enter in the commands that sgit has posted.

1 Like

ok, now from a terminal do:
manjaro-chroot -a

that should bring you to a #shell

2 Likes
 manjaro-chroot -a
==> Detected systems:
 --> 0) ManjaroLinux
 --> 1) ManjaroLinux1
==> Select system to mount [0-1] : 
0
==> Mounting (ManjaroLinux) [/dev/sda3]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
[manjaro /]#  inxi -Fxxxz
12System:    12Host manjaro 12Kernel 4.19.13-1-MANJARO x86_64 12bits 64 12compiler gcc 12v 8.2.1 12Console N/A 
           12wm kwin_x11 12dm N/A 12Distro Manjaro Linux 
12Machine:   12Type Laptop 12System ASUSTeK 12product X540SA 12v 1.0 12serial <filter> 
           12Mobo ASUSTeK 12model X540SA 12v 1.0 12serial <filter> 12UEFI American Megatrends 12v X540SA.207 
           12date 11/25/2015 
12Battery:   12ID-1 BAT0 12charge 0 Wh 12condition 0/33.2 Wh 12volts 11.2/11.2 12model ASUSTeK X550A26 
           12type Li-ion 12serial <filter> 12status Charging 12cycles 297 
12CPU:       12Topology Dual Core 12model Intel Celeron N3050 12bits 64 12type MCP 12arch Airmont 12rev 3 
           12L1 cache 112 KiB 12L2 cache 1024 KiB 
           12flags lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 12bogomips 6402 
           12Speed 1300 MHz 12min/max 480/2160 MHz 12Core speeds (MHz) 121 716 122 2069 
12Graphics:  12Device-1 Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics 
           12vendor ASUSTeK 12driver i915 12v kernel 12bus ID 00:02.0 12chip ID 8086:22b1 
           12Display 12server X.org 1.20.3 12driver vesa 12compositor kwin_x11 12tty N/A 
           12Message Advanced graphics data unavailable for root. 
12Audio:     12Device-1 Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High 
           Definition Audio 
           12vendor ASUSTeK 12driver snd_hda_intel 12v kernel 12bus ID 00:1b.0 12chip ID 8086:2284 
           12Sound Server ALSA 12v k4.19.13-1-MANJARO 
12Network:   12Device-1 Realtek RTL810xE PCI Express Fast Ethernet 12vendor ASUSTeK 12driver r8169 
           12v kernel 12port e000 12bus ID 02:00.0 12chip ID 10ec:8136 
           12IF enp2s0 12state down 12mac <filter> 
           12Device-2 Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 12vendor AzureWave 
           12driver ath9k 12v kernel 12port e000 12bus ID 03:00.0 12chip ID 168c:0036 
           12IF wlp3s0 12state up 12mac <filter> 
12Drives:    12Local Storage 12total 473.26 GiB 12used 19.93 GiB (4.2%) 
           12ID-1 /dev/sda 12vendor Seagate 12model ST500LT012-1DG142 12size 465.76 GiB 12speed 6.0 Gb/s 
           12serial <filter> 12rev SDM1 
           12ID-2 /dev/sdb 12type USB 12vendor Generic 12model Flash Disk 12size 7.50 GiB 12serial <filter> 
           12rev 8.07 
12Partition: 12ID-1 / 12size 175.38 GiB 12used 19.78 GiB (11.3%) 12fs ext4 12dev /dev/sda3 
12Sensors:   12System Temperatures 12cpu 6280.0 C 12mobo 60.0 C 
           12Fan Speeds (RPM) 12cpu 3400 
12Info:      12Processes 181 12Uptime 19m 12Memory 1.85 GiB 12used 1.11 GiB (60.1%) 12Init systemd 12v 241 
           12Compilers 12gcc 8.2.1 12Client Unknown Client: systemd 12inxi 3.0.30 

1 Like
inxi -Fxxxz
12System:    12Host manjaro 12Kernel 4.19.13-1-MANJARO x86_64 12bits 64 12compiler gcc 12v 8.2.1 12Console N/A 
           12wm kwin_x11 12dm N/A 12Distro Manjaro Linux 
12Machine:   12Type Laptop 12System ASUSTeK 12product X540SA 12v 1.0 12serial <filter> 
           12Mobo ASUSTeK 12model X540SA 12v 1.0 12serial <filter> 12UEFI American Megatrends 12v X540SA.207 
           12date 11/25/2015 
12Battery:   12ID-1 BAT0 12charge 0 Wh 12condition 0/33.2 Wh 12volts 11.2/11.2 12model ASUSTeK X550A26 
           12type Li-ion 12serial <filter> 12status Charging 12cycles 297 
12CPU:       12Topology Dual Core 12model Intel Celeron N3050 12bits 64 12type MCP 12arch Airmont 12rev 3 
           12L1 cache 112 KiB 12L2 cache 1024 KiB 
           12flags lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 12bogomips 6402 
           12Speed 480 MHz 12min/max 480/2160 MHz 12Core speeds (MHz) 121 480 122 480 
12Graphics:  12Device-1 Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics 
           12vendor ASUSTeK 12driver i915 12v kernel 12bus ID 00:02.0 12chip ID 8086:22b1 
           12Display 12server X.org 1.20.3 12driver vesa 12compositor kwin_x11 12tty N/A 
           12Message Advanced graphics data unavailable for root. 
12Audio:     12Device-1 Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High 
           Definition Audio 
           12vendor ASUSTeK 12driver snd_hda_intel 12v kernel 12bus ID 00:1b.0 12chip ID 8086:2284 
           12Sound Server ALSA 12v k4.19.13-1-MANJARO 
12Network:   12Device-1 Realtek RTL810xE PCI Express Fast Ethernet 12vendor ASUSTeK 12driver r8169 
           12v kernel 12port e000 12bus ID 02:00.0 12chip ID 10ec:8136 
           12IF enp2s0 12state down 12mac <filter> 
           12Device-2 Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 12vendor AzureWave 
           12driver ath9k 12v kernel 12port e000 12bus ID 03:00.0 12chip ID 168c:0036 
           12IF wlp3s0 12state up 12mac <filter> 
12Drives:    12Local Storage 12total 473.26 GiB 12used 19.95 GiB (4.2%) 
           12ID-1 /dev/sda 12vendor Seagate 12model ST500LT012-1DG142 12size 465.76 GiB 12speed 6.0 Gb/s 
           12serial <filter> 12rev SDM1 
           12ID-2 /dev/sdb 12type USB 12vendor Generic 12model Flash Disk 12size 7.50 GiB 12serial <filter> 
           12rev 8.07 
12Partition: 12ID-1 / 12size 175.38 GiB 12used 19.78 GiB (11.3%) 12fs ext4 12dev /dev/sda3 
12Sensors:   12System Temperatures 12cpu 6280.0 C 12mobo 60.0 C 
           12Fan Speeds (RPM) 12cpu 3400 
12Info:      12Processes 180 12Uptime 29m 12Memory 1.85 GiB 12used 1.08 GiB (58.3%) 12Init systemd 12v 241 
           12Compilers 12gcc 8.2.1 12Client Unknown Client: systemd 12inxi 3.0.30 
[manjaro /]# mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
            video-vesa            2017.03.12                true            PCI
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!
[manjaro /]# grep -v ^# /etc/X11/xorg.conf.d/*.conf
/etc/X11/xorg.conf.d/00-keyboard.conf:Section "InputClass"
/etc/X11/xorg.conf.d/00-keyboard.conf:        Identifier "system-keyboard"
/etc/X11/xorg.conf.d/00-keyboard.conf:        MatchIsKeyboard "on"
/etc/X11/xorg.conf.d/00-keyboard.conf:        Option "XkbLayout" "gb"
/etc/X11/xorg.conf.d/00-keyboard.conf:        Option "XkbModel" "pc105"
/etc/X11/xorg.conf.d/00-keyboard.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf: 
/etc/X11/xorg.conf.d/90-mhwd.conf: 
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "Device"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Identifier  "Device0"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Driver      "vesa"
/etc/X11/xorg.conf.d/90-mhwd.conf:    BusID       "PCI:0:2:0"
/etc/X11/xorg.conf.d/90-mhwd.conf:      Option      "DRI"    "true"
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf: 
/etc/X11/xorg.conf.d/90-mhwd.conf: 
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "DRI"
/etc/X11/xorg.conf.d/90-mhwd.conf:        Group  "video"
/etc/X11/xorg.conf.d/90-mhwd.conf:        Mode   0666
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf: 
/etc/X11/xorg.conf.d/90-mhwd.conf: 
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "Extensions"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Option "Composite" "Enable"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Option "RENDER"    "Enable"
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf: 
/etc/X11/xorg.conf.d/90-mhwd.conf: 
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "InputClass"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Identifier          "Keyboard Defaults"
/etc/X11/xorg.conf.d/90-mhwd.conf:    MatchIsKeyboard        "yes"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf: 
[manjaro /]# grep -v ^# /etc/X11/mhwd.d/*.conf
 
 
Section "Device"
    Identifier  "Device0"
    Driver      "vesa"
    BusID       "PCI:0:2:0"
        Option      "DRI"    "true"
EndSection
 
 
Section "DRI"
        Group  "video"
        Mode   0666
EndSection
 
 
Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER"    "Enable"
EndSection
 
 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
 
[manjaro /]# cat /var/log/Xorg.0.log | grep -E "(EE)|\(WW)|\error|\failed|\Time"
[   438.476] Current Operating System: Linux ACE 4.19.24-1-MANJARO #1 SMP PREEMPT Wed Feb 20 22:59:23 UTC 2019 x86_64
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   438.477] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Feb 21 22:14:24 2019
[   438.478] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[   438.478] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[   438.478] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi".
[   438.479] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi".
[   438.479] (WW) Ignoring unrecognized extension "Composite"
[   478.789] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   478.861] (WW) VESA(0): Unable to estimate virtual size
[   479.019] (II) VESA(0): VBESetVBEMode failed0004:04ad: 0F ILLEGAL EXTENDED X86 OPCODE!
[   479.020] (EE) 
Fatal server error:
[   479.020] (EE) AddScreen/ScreenInit failed for driver 0
[   479.020] (EE) 
[   479.020] (EE) 
[   479.020] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   479.020] (EE) 
[manjaro /]# journalctl -b0 -p4
-- Logs begin at Tue 2018-12-04 09:21:54 EAT, end at Mon 2019-02-25 15:18:03 EAT.>
-- No entries --
lines 1-2/2 (END)

you can put them all in one post instead of 1 each post. just edit/add the rest to one of them

2 Likes

from looking at it, i see many font errors. that is something i didn’t know about till now. i did not mention that i did a font install with dolphin (KDE file manager) from a folder with microsoft TTFs
i think that’s the curlprit, but not sure yet also seen some stuff with vesa , i thought it was mesa

Worth reading:

2 Likes

i have font errors too, unless your missing something critical it’s not a big deal. your issue is video related

[   478.789] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   478.861] (WW) VESA(0): Unable to estimate virtual size
[   479.019] (II) VESA(0): VBESetVBEMode failed0004:04ad: 0F ILLEGAL EXTENDED X86 OPCODE!
[   479.020] (EE) 
Fatal server error:
[   479.020] (EE) AddScreen/ScreenInit failed for driver 0
[   479.020] (EE) 
[   479.020] (EE) 
[   479.020] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   479.020] (EE) 

couple questions:
did you install any video drivers outside of using mhwd?
is there a reason you want to use vesa instead of the intel driver or modesetting driver?

1 Like

Not installed any driver outside the settings menu, if that’s what you’re asking. I was made to believe that Vesa doesn’t use too much system resources so I went for it

Thank you, but I can’t see any text, not even the one saying systems are starting

i dont know much about vesa as i have never used it. you can try using the modesetting or intel driver.

edit the following files like so:
sudo nano /etc/X11/xorg.conf.d/90-mhwd.conf

empty it out and copy/paste this:

#modesetting configuration

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0:2:0"
EndSection

then ctrl+x, then Y, then enter.

then either remove or rename the video .conf file in
ls -la /etc/X11/mhwd.d/
sudo rm /etc/X11/mhwd.d/name-of-file.conf (only the gpu related .conf file)

if this does not work, i dont see why it wouldnt. but if it does not, then remove the drivers you have installed and just install the free drivers the normal way.

sudo mhwd -r pci video-vesa
sudo mhwd -a pci free 0300

That’s covered in the first thread I linked to.

However, if you can chroot in then you should be able to follow the steps and make sure you’re fully updated.

If you have made other changes to the system then you’ll need to “undo” those changes.

It sounds like you installed a different graphics driver, so which one and how?

Also, @dglt’s suggestions should help.

you said i should empty it, halfway in, there’s something about keyboard and i have deleted the rest, im not sure whether i should delete everything or just the first parts. please tell me what to do

vesa through settings. i’m using a live session to troubleshoot. turns out vesa is the problem

yes because you already have a 00-keyboard.conf file, and possibly also one in mhwd.d so, yes. empty it and copy/paste what i gave you.

i think in your situation, letting mhwd do all of this might be easier. please just do this.

sudo mhwd -r pci video-vesa
sudo mhwd -r pci video-linux
sudo mhwd -a pci free 0300

no errors? reboot. you will not have to edit anything this way and mhwd will detect and make changes as it sees necessary.

2 Likes

back to my regular session. thank you.
credits to @dglt and @jonathon

in case you’re experiencing problems after installing video drivers, and can boot from usb,

manjaro-chroot -a
sudo mhwd -r pci video-vesa
sudo mhwd -r pci video-linux
sudo mhwd -a pci free 0300
2 Likes