I moved my windows from a hard drive to NVME and grub doesn't detect the new windows location

So I can still get to manjaro but it will default to windows so I thought “Fine I’ll just bcdedit /set {bootmgr} path \EFI\manjaro\grubx64.efi again” and so i did and got “A device which does not exist was specified.” and I’m not sure what to do. Sure its not that bad i just need to hit f11 every boot if i want to go manjaro but i want to be able to select windows from grub again like i had when windows was on the hard drive but grub still thinks windows is on the hard drive even after i formated that drive. its empty no files. I made sure of that. (formated it) If any one could advise what i need to do that would be wonderfull :slight_smile:


Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz

Base speed:	3,60 GHz
Sockets:	1
Cores:	8
Logical processors:	8
Virtualization:	Enabled
L1 cache:	512 KB
L2 cache:	2,0 MB
L3 cache:	12,0 MB


16,0 GB

Speed:	2400 MHz
Slots used:	2 of 4
Form factor:	DIMM
Hardware reserved:	61,5 MB


NVIDIA GeForce RTX 3070

Driver version:
Driver date:	2021/08/27
DirectX version:	12 (FL 12.1)
Physical location:	PCI bus 1, device 0, function 0

Just update the menu:

sudo update-grub

That fixed it. You are a legend!

now… how do i mark this as solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.