I keep getting asked for wifi password after I have disabled KWallet and delete a gpg key

A couple of weeks, I was doing a course on Kubernetes and had to pull a docker image. When i did so, I was asked for a passphrase for a gpg key that I created 6 months ago. The problem is that I forgot that passphrase so after trying to guess it multiple times and to revoke that key. I eventually had to delete it.

Now, that somehow caused a few applications on my pc to start acting weird. Primarily, the first time I rebooted my pc. I got a notification from KWallet, I forgot what it was exactly but when I looked online, some people recommended to disable the Kwallet subsystem from the setting menu.

When I did so, the notification went away but now my pc doesn’t remember any of my WIFI password even after I enter them. Every time I login I have to enter it again to reconnect.

Classic XY problem.
If a solution creates a new problem, it likely wasn’t the right fix. Better undo it and try something else.


KDE uses KWallet to remember user passwords. Now you disabled it, it has to ask them every time.


Not precise enough to be able to help.


I guess you’d need to replace it with a new one.

I did create a new gpg key but is there a way to make so that Manjaro uses this new one as the default key?

I enabled KWallet again and rebooted my pc. Now it asks for KWallet’s password when I login and not the Wifi password.

Sorry, i don’t know much about that.
https://wiki.archlinux.org/title/GnuPG

I don’t know much about that either, but have you tried to give it YOUR password?
… my thinking behind this is:
your password will open the wallet - it has to be “opened” somehow -
and then (and only then) can you use it to store other things - like your wifi password