I installed Linux today and i cant get access Windows

I installed Linux today with SomeOrdinaryGamers (mutahar) tutorial and i think i did a mistake. I have 2 drives and manjaro and windows are on different ones. For some reason i cant get access windows (it says no OS found when i boot from that drive.) From what i can understand i didn’t dual boot it and i don’t know how to do that. It just seems my windows is lost forever. If someone can tell me how to dual boot manjaro without having access to windows that would be great but a guide to uninstalling manjaro without having access to windows (or another os) would be good too.

Hello, follow this thread Os-prober, and grub can't find windows 10

(btw, your desktop environment is not relevant to the issue)

thanks im looking into it now

I can see the boot menu but windows is not appearing. I have tried re installing manjaro on the same drive where i have windows and running the command there but this didn’t work.

Perfect! You couldn’t do a better thing today :+1: :joy: Now whatfor you need help, having the best OS in your PC already, I don’t know…

1 Like

:sweat_smile: :upside_down_face:

I have had problems with accessing windows since i installed manjaro (more info on my first post). I have tried all the fixes that people told me but windows does not pop up on the menu. I know it exists cause i can see it in my folders but when i select the drive that it is in it just says no OS. I have tried re installing manjaro on that drive but that did nothing and still i cant access my windows please help.

So why you duplicate posts, one is enough.

1 Like

did you try to install manjaro on the same hard disk as windows?
did you make sure to select the manjaro and win hard drive as master boot record?

I dont know what that means

So you have overwritten Windows or installed alongside?

What is the output of the command:

sudo update-grub

Before i had two volumes of windows on different drives and i overwrote one to install manjaro on the one i didnt use but when i tried fixing the problem by re installing it i clicked install alongside.

Before it fixed it and i could see the boot menu (windows did not appear) but now it just says my username is not in the sudoers file. This incident will be reported

Should i re install windows from a flash drive and then re install manjaro in a way that windows works?

i fixed it, when i type sudo update-grub it says:
Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.9-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.9-x86_64.img
Found initrd fallback image: /boot/initramfs-5.9-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
It’s output will be used to detect bootable binaries on them and create new boot entries.
gFound Manjaro Linux (20.2.1) on /dev/sdb4
Adding boot menu entry for UEFI Firmware Settings …
Found memtest86+ image: /boot/memtest86+/memtest.bin

Hi @stathis, you said you ‘fixed it’. I cannot find windows from the output you showed.
You can also show code or terminal output with triple back ticks on both sides (```). Its on the left of the ‘1’ key

Nice to see another SOG fan :grin:

Thanks but i didn’t fix anything really, im stuck on manjaro. the only thing i fixed was the twelfth post of this thread (2nd part)

Update: so it turns out that my problem is that the partition that used to be bootable with windows was converted into a basic data partition when i installed Linux. I don’t know how or why but if anyone knows how to fix pls help.

Hi. I installed Manjaro yesterday and formatted my existing EFI partition which contained my old Linux and my Windows. Looks like you’re using UEFI so hopefully this helps.

Using a bootable Windows USB in troubleshooting mode: I had to recreate the Windows EFI boot data and bootloader configuration into my existing EFI partition, which contained the Manjaro boot.

Note: I didn’t need to create a new EFI partition or MBR record. Merely copy EFI boot files from my Windows disk into my existing EFI partition.

The drive letters you need to add to the config are what you can see in the troubleshooting mode. e.g. “bcdedit /store BCD /set {default} device partition=c:” my Windows partition was assigned letter D in the troubleshooting mode, so I used “partition=d:” instead of c.

Once this was all done, I went back into Manjaro and ran an update-grub and it found my Windows install.

I can’t include links in my posts so I’ll try to pm you the URL.

edit: can’t pm either.

https {colon} //medium {dot} com/@hetmansoftware/how-to-restore-the-structure-of-deleted-efi-partitions-in-windows-653a68b5c09f

1 Like