I have to reinstall my Nvidia drivers after every reboot

I’m sorry to come bother you with such a common problem but it is annoying and I cannot find the missing configuration … I am the happy owner of an RTX 2060 on my fixed pc (which also has an igpu intel i5-8600) but I only use the 3 displayport ports of my graphics card (nothing connected to the hdmi output of the igpu). I disabled the igpu on my bios (no way to check if it really disables it). When I boot I have no image but only a tty. Currently I just have to log in, run this command (mhwd -i pci video-hybrid-intel-nvidia-455xx-prime -f) to reinstall the drivers and tadam it works.
My first mistake is maybe that I am using the hybrid driver but since the igpu is deactivated I should rather turn to the nvidia only? Because of the too recent kernel? I still have to install the reverse prime despite the fact that the igpu is disabled?

As you will see inxi -G isn’t able to find the driver

Here are some order returns that may help you find the missing thing (commands launched before re-installing the drivers) :

mhwd-kernel -li

e[32mCurrently running:e[0m 5.9.8-2-MANJARO (linux59)
The following kernels are installed in your system:
   * linux58
   * linux59

mhwd -li

e[1me[31m> e[mInstalled PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-450xx-prime            2020.10.04               false            PCI
     video-modesetting            2020.01.13                true            PCI

e[1me[31mWarning: e[mNo installed USB configs!

inxi -G

Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] driver: N/A 
           Display: server: X.org 1.20.9 driver: nvidia unloaded: modesetting tty: 128x48 
           Message: Advanced graphics data unavailable in console for root. 

inxi -Fazy

  Kernel: 5.9.8-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/vmlinuz-5.9-x86_64 
  root=UUID=94b527ce-2de5-44d9-b369-cd21e29f0c41 rw quiet 
  Console: tty 2 Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: H370AORUSGAMING3WIFI v: N/A 
  serial: N/A 
  Mobo: Gigabyte model: H370 AORUS GAMING 3 WIFI-CF serial: N/A 
  UEFI: American Megatrends v: F12a date: 01/18/2019 
  Info: 6-Core model: Intel Core i5-8600 socket: LGA1151 (U3E1) note: check 
  bits: 64 type: MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
  stepping: A (10) microcode: DE L1 cache: 384 KiB L2 cache: 9216 KiB 
  L3 cache: 9000 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 37213 
  Speed: 800 MHz min/max: 800/4300 MHz base/boost: 4059/8300 volts: 1.1 V 
  ext-clock: 100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 
  6: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled 
  Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] vendor: Micro-Star MSI 
  driver: N/A alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0 
  chip ID: 10de:1f08 
  Display: server: X.org 1.20.9 driver: nvidia unloaded: modesetting 
  alternate: fbdev,nouveau,nv,vesa tty: 128x48 
  Message: Advanced graphics data unavailable in console for root. 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Sound Server: ALSA v: k5.9.8-2-MANJARO 
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
  bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlo1 state: down mac: <filter> 
  Device-2: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel 
  port: efa0 bus ID: 00:1f.6 chip ID: 8086:15bc 
  IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IF-ID-1: br-67cad597028c state: down mac: <filter> 
  IF-ID-2: br-82702b02d64f state: down mac: <filter> 
  IF-ID-3: br-93afd3d0a9b5 state: down mac: <filter> 
  IF-ID-4: br-efea58eda626 state: down mac: <filter> 
  IF-ID-5: docker0 state: down mac: <filter> 
  Local Storage: total: 3.18 TiB used: 64.54 GiB (2.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST2000DM006-2DM164 
  family: Barracuda 3.5 size: 1.82 TiB block size: physical: 4096 B 
  logical: 512 B sata: 3.1 speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
  rev: CC26 temp: 36 C scheme: GPT 
  SMART: yes state: enabled health: PASSED on: 238d 4h cycles: 1096 
  read: 112.65 TiB written: 7.46 TiB Pre-Fail: attribute: Spin_Retry_Count 
  value: 100 worst: 100 threshold: 97 
  ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO 500GB family: based SSDs 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B sata: 3.1 
  speed: 6.0 Gb/s serial: <filter> rev: 1B6Q temp: 27 C scheme: GPT 
  SMART: yes state: enabled health: PASSED on: 238d 10h cycles: 1101 
  written: 29.50 TiB 
  ID-3: /dev/sdc vendor: Western Digital model: WD10EZRX-00L4HB0 family: Green 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B sata: 3.0 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A01 temp: 32 C 
  scheme: MBR 
  SMART: yes state: enabled health: PASSED on: 161d 23h cycles: 1232 Old-Age: 
  UDMA CRC errors: 154 
  ID-1: / raw size: 99.40 GiB size: 97.34 GiB (97.93%) used: 43.98 GiB (45.2%) 
  fs: ext4 block size: 4096 B dev: /dev/sdb5 
  ID-2: /boot raw size: 1.00 GiB size: 975.9 MiB (95.21%) 
  used: 112.3 MiB (11.5%) fs: ext4 block size: 4096 B dev: /dev/sdb1 
  ID-3: /home raw size: 100.00 GiB size: 97.93 GiB (97.93%) 
  used: 20.43 GiB (20.9%) fs: ext4 block size: 4096 B dev: /dev/sda1 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 10.00 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb8 
  System Temperatures: cpu: 44.0 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 177 Uptime: 3m Memory: 47.00 GiB used: 289.8 MiB (0.6%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: apt: 0 pacman: 1372 
  lib: 385 flatpak: 0 Shell: Bash v: 5.0.18 running in: tty 2 inxi: 3.1.08 

mhwd-gpu --status
:: status
xorg configuration file: ‘/etc/X11/mhwd.d/nvidia.conf’

cat /etc/modprobe.d/mhwd-gpu.conf

## Generated by mhwd - Manjaro Hardware Detection
blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm
options nvidia "NVreg_DynamicPowerManagement=0x02"

cat /etc/X11/mhwd.d/nvidia.conf

## Generated by mhwd - Manjaro Hardware Detection
(empty file)

Thanks for you help !

start there.

1 Like

I just tried, I had the same problem after rebooting (I obviously uninstalled the other one before)

So you now have removed video-hybrid-intel-nvidia-450xx-prime and video-modesetting and have installed profile video-nvidia-455xx in mhwd/MSM ?

Yes that’s it.

I can’t post a screenshot but in the config pannel/hardware only video-nvidia-455xx is checked in the installed column

Can you check that those xorg/mhwd confs are not present and/or have changed?
We might try nuking all of those, then force-reinstall, ex:

sudo mhwd -f -i pci video-nvidia-455xx

(PS - I was under the impression that both ‘455’ and linux59(+nvidia) had issues. You might try with 450 and 5.8)

Can you specify which exactly?

I have try 450 with linux59 & 455 with linux58 but never 450 with linux58, i will try after your response


And anything else related.

Ok, thanks. I have just try to removed the confs and force the reinstallation, not working.
After, i installed the 450 version and i booted in linux58, same result

Oh… I notice you have missed some BIOS updates too.

Assuming you have rev. 1.0 of this board …

Where I notice there is mention of stability concerns with DDR4 memory which may be addressed in latest update.

  • Improve DDR compatibility
  • Workaround beta BIOS to improve Kingston DDR4 stability concern on some specific memory chip suppliers.

Hey, i’m back after the update erase all my boot data and as I cannot add an entry manually directly via the bios, I had to use a livecd… (i hate gigabyte for this, asus is really better for that). On linux59 et nvidia-450 still no screen when i boot