I have run into a couple of problems with the KDE


I have run into a couple of problems with the KDE. This happened after I did a recent update of programs and I moved around some icons in the panel.

  1. The KDE panel no longer displays minimised programs and no longer displays a small preview when you hover the cursor over it.

  2. Programs no longer minimise to the taskbar. They remain active in the background - you can see them via KSysGuard - but they are not in the taskbar.

Something broke - I hope you can help me fix it. I don’t have a lot of Linux experience.

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.15-1-MANJARO
OS Type: 64-bit
Processors: 4 × AMD FX™-4100 Quad-Core Processor
Memory: 7.8 GiB of RAM
Graphics Processor: AMD CEDAR

Many thanks
Chris Cooper

Welcome to the forum! :slight_smile:

Yes, something broke, but you’re the one who broke it, and you can also fix it again. :grin:

Here’s the thing… What you call the task bar isn’t a task bar; it’s a panel. Plasma allows you to have multiple panels, or none at all ─ whatever you wish. Panels can hold icons and widgets ─ so-called plasmoids.

One of these widgets is a task manager widget ─ there are alternatives too, but I’ll get into that in a minute. So, what happened is that when you were moving stuff around, you may have accidentally deleted the task manager widget, or you may have moved it off of the panel and onto the desktop, where it is now invisible because the panel is covering it.

Here’s what you should do… Right-click the desktop and choose “Enter Edit Mode”. Then, right-click the panel and choose “Edit Panel”. Now, temporarily, just so as to see whether you’ve moved the task manager off of the panel and onto the desktop, drag your panel to the top of the screen ─ or to the bottom of the screen if it was at the top already ─ or to either the left or right edge. If the task manager is indeed on the desktop, then you should now be able to see it, and delete it (by right-clicking it and choosing “Remove Widget”).

If the task manager is not there, then you can put your panel back where it used to be, and then you right-click the panel again and choose “Add Widgets”. You will then see a list of available widgets on the left side of the screen. Choose one of the available task managers ─ there’s a conventional one which shows the name of the running application, and there’s an icons-only one, which only shows the icons ─ and drag it to the position on the panel where you want it.

When you’re done, don’t forget to exit the edit mode by right-clicking the desktop again and choosing the appropriate option. :wink:

1 Like

Many thanks Aragorn, that fixed it straight away.
The task manager has a separate icon for every task now - before it used to stack similar items under 1 icon. But that is a small point - you have solved the problem.
Many thanks again Aragorn.

1 Like

Hi @superkde, and welcome!

I’m glad you got your ‘taskbar’ back! It took me a while to understand the concept as well.

Regarding your second point, right-click on the taskbar, and select the “Configure…” option.

In the popup window, you can then configure mentioned behaviours of the taskbar.

Also, have a look in System settings, available from the launcher, where you can configure much, much more.

1 Like

As @Mirdarthos said, this is configurable. :slight_smile:

Right-click the task manager and choose “More Actions”. At the bottom of the new popup menu, you will see an option to configure the task manager. If you click that, you get a configuration screen. Click on “Behavior” in that screen, and then you can select whether you want to group windows together or not. :wink:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.