I have a problem installing and booting linux

After I start a download or open any distro, the install/boot will just freeze and it won’t work, I’m pretty sure the problem is with my drivers, I’m using rtx 2070 super.
When I press Ctrl+alt+f2 I don’t see what I write because the entire thing is corrupted although I think I can write there.
If anyone has any solution and know how to fix it please help.

The nVidia 450 series driver was ported to Manjaro a few days ago, so download the latest version again and boot the USB and provide the output of:

inxi --full --verbosity=7 --filter --no-host --admin

so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…


1 Like

I’m sorry I’m a bit inexperienced, what do you mean by the output of inxi --full --verbosity=7 --filter --no-host --admin?

you run this command in terminal and copy/paste here the output (use here btn </> for format text)

1 Like

what I meant by the install freezes is that it doesnt get to the home screen where you start calamares from, I now tried to select drivers as nonfree in the options and it seems to work, here’s the output of the command:

Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64
root=UUID=c9c3114d-1964-4361-8f24-1395b4df77c4 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.18.5 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux
Type: Desktop Mobo: ASUSTeK model: H110M-K v: Rev X.0x serial:
UEFI: American Megatrends v: 4210 date: 06/25/2019
Device-1: hidpp_battery_0
model: Logitech G305 Lightspeed Wireless Gaming Mouse serial:
charge: 100% (should be ignored) rechargeable: yes status: Discharging
RAM: total: 7.72 GiB used: 844.7 MiB (10.7%)
RAM Report:
permissions: Unable to run dmidecode. Root privileges required.
Topology: Quad Core model: Intel Core i5-7400 bits: 64 type: MCP
arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: CA
L2 cache: 6144 KiB bogomips: 24008
Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800
Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est
f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window
hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single
lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc
nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt
pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss
ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave
xsavec xsaveopt xsaves xtopology xtpr
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: disabled, RSB filling
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: eVga.com.
driver: nvidia v: 440.82 bus ID: 01:00.0 chip ID: 10de:1e84
Display: x11 server: X.Org 1.20.8 driver: nvidia compositor: kwin_x11
resolution: 1920x1080~60Hz, 1440x900~60Hz
OpenGL: renderer: GeForce RTX 2070 SUPER/PCIe/SSE2
v: 4.6.0 NVIDIA 440.82 direct render: Yes
Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170
Device-2: NVIDIA TU104 HD Audio vendor: eVga.com. driver: snd_hda_intel
v: kernel bus ID: 01:00.1 chip ID: 10de:10f8
Device-3: Logitech Webcam C170 type: USB driver: snd-usb-audio,uvcvideo
bus ID: 1-3:2 chip ID: 046d:082b
Sound Server: ALSA v: k5.6.15-1-MANJARO
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus ID: 03:00.0
chip ID: 10ec:8168
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac:
IP v4: type: dynamic noprefixroute scope: global
IP v6: type: noprefixroute scope: link
Local Storage: total: 1.27 TiB used: 8.32 GiB (0.6%)
ID-1: /dev/sda vendor: SanDisk model: SDSSDA120G size: 111.79 GiB
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
serial: rev: 80RL scheme: GPT
ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-08WN4A0
size: 931.51 GiB block size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s rotation: 7200 rpm serial: rev: 1A01
scheme: MBR
ID-3: /dev/sdc vendor: Samsung model: SSD 860 EVO 250GB
size: 232.89 GiB block size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s serial: rev: 4B6Q scheme: GPT
ID-4: /dev/sdd type: USB vendor: SanDisk model: USB Flash Drive
size: 28.64 GiB block size: physical: 512 B logical: 512 B
serial: rev: 1.00 scheme: MBR
Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GH24NSD1 rev: LB00
dev-links: cdrom
Features: speed: 12 multisession: yes audio: yes dvd: yes
rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Message: No RAID data was found.
ID-1: / raw size: 232.59 GiB size: 227.94 GiB (98.00%)
used: 8.32 GiB (3.6%) fs: ext4 dev: /dev/sdc2 label: N/A
uuid: c9c3114d-1964-4361-8f24-1395b4df77c4
ID-2: /boot/efi raw size: 300.0 MiB size: 299.4 MiB (99.80%)
used: 280 KiB (0.1%) fs: vfat dev: /dev/sdc1 label: N/A uuid: 15F1-3D32
ID-1: /dev/sda1 size: 16.0 MiB fs: label: N/A uuid: N/A
ID-2: /dev/sda2 size: 111.38 GiB fs: ntfs label: N/A
ID-3: /dev/sdb1 size: 1 KiB fs: label: N/A uuid: N/A
ID-4: /dev/sdb5 size: 931.51 GiB fs: ntfs label: gaming
uuid: 88F810FAF810E7E8
ID-5: /dev/sdd1 size: 28.61 GiB fs: exfat label: Ventoy uuid: 4E21-0000
ID-6: /dev/sdd2 size: 32.0 MiB fs: vfat label: VTOYEFI uuid: 1B29-1491
Hub: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0
speed: 480 Mb/s chip ID: 1d6b:0002
Device-1: 1-3:2 info: Logitech Webcam C170 type: Video,Audio
driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s
chip ID: 046d:082b
Device-2: 1-4:3 info: Logitech USB Receiver type: Keyboard,Mouse,HID
driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0
speed: 12 Mb/s chip ID: 046d:c53f
Device-3: 1-5:4
info: Cambridge Silicon Radio Bluetooth Dongle (HCI mode)
type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
chip ID: 0a12:0001
Device-4: 1-6:5 info: Microdia USB DEVICE type: Keyboard,Mouse
driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
chip ID: 0c45:8513
Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0
speed: 5 Gb/s chip ID: 1d6b:0003
Device-5: 2-2:2 info: SanDisk USB Flash Drive type: Mass Storage
driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s
chip ID: 0781:5584 serial:
Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0
speed: 480 Mb/s chip ID: 1d6b:0002
Hub: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1
speed: 10 Gb/s chip ID: 1d6b:0003
System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 47 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 185 Uptime: 25m Init: systemd v: 245 Compilers: gcc: 10.1.0
Shell: bash v: 5.0.17 running in: konsole inxi: 3.0.37

  1. Next time, please use ``` to delimit your output so it looks like this:
  1. you have the 440;82 driver installed, so:

    • Log off

    • Switch to TTY2 by pressing Ctrl+Alt+F2

    • Log in there

    • Execute:

      sudo mhwd --install pci video-nvidia-450xx
  2. You have an EOL kernel installed:


    sudo mhwd-kernel --install linux57
    sudo reboot
  3. Hrmph… I forgot about:

    So try downloading again in a couple of days… I’ll contact the devs to know when the new ISO will be updated.

No don’t worry about the TTY it’s in the arch option and it happened before I did nonfree

I can’t download the driver, it shows an output of config 'video-nvidia-450xx' does not exist!

It takes a lot of testing before they release a new version.

Download and try again when the 20.1 version gets released as an ISO.

Sorry! (this only happens 3-4 times / year…)

P.S. Your hardware is rather new and that’s the culprit…
P.P.S. unless pamac upgrade works on a USB stick (never tried myself)
P.P.P.S. unless you have access to another machine, install from one USB stick to another USB stick and then upgrade the 2nd USB stick on the other machine and then boot your machine with that one…

No it’s fine I can enter the tty2 now but it won’t let me install video-nvidia-450xx because it says it doesn’t exist

pamac upgrade first… Then see if it becomes available… (It’s only a few days old…)


Ahh you are still in the live usb session and have not installed yet i presume?
It would seem your graphics-card is not well supported yet by the open-source nouveau driver and needs the nonfree drivers. To install simply start the live system again with the nonfree drivers selected and install via calamares. The correct (in this case nonfree) drivers should be installed aswell with this.

And as you have already found out what the tty is, you should always update while beeing in the tty to make sure currently used parts of the programs don’t try to access the updated parts while in the update process, as it somtimes can break things.
You can easily update with pamac upgrade and after that restart the system with shutdown -r now.

@Fabby he doesn’t need to update first. The provided 440xx series nvidia driver will work well enough as it supports his gc.

Everything is working great, I have linux57 and I’ll keep it at 440xx for now.
Thank for everyone who helped!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.