I got a warning after running the latest round of updates; I'm confused what to do next


#1

So after running the most recent round of updates, at the conclusion fo the process I got the following message:

“directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700”

I clicked on the “close” button and that seemed to be the end of it. No more warnings, no new updates, no follow up messages.

Why did I get this message? What does it mean? And how can I address it?

Edit: I want to clarify that I don’t believe I have ever touched that folder (I may have installed apps that have touched it, but I consciously never have).


#2

The answer is in the thread about the latest stable update here (Troubleshooting guide - scroll down a bit).

EDIT:
the correct answer is provided by fhdk in a post below.

It means that the permissions of this directory must be set to 700 (or drwx------).

Try this (as suggested in the original thread):

sudo chmod 700 /var/lib/samba/private/


#3

another option if you don’t use any windows file shares is to remove samba which is what I did. there’s no point having a couple of services installed that aren’t used.


#4

Actually it means the opposite.

The filesystem is 755 when the package expects it to be 700.

So the right thing to do is to set permissions as the package expects it to be.

sudo chmod 700 /var/lib/samba/private/

You don’t need to. It is probably a fix since the folder mentioned is named private and as such is a folder that samba uses for stuff like certificates, keys, private keys, and so on.

Such folder is only accessible for the system service running samba and the service will presumably refuse to run if permissions is wrong.

Try that with your .gnupg folder or the .ssh folder. If permissions is world readable you will get complaints from application and some even refuses to run unless only accessible by owner aka chmod 700 ~/.ssh -R as an example.


#5

Thank you for providing the answer, but I’m still confused as to how this happened.

Surely if an update required that setting, then it should have done so…or a prior update should have done so.

I’m just sort of frustrated taht I’m running my system as I should be, and it is still running into various bugs/errors.


#6

Computer systems - and the software needed to operate them - are in nature extremely complex.

Everybody - including Microsoft, Apple and various Linux distributions do everything in their power to do it right the first time.

However - because we are humans - errors slip in. We cannot avoid - just accept it and cope with them as they occur.

When you have an issue - do as you did now - ask here in the forum - and remember we are humans just like you, sometimes with the same frustrations that things do not operate as we expect.

There is no stupid questions - you wouldn’t ask if you knew the answer - hence only stupid answers exist.


#7

Well I guess Manjaro could change the default permissions to 777. Then it will be just like Windows, totally insecure. :smile:


#8

But how did you do it? I wanted to do this both times the error occurred during Testing Updates, but Pamac indicated “bad things” lay ahead if i proceeded, so i chickened out:


#9

Just run

sudo pacman -R samba

If samba has been installed as a dependency then using -Rns will remove all other dependencies - which is not always a desired behavior.

Using Pamac to uninstall will in most circumstances use -Rns so using the terminal is the way to go.

Unless using the functionality of sharing folders from your system to other systems on the network - users do not need samba.

It is often installed as a dependency of the other packages - e.g.

  • manjaro-settings-samba
  • thunar-shares-plugin-manjaro
  • thunar-shares-plugin
  • nautilus-share
  • nemo-share

These packages exist on some of the full blown ISO’s as a way of providing the best OOBE as possible.

If you only need to access files - eg stored on a home NAS or a windows computer then the package smbclient and gvfs-smb will provide that access.


#10

I just replied to another topic (having other troubles with the update) and my sentiment is definitely not to chastise, or diminish in anyway, all the hard work everyone is doing. Its just getting frustrated at things not working (while not blaming anyone or denigrating them).

My overrriding fear is that these manual fixes mean that my system is corrupted in some way.

And also, I’m striving to be the catalyst to get several people in my immediate circle to switch to Linux; and it is irritating (again while being fully cognizant of the enormous effort others are putting in) that it doesn’t work as its supposed to. And for them, just their mindset is that any slight against Linux, condemns the entire endeavor.

Just frustrated I guess.


#11

:+1:
If you don’t need samba then by all means uninstall it using the terminal.

sudo pacman -R samba

That will effectively remove this issue.


#12

I just removed samba and manjaro-settings-samba using octopi, there were no warnings and the systems have been fine since


#13

Thank you & also @micsim35. I have run that command now, apparently successfully… but what do i do please about libwbclient? Just leave it alone, or also remove it? [it is listed as a dependency for cifs-utils smbclient, which in turn have their own complex dependency chains (this feels like i am disappearing down Alice’s rabbit hole)]:

$ pacman -Qi smbclient
Name            : smbclient
Version         : 4.7.6-1
Description     : Tools to access a server's filespace and printers via SMB
Architecture    : x86_64
URL             : http://www.samba.org
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : popt  cifs-utils  tdb  libwbclient>=4.7.6  ldb  tevent  libgcrypt  python2  talloc  readline  gnutls  libbsd  libldap  libcups
Optional Deps   : None
Required By     : gvfs-smb  kdebase-runtime  kio-extras  mpd  mplayer  mpv  python-pysmbc  samba
Optional For    : vlc-nightly
Conflicts With  : None
Replaces        : None
Installed Size  : 24.95 MiB
Packager        : Tobias Powalowski <tpowa@archlinux.org>
Build Date      : Tue 13 Mar 2018 23:53:57 AEDT
Install Date    : Mon 19 Mar 2018 13:57:45 AEDT
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

[kdemeoz@GA-Z97-HD3-Tower ~]$ pacman -Qi cifs-utils
Name            : cifs-utils
Version         : 6.7-2
Description     : CIFS filesystem user-space tools
Architecture    : x86_64
URL             : http://wiki.samba.org/index.php/LinuxCIFS_utils
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : libcap-ng  keyutils  krb5  talloc  libwbclient  pam
Optional Deps   : None
Required By     : smbclient
Optional For    : udevil
Conflicts With  : None
Replaces        : None
Installed Size  : 187.00 KiB
Packager        : Tobias Powalowski <tpowa@archlinux.org>
Build Date      : Fri 17 Mar 2017 22:50:28 AEDT
Install Date    : Thu 26 Oct 2017 22:38:08 AEDT
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

#14

if in doubt, leave it alone. I don’t think we have the same system configurations


#15

If you do not access files on other computers eg. a NAS which offers windows like shares then you can uninstall it - the same goes for cifs-utils. They are only used as means to access files across a network.

However they can be dependencies of other packages which you use.

KDE has a lot of built-in functionality and some of that functionality might depend on said packages.

You can try the same uninstall approach and if you from the message sees that packages you use will get uninstalled too then better let them be. :slight_smile: They do no harm.


#16

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.