I can't update AUR and other packages in Pamac


when i do pamac update i get the following error message

Checking brave-bin dependencies...
Checking ulauncher dependencies...
Error: Failed to prepare transaction: invalid or corrupted database

Edit build files : [e] 
Apply transaction ? [e/y/N] y

Transaction cancelled.

The error also occured when i tried to install copyq (official repo), but worked manually with pacman -S.
Flatpak packages over the GUI also didnt work, but did work in the terminal.

After being new to this forum due to this problem, that i could’nt fix myself threw research (still), i had an unfavorable start in this thread (same topic) Pamac is broken - #19 by linux-aarhus
I apologize to those who wasted their time on me. I hope you’ll be willing to help me after all. If so, i will provide you with the information you need.

I tried to do pamac update after i turned all the 3rd party options off as @philm suggested here Pamac is broken - #21 by philm
This is the result:

Nothing to do.
Transaction successfully finished.

Pamac is broken - #16 by Mirdarthos @Mirdarthos

Safely check for updates without modifiying the databases
(Exit code is 100 if updates are available)

pamac checkupdates [options]

  --builddir <dir> : build directory (use with --devel), if no directory is given the one specified in
                     pamac.conf file is used
  --aur, -a        : also check updates in AUR
  --no-aur         : do not check updates in AUR
  --quiet, -q      : only print one line per update
  --devel          : also check development packages updates (use with --aur)
  --no-devel       : do not check development packages updates

Pamac is broken - #28 by philm @philm

 Kernel: 6.1.60-1-MANJARO arch: x86_64 bits
 Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11
 Manjaro Linux base: Arch Linux

I did try this already.

I did manage to update all my packages separately with yay -S (AUR) and flatpak update, i dont think this fixes the problem longterm, but i keep my system updated after all.

If someone deigns to help me fix the root of the problem, i would be pleased.

sudo pacman -Rns $(pacman -Qsq pamac)
sudo pacman -Syu
yay -Sua
flatpak update

Or, if you intend to keep using pamac … maybe try removing all of its cache, and doing --force-refresh maybe?


pamac upgrade --force-refresh --enable-downgrade --aur --devel

To be honest, I still use yay… yay copyq works fine here.

maybe an update alias yup='yay && flatpak update'

1 Like

Pamac can be a great application - but can also increase the complexity of a sync process or as you call it update.

The root of your problem is complexity.

I suggest you do as @cscs suggests - perhaps not the removal of pamac - but instead of using a multi-purpose tool - split the process using the tool designed for that process.

multi-purpose tools is like a swiss army knife - they become cluttered and hard to use …

  • system packages from repo
     sudo pacman -Syu
  • custom build scripts - use an AUR helper which can be targeted to rebuild custom scrips only
  • flatpak - use flatpak’s own update command

Use AUR to notify when your preferred scripts has been updated or use home brewed script like

Also bear in mind that using AUR always assumes an Arch Linux system - and this may not equal a Manjaro system - unless you are using unstable branch.

1 Like

Pamac is currently frozen, most crash related bugs on GitLab are not treated or even discussed.

Pamac has a serious problem of synchronization with Manjaro repos, it’s recommended to use yay that connects directly to Arch repos to install your wanted AUR packages.

I thought it would work. The following is the output of your command.

patching file configure.in
Hunk #1 succeeded at 1106 (offset 1 line).
Hunk #2 succeeded at 1115 (offset 1 line).
patching file export/export_im.c
patching file filter/filter_compare.c
patching file filter/filter_logoaway.c
patching file filter/filter_logo.c
patching file import/import_im.c
patching file import/import_imlist.c
patching file import/probe_im.c
patching file import/demux_pass.c
patching file import/extract_ac3.c
patching file import/extract_mp3.c
patching file import/v4l/import_v4l2.c
/var/tmp/pamac-build-q/transcode/PKGBUILD: line 29: autoreconf: command not found
==> ERROR: A failure occurred in prepare().

Ok, i would like to do that and use other ways to sync in the future, but how do i do it? How do i switch? I mean sudo pacman -Syu isn’t working either. I will read your linked posts, but maybe you can help me with it.

Even from the commandline, if i do sudo pacman -Syu, should’nt that work?

You don’t have base-devel installed.

sudo pacman -S base-devel

You should do some reading.


If i try to run your script found in [root tip] [HowTo] Check if your AUR build scripts have been updated for example the output is just transcode%

yaydoesnt work either. Its always transcode now, but im sure next time it will be something new, something different that causes trouble, even if i (we) manage to find a solution

/home/pov/.cache/yay/transcode/PKGBUILD: line 29: autoreconf: command not found
==> ERROR: A failure occurred in prepare().
 -> error making: transcode-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
transcode - exit status 4

Oh, how did you could you see that?

It complains about a missing program during the build process. You need base-devel to build AUR packages, as the link I posted states.

You can see autoreconf is from the autoconf package, which is part of base-devel:

$ pacman -F autoreconf
core/autoconf 2.71-4 [installed]
extra/bash-completion 2.11-3 [installed]

$ pacman -Si base-devel
Repository      : core
Name            : base-devel
Version         : 1-2
Description     : Basic tools to build Manjaro Linux packages
Architecture    : any
URL             : https://www.manjaro.org
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : archlinux-keyring  autoconf  automake  binutils  bison  debugedit  fakeroot  file  findutils  flex  gawk  gcc  gettext  grep  groff  gzip  libtool  m4  make  manjaro-keyring  pacman  patch  pkgconf  sed  sudo  texinfo
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 23.06 KiB
Installed Size  : 0.00 KiB
Packager        : Mark Wagie <mark@manjaro.org>
Build Date      : Tue 21 Feb 2023 16:32:58 GMT
Validated By    : MD5 Sum  SHA-256 Sum  Signature
1 Like

I see, thank you very much. Can you explain yourself why i missed that package? Did i do something that got rid of it or how can it just miss?

It’s not installed by default.

You’re meant to read the link I posted before using the AUR, which tells you to install base-devel.

I’ve quoted it here:

First, ensure that the necessary tools are installed by installing base-devel; this meta package has make and other tools needed for compiling from source, listed as dependencies.

Note: Packages in the AUR assume that base-devel is installed in the build environment.

1 Like

Though it looks like it, im not new to Manjaro. I have it for over 5 years now. Why should a so important package miss from the start and until now i never had a problem with it. Sorry, im sure it makes sense to you, not for me. I would appreciate you explaining if you can.

Probably because base-devel used to be a group and was changed to a meta package, this required reinstalling base-devel.

I imagine you haven’t installed/updated any AUR packages since before the change, or if you did then they didn’t require anything from base-devel.

1 Like