I can't switch to free graphics drivers

i3

#1

When I installed the distro I selected the non-free drivers, but I have some tearing, besides that the Catalyst Configuration Center does not open, if I try to open it from the terminal I get

amdcccle: error while loading shared libraries: libQtGui.so.4: can not open shared object file: No such file or directory`

So I wanted to switch to free drivers to see my performance. I uninstalled catalyst with sudo mhwd -r pci video-catalyst and installed the free drivers with sudo mhwd -a pci free 0300. When restarting I got an error that says

[FAILED]: Failed to start Light Display Manager

so I had to enter the terminal (Ctrl + Alt + F2) and return to catalyst.

Does anyone know what this error is due to and how can I install the free drivers? or how can I open catalyst to change the settings? Thanks.


#2

Support for the Catalyst driver has been dropped. They have been deprecated.


#3

This worked. I did not know that catalyst had been discontinued, until a few months ago I used it in XFCE. With the free drivers the tearing was solved besides the animations are more smooth. Thanks!


#4

Awesome, so glad that fixed things up for you.


#5

that should not work as there is no video-ati in mhwd anymore. Now it is called video-linux.
Glad that it worked anyway.

Edited the linked post to display the current working mhwd command.

Edit: @philm it seems that now the catalyst control center is broken due to changes in Qt.


#6

I assume he figured that out if used the outdated command. Thanks for updating your post.