I can't share my screen

hey there,
today while i was in my online class , my tutor asked me to share my screen to check my program . bu t when i tried to do it it only shares a blank screen with a mouse pointer. i was on manjaro gnome , firefox , google meet . i had the same experience while i was using discord. when i tried to share the screen it only shares the blank screen with mouse pointer. how can i fix this ?

Please post the output of inxi -Fazy. I believe this is caused by you using a Wayland compositor.

  Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=259aae08-fc59-4ec8-a4db-e26e2d716fa4 rw quiet udev.log_priority=3 
  Desktop: GNOME 3.38.1 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.38.2 
  Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505DY_FX505DY v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: FX505DY v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: FX505DY.315 date: 03/09/2020 
  ID-1: BAT0 charge: 37.1 Wh condition: 38.1/48.0 Wh (79%) volts: 11.9/11.9 
  model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Not charging 
  Info: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 18 (24) 
  stepping: 1 microcode: 8108102 L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 33548 
  Speed: 1222 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 
  1: 1223 2: 1282 3: 1222 4: 1222 5: 1397 6: 1396 7: 1338 8: 1395 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67ef 
  Device-2: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
  bus ID: 04:00.0 chip ID: 1002:15d8 
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus ID: 1-4:3 chip ID: 13d3:56a2 serial: <filter> 
  Display: wayland server: X.org 1.20.9 compositor: gnome-shell driver: amdgpu 
  note: display driver n/a - try sudo/root display ID: 0 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.38.0 
  5.8.18-1-MANJARO LLVM 11.0.0) 
  v: 4.6 Mesa 20.2.3 direct render: Yes 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 04:00.1 chip ID: 1002:15de 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 04:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.8.18-1-MANJARO 
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: AzureWave driver: rtl8821ce v: N/A modules: 8821ce port: e000 
  bus ID: 02:00.0 chip ID: 10ec:c821 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: down mac: <filter> 
  Local Storage: total: 931.51 GiB used: 53.10 GiB (5.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 0J scheme: GPT 
  ID-1: / raw size: 149.97 GiB size: 146.62 GiB (97.76%) 
  used: 53.08 GiB (36.2%) fs: ext4 dev: /dev/sda6 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 48.5 C mobo: N/A 
  Fan Speeds (RPM): cpu: 3200 
  GPU: device: amdgpu temp: 48.0 C device: amdgpu temp: 45.0 C watts: 7.08 
  Processes: 260 Uptime: 36m Memory: 7.53 GiB used: 1.53 GiB (20.3%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: 
  pacman: 1164 lib: 325 Shell: Zsh v: 5.8 running in: gnome-terminal 
  inxi: 3.1.08

Wayland screen sharing is not nearly as mature as X11 screen sharing.

The simplest and quickest solution is to log out, and before logging in, click on the gear icon in the lower right corner, and select the Xorg/X11 session.

Electron applications can only share the full screen when you are in an X11 session, nonetheless, even in a Wayland session, you should be able to share other X11 applications running in XWayland, just not Wayland-native applications and the full screen.

There is some experimental support for full screen sharing in Firefox and Google Chrome, as far as I’m aware.

1 Like

our result after a lot of tries in screen sharing:
JITSI and chrome/chromium is the best combo for us.
With Firefox and other browsers we have had problems again and again.
Especially when we wanted to share one application window.

1 Like

thanks bro , it’s working now. is there any way i could set xorg as default to load instead of logging out and in again ?

but irrespective of browser , my discord screen sharing is not working also . is this have something to do with the gnome variant ? what is it connected with

Not working in X11? Or not working in Wayland?

I believe it remembers your last choice, although I’m not sure.

both discord and firefox is working fine now.

1 Like

wow nice! Glad to hear about it. Thanks for sharing.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.