I can't install Sublime Text 4

Hi, I need help, I can’t install sublime text 4, on Manjaro kde, I have update the mirrors 6 or 7 times, and there is not enought, please I need your help,

This is the error:
no se pudo descargar sublime-text.db
error: no se pudo obtener el archivo «sublime-text.db» desde
“download sublimetext com”: Resolving timed out after 10000 millisecon

Thank you

You seem to have some problem with your network connection or your DNS servers. Your computer seems to not be able to resolve the IP of that address (download.sublimetext.com). Can you manually download the file from Sublime website?

I don’t know if you’re using AUR or if you’ve followed the instructions on sublimetext.com for adding a repository to pacman for Arch but updating your mirrors wont help in this situation since you’re trying to download from a specific website.

on both options AUR / instructions of sublime web don’t work…

Thank you, with the download I could install sublime text,
but if I tried to update the system, I got the same error.

Add the sublime text repo to your pacman.conf - follow the instructions on their web