I can't install Manjaro KDE anymore. Getting errors on the installer when ever I do

So, for a little bit of backstory.

What ended up happening is that I switched to KDE Manjaro a few days ago (moved from windows 10). First install went great. I got KDE running and all was good, up until I installed a few applications that pretty much prevented me from loading back into Manjaro after I rebooted. (all I got was a black, blank screen that did not show anything what-so ever.) That ended up making me reinstall Manjaro from the USB I have.

A few errors happened and prevented me from reinstalling Manjaro, but were somehow resolved after I did something. (not sure what I did, to make it work again.) And I installed the OS once again.

After a day of getting back up to pace, the same thing happened again after I restarted my Laptop ( Black, blank screen that didn’t let me boot into anything, and for my laptop it’s an HP laptop that came bundled with windows 10.) Anything else I tried didn’t seem to work, so I was forced to try and reinstall Manjaro KDE once again. only this time…

I can’t.

I tried erasing the drive, replacing the partition… I haven’t tried doing manual partitioning or any other option than those two. (I fear screwing up anything further that I can manage.)

The error I get is this.

Boost.Python error in job “bootloader”.

Command ‘grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force’ returned non-zero exit status 1.

Installing for x86_64-efi platform. Could not prepare Boot variable: No space left on device grub-install: error: efibootmgr failed to register the boot entry: Input/output error.

Traceback:

File “/usr/lib/calamares/modules/bootloader/main.py”, line 485, in run

prepare_bootloader(fw_type)

File “/usr/lib/calamares/modules/bootloader/main.py”, line 457, in prepare_bootloader

install_grub(efi_directory, fw_type)

File “/usr/lib/calamares/modules/bootloader/main.py”, line 319, in install_grub

check_target_env_call([libcalamares.job.configuration[“grubInstall”],

File “”, line 6, in

So… is there anything I can do to fix this? (I have a small feeling that I’m installing Manjaro in a wrong way tbh.)

1 Like

Hello Odyssey, you may want to verify your BIOS and check if the BIOS has two different environments for Windows 7 and Windows 8 because that would mean you are trying to boot between UEFI/EFI. If you do have Windows 7 as an option, try changing it so that you can boot the USB via the BIOS or boot screen and you should use the name of the USB; not UEFI: NAME OF USB HERE

1 Like

In Windows, I used Rufus to image USBs with Linux ISOs. UEFI/BIOS compatibility is a thing you should watch out for, along with trying to disable Secure Boot in your target machine’s UEFI/BIOS settings.

In the installer, overwriting the partition with the default “automagically install the OS on this drive pls” should be fine; you don’t have to do anything fancy.

After a day of getting back up to pace, the same thing happened again after I restarted my Laptop ( Black, blank screen that didn’t let me boot into anything, and for my laptop it’s an HP laptop that came bundled with windows 10.)

My guess is that two things may be happening:

:one: Your laptop can’t run Linux well. This is a very common issue, and you have to be careful about the kind of laptop you run Linux on, unfortunately. It’s often a crapshoot. Laptops are full of obscure/proprietary hardware and Windows-targeted dependencies. Lenovo laptops (but not all!) are usually the most Linux-friendly (some even come with Linux preinstalled), and are your best bet outside of System76 or Purism. Searching online about your model and whether it runs Linux can give you some anecdata.

:two: If the installer/new install uses kernel 5.10, you might be trying to install at a bad time; kernel 5.10 seems unusually buggy right now (I just hopped back to 5.4 because of it, and it’s the only time I’ve had to in around two years of using Manjaro :sob:).

Of these, :one: is probably the most likely.

If you’re desperate to investigate, when you get a black screen, it could be that the DE (desktop environment, which is your wallpaper, your taskbar, windows, etc.) failed to load (this is unlikely if you can’t see your mouse though). Your DE loads on your “main TTY” (usually located at Ctrl+Alt+F1) and you can go into an alternate TTY (e.g., Ctrl+Alt+F2). This will prompt you to log in (you might have to hit your Num Lock key a few times to re-enable your numpad if you use it to enter your password), and you’ll be in your system without the DE. :milky_way: Here, you might be able to see what happened with the command journalctl, the systemd journal. Hit the End key to go all the way down and PgUp your way to go back in time and see if there’s any likely errors that hint at why the DE crashed.

Also, if you can get a terminal in your main TTY, you can even try restarting the DE by using kstart5 plasmashell.

If you can’t do any of that stuff, though, the crash is probably much more severe. :laughing: