I can't install anything anymore

Since a week ago I couldn’t update kconfig and kcoreadons, I didn’t care about this because I still could install programs normally, it returned a message like “kconfig considered cmake 240 but didn’t accepted it”. now I can’t install anything because qt6, I have already refreshed repositories

Warning: cannot resolve "qt6-x11extras", a dependency of "kwindowsystem-git"
Warning: cannot resolve "qt6-x11extras", a dependency of "kwindowsystem-git"
Error: Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'qt6-x11extras' required by kwindowsystem-git

Solved: I deleted basically everything that starts with K

both of these are AUR packages - probably needed by yet another AUR package

see whether you can dispense of them - if something in the normal repositories is equivalent

or see what needs them and whether you (still) need that

1 Like

did you try rebuilding kwindowsystem-git recently? On AUR there is an comment that the package was broken and needed QT6 build flag to work.

davispuh commented on 2023-02-05 20:46 (UTC)

Doesn’t build anymore. Need to add -DQT_MAJOR_VERSION=6 CMake option now.

while latest AUR update that probably fixed it was

Last Updated: 2023-02-13 00:45 (UTC)

1 Like

There is no such AUR package (yet?).

Why are you using kwindowsystem-git? Just install kwindowsystem from the official repository.

Just install kwindowsystem from the official repository.

now I can’t install it neither uninstall the git one

Just install the repository one, accept the replacement.

At least give every command output instead of letting us guess what we can’t know.