I cant figure out why my wifi wont work

installed pcie wifi card in my computer and can not get to work. other than it showing no wireless extension i dont know what could be keeping it from working

Did you try rebooting? More information about the issue might also help in finding the problem.

What does your system say about your hardware?
inxi -Fazy

well as soon as i figure out how to send it ill show you

and it is apparently gonna be one of those days

Bluetooth tethering via handy to submit your inxi and other output?

  Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=d6f33eef-d787-49b9-8316-c56d7b7be78b ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop System: LENOVO product: 10KY002AUS v: Lenovo S510 
  serial: <filter> Chassis: type: 3 serial: <filter> 
  Mobo: LENOVO model: SKYBAY v: SDK0J40697 WIN 3305021491209 serial: <filter> 
  UEFI: LENOVO v: M0UKT21A date: 03/31/2016 
  Info: Dual Core model: Intel Core i3-6100 bits: 64 type: MT MCP 
  arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: E2 
  L2 cache: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 29608 
  Speed: 900 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 900 2: 900 3: 902 
  4: 900 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 530 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:1912 
  Display: x11 server: X.Org 1.20.10 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x203mm (10.6x8.0") 
  s-diag: 338mm (13.3") 
  Monitor-1: DP2 res: 1024x768 hz: 60 dpi: 43 size: 600x340mm (23.6x13.4") 
  diag: 690mm (27.2") 
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 20.3.3 
  direct render: Yes 
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
  Sound Server: ALSA v: k5.10.7-3-MANJARO 
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: f040 
  bus ID: 01:00.0 chip ID: 8086:2723 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Device-3: Samsung GT-I9070 (network tethering USB debugging enabled) 
  type: USB driver: rndis_host bus ID: 1-2:7 chip ID: 04e8:6864 
  serial: <filter> 
  IF: enp0s20f0u2 state: unknown speed: N/A duplex: N/A mac: <filter> 
  Local Storage: total: 465.76 GiB used: 19.43 GiB (4.2%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WD5000AAKX-22ERMA0 size: 465.76 GiB block size: physical: 512 B 
  logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1H17 
  ID-1: / raw size: 465.46 GiB size: 457.16 GiB (98.22%) 
  used: 19.43 GiB (4.3%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 32.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 190 Uptime: 4h 49m wakeups: 0 Memory: 3.75 GiB 
  used: 1.27 GiB (33.7%) Init: systemd v: 247 Compilers: gcc: N/A 
  Packages: 1208 pacman: 1205 lib: 402 flatpak: 0 snap: 3 Shell: Bash v: 5.1.0 
  running in: xfce4-terminal inxi: 3.2.02 

I suppose this is the one? Here is something that may help.


that didnt help assuming i did it right

Are you dual booting with Windoze? If yes, switch off Fast startup in Windows and Fast boot in your firmware, fully shutdown your compter and wait for some seconds before reboot.

Independently from the above enter

echo "power_save=0" | sudo tee -a /etc/modprobe.d/iwlwifi.conf
sudo depmod -a

Then reboot.


nmcli device wifi list | grep "*"

and post result.

i am not

[scott@scott-10ky002aus ~]$ nmcli device wifi list | grep "*"
[scott@scott-10ky002aus ~]$ 

what gives

ip link
[scott@scott-10ky002aus ~]$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:01:6c:d9:17:42 brd ff:ff:ff:ff:ff:ff
4: enp0s20f0u2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether 9a:2d:aa:26:67:ce brd ff:ff:ff:ff:ff:ff
[scott@scott-10ky002aus ~]$ ip link

In your case I would check if you have installed the card properly, there is no hardware detected…

ive double checked 4 times now

unless the pcie slot isnt working

I just read this post on this forum where a user with he exact same chip ID needs to reboot his machine a few times to get the hardware to show up.

There is a thread on the arch bbs from a user having the same chip in a M.2 to PCI setup with issues getting the kernel to see it properly. The solution was to set the power saving setting to off.

What I wonder is how inxi sees the network device and a driver and then ip sees no interface, is the device now also abcent in inxi in the same boot cycle?

I would try to update the firmware and reset the bios to defaults, disable fastboot if there is any option for it.

Please set up some swap space it we will see you here in a few day’s after you have fixed it with the issue of sudden crashes and reboots :wink:

Seriousfreedom … there is no way this should have anything to do with it, but after chasing the error for over a month and three kernels, I stumbled on this: Boot into UEFI/BIOS and TURN OFF your ethernet port.

My wifi instantly returned.