I can't connect to wifi

I am a new user to both Linux and Manjaro. I can’t connect to any wifi as the list is empty. It is not blocked or anything. My inxi output is

System:
  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=1be28bff-14ac-4bd6-8c07-940e0b04a857 rw quiet
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Portable System: Dell product: Vostro 2520 v: N/A
    serial: <superuser required> Chassis: type: 8 serial: <superuser required>
  Mobo: Dell model: 0V1NDP v: A11 serial: <superuser required> UEFI: Dell
    v: A11 date: 02/24/2014
Battery:
  ID-1: BAT0 charge: 39.3 Wh (93.6%) condition: 42.0/48.8 Wh (86.0%)
    volts: 12.5 min: 11.1 model: Samsung SDI DELL 7XFJJA2 type: Li-ion
    serial: <filter> status: charging
Memory:
  RAM: total: 5.66 GiB used: 2.13 GiB (37.6%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
    required.
CPU:
  Info: model: Intel Pentium 2020M bits: 64 type: MCP arch: Ivy Bridge
    built: 2012-15 process: Intel 22nm family: 6 model-id: 0x3A (58) stepping: 9
    microcode: 0x21
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 2 MiB
    desc: 1x2 MiB
  Speed (MHz): avg: 1238 high: 1280 min/max: 1200/2400 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1197 2: 1280
    bogomips: 9580
  Flags: acpi aperfmperf apic arat arch_perfmon bts clflush cmov
    constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb
    ept erms est flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs lahf_lm
    lm mca mce md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe
    pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdtscp
    rep_good sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm
    tm2 tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid x2apic xsave
    xsaveopt xtopology xtpr
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0156 class-ID: 0300
  Device-2: Microdia Laptop_Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-1.5:4 chip-ID: 0c45:6473 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 model: BOE Display 0x06d3 built: 2016 res: 1366x768
    hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel HD Graphics 2500 (IVB GT1) v: 4.2 Mesa 22.1.6
    direct render: Yes
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Broadcom BCM43142 802.11b/g/n vendor: Dell Wireless 1704 802.11n +
    BT 4.0 driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 07:00.0 chip-ID: 14e4:4365 class-ID: 0280
  IF: wlp7s0 state: dormant mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8168 v: 8.050.03-NAPI modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 09:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Message: No bluetooth data found.
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 931.51 GiB used: 322.54 GiB (34.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10SPZX-26Z10T0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 1A04 scheme: GPT
  Optical-1: /dev/sr0 vendor: TSSTcorp model: DVD+-RW SN-208DN rev: D100
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition:
  ID-1: / raw-size: 194.7 GiB size: 190.59 GiB (97.89%) used: 17.73 GiB (9.3%)
    fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: 1be28bff-14ac-4bd6-8c07-940e0b04a857
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 300 KiB
    (0.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A uuid: 8A2C-2655
  ID-3: /run/media/sachin/New Volume raw-size: 736.2 GiB size: 736.2 GiB
    (100.00%) used: 304.81 GiB (41.4%) fs: ntfs dev: /dev/sda5 maj-min: 8:5
    label: New Volume uuid: 80D066A4D0669FE0
Swap:
  Alert: No swap data was found.
Unmounted:
  ID-1: /dev/sda4 maj-min: 8:4 size: 507 MiB fs: ntfs label: N/A
    uuid: 8672DFB872DFAB67
USB:
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 1-1.2:3 info: Lenovo Wireless KB_Mouse KN100 WW
    type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1
    speed: 12 Mb/s power: 98mA chip-ID: 17ef:609f class-ID: 0301
  Device-2: 1-1.5:4 info: Microdia Laptop_Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:6473 class-ID: 0e02
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 2-1.6:3 info: Realtek RTS5138 Card Reader Controller
    type: Mass Storage driver: ums-realtek interfaces: 1 rev: 2.0
    speed: 480 Mb/s power: 500mA chip-ID: 0bda:0138 class-ID: 0806
    serial: <filter>
Sensors:
  System Temperatures: cpu: 52.0 C mobo: 48.0 C
  Fan Speeds (RPM): cpu: 2989
Info:
  Processes: 173 Uptime: 20m wakeups: 1 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6
  Packages: pacman: 1326 lib: 391 flatpak: 0 Shell: Zsh v: 5.9 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.20 

For days I looked at many forms but I couldn’t solve my problem. One thing I found out is that my NetworkManager.conf file is empty. It only has

# Configuration file for NetworkManager.
# See "man 5 NetworkManager.conf" for details.

What can I do to solve my problem

post output from:
mhwd -l

This is my output

0000:09:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI


> 0000:07:00.0 (0200:14e4:4365) Network controller Broadcom:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
   network-broadcom-wl            2018.10.07               false            PCI


> 0000:00:02.0 (0300:8086:0156) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

install the driver:
sudo mhwd -i pci network-broadcom-wl
reboot

This comes up when I try to to install

Warning: a version of config 'network-broadcom-wl' is already installed!
Use -f/--force to force installation...

post output from:
mhwd -li
pacma -Qs broadcom

The mhwd -li output is

Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI
   network-broadcom-wl            2018.10.07               false            PCI
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!

The pacman -Qs broadcom output is

local/broadcom-wl-dkms 6.30.223.271-31
    Broadcom 802.11 Linux STA wireless driver

so output from:
pacman -Qs headers
mhwd-kernel -li

The pacman -Qs headers output is

    Access control list utilities, libraries and headers
local/libcups 1:2.4.2-3
    The CUPS Printing System - client libraries and headers
local/linux-api-headers 5.18.15-1
    Kernel headers sanitized for use in userspace
local/linux515-headers 5.15.60-1
    Header files and scripts for building modules for Linux515 kernel
local/linux54-headers 5.4.210-1
    Header files and scripts for building modules for Linux54 kernel
local/vulkan-headers 1:1.3.221-1 (vulkan-devel)
    Vulkan header files
local/xorgproto 2022.1-1
    combined X.Org X11 Protocol headers

The mhwd-kernel -li output is

Currently running: 5.15.60-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux515
   * linux54

so you have everyhting installed that you should have…
lets try remove the dkms driver and install the normal one:
pamac remove broadcom-wl-dkms
reboot. then install this one:
sudo mhwd -i pci network-broadcom-wl
reboot

I did as you said and when I try to install it the same result comes

Warning: a version of config 'network-broadcom-wl' is already installed!
Use -f/--force to force installation...

so you removed the dkms one ?

Yes I did that and rebooted

so use pacman:
sudo pacman -S linux515-broadcom-wl linux54-broadcom-wl
reboot

It installed correctly but even after rebooting i can’t connect to wifi

what exactly did you do when you tried to make it work? only installed the dkms and headers? or creating/modifying some config/s?
post output from:
ls /etc/modprobe.d

I did a lot of things but I think I didn’t touch any of the configs
This is the output

blacklist.conf  hp.conf  linux515-broadcom-wl.conf  linux54-broadcom-wl.conf  r8169_blacklist.conf

output from:
cat /etc/modprobe.d/blacklist.conf
cat /etc/modprobe.d/r8169_blacklist.conf
cat /etc/modprobe.d/hp.conf

The output of cat /etc/modprobe.d/blacklist.conf is

blacklist b43
blacklist b43legacy
blacklist ssb
blacklist bcm43xx
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist bcma

The output of cat /etc/modprobe.d/r8169_blacklist.conf is

blacklist r8169

The output of cat /etc/modprobe.d/hp.conf is

blacklist hp_wmi

there are broadcoms blacklisted in the blacklist.conf, probably from the dkms drivers… post also output from to compare it:
cat /etc/modprobe.d/linux515-broadcom-wl.conf