I cannot update the system on kde plasma

I am trying to update the system using the command
$ pacman -Syu
$ pacman -Syyu
, but it is not updating even though I have restored the system from (Time Shift) program.
and this error appears

were you switching branches?
post output from:
sudo pacman-mirrors --get-branch
and run:
sudo pacman -Syyuu

  • stable This is the result of this command

This is the result of this command

refresh your mirrors:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

Should I delete these two?

it looks like the mirrors are messed up, so try this:

sudo pacman-mirrors --country YourCountry --interactive 

and select a country or two and try again… for example:

sudo pacman-mirrors --country Austria --interactive 

dont delete the libraries, they have a lot of dependencies, it is most likely a mirror issue…

The problem has not been solved :smiling_face_with_tear: :smiling_face_with_tear:

i edited my post, did you try that?

Yes, I tried but it did not succeed.

try this:

pamac update --force-refresh

and is it a fresh install? or did you alredy run a update?

It did not work, but I used the
$ sudo pacman -Syu --ignore=libcap,libelf
and now it works. Is this correct?

well not really, since you are now in a partial update state… and you didnt answer:

a partial update state
The problem has not been solved :smiling_face_with_tear: :smiling_face_with_tear:

Okay, I want to ask another question. What if I take a backup, then reinstall the system using an ISO file, and then restore the backup using TimeShift? Will everything be okay and will I overcome this problem, and all the programs will be the same as before due to TimeShift?

why would you use timeshift on the fresh install? maybe the reinstall would fix the update issue…
try reinstalling the 2 packages that you ignored:
sudo pacman -S libcap libelf

so sad :smiling_face_with_tear:

so remove the 2 lib32 packages:

sudo pacman -Rdd lib32-libcap lib32-libelf

it should remove only these two, if it wants to remove more, dont proceed… if it removed only these two, reinstall these:
sudo pacman -S libcap libelf
if it worked install the 2 packages back:
sudo pacman -S lib32-libcap lib32-libelf
if it worked rerun:
sudo pacman -Syyu

Does not installing it cause harm?

It should be noted that I confirmed it through the first command.
sudo pacman -S libcap libelf

Thanks :heart_eyes: :heart_eyes:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.