I cannot login to my laptop since the last update 2024-01-13

Unfortunately I have a problem with the last stable update from 13.01.2023.

After restarting, I can no longer log in!!! the system freezes when logging in!

Luckily I was able to return to the previous status using TimeShift.
I repeated it a total of 5 times. Below are the details of the kernel update window. I suspectes this is where the problem lies. I use KDE Plasma. X11. Kernel: linux67

==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'

I solved this by installing upd72020x-fw and linux-firmware-qlogic. Nevertheless, I cannot log in after the update. This error message appears when booting up, see screenshot.

do you have any tips for me to fix the problem? i still can’t install the update :confused:

I am on the status before the update, except for the new kernel!

Thanks in advance

can you please return

inxi -Fza 
cpupower frequency-info
pacman -Qs dbus-
inxi -Fza 
  cpupower frequency-info
  pacman -Qs dbus-
  Kernel: 6.7.0-0-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.7-x86_64
    root=UUID=bd1d44ca-91e0-4a22-b906-6d798639c31c rw quiet resume=LABEL=swap
    apparmor=1 security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82A2 v: Yoga Slim 7 14ARE05
    serial: <superuser required> Chassis: type: 10 v: Yoga Slim 7 14ARE05
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required> UEFI: LENOVO v: DMCN44WW date: 03/17/2023
  ID-1: BAT1 charge: 28.3 Wh (52.9%) condition: 53.5/60.7 Wh (88.1%)
    power: 4.8 W volts: 15.4 min: 15.4 model: Sunwoda L19D4PF4 type: Li-poly
    serial: <filter> status: discharging cycles: 358
  Info: model: AMD Ryzen 7 4800U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
    process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600106
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1424 high: 1800 min/max: 1400/1800 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1400 2: 1800
    3: 1400 4: 1400 5: 1400 6: 1400 7: 1400 8: 1400 9: 1397 10: 1400 11: 1400
    12: 1400 13: 1400 14: 1400 15: 1400 16: 1400 bogomips: 57518
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_rstack_overflow mitigation: Safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Renoir [Radeon RX Vega 6 ] vendor: Lenovo driver: amdgpu
    v: kernel arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 04:00.0 chip-ID: 1002:1636
    class-ID: 0300 temp: 26.0 C
  Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x683d built: 2019
    res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
    diag: 355mm (14") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (renoir LLVM
    16.0.6 DRM 3.56 6.7.0-0-MANJARO) device-ID: 1002:1636 memory: 500 MiB
    unified: no
  API: Vulkan v: 1.3.274 layers: 4 device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV RENOIR) driver: mesa radv v: 23.1.9-manjaro1.1
    device-ID: 1002:1636 surfaces: xcb,xlib
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
    snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
    snd_sof_amd_rembrandt, snd_sof_amd_vangogh pcie: gen: 3 speed: 8 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.7.0-0-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-4:4 chip-ID: 8087:0029
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Local Storage: total: 1.05 TiB used: 541.74 GiB (50.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: KIOXIA model: N/A
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 0107ANLS temp: 23.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: SK Hynix
    model: HFS512GD9TNG-L3A0B size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 80050C10 temp: 30.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Generic model: MassStorageClass
    size: 119.25 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 2.0 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
    fw-rev: 2402 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 100 GiB size: 98.12 GiB (98.12%) used: 61.46 GiB (62.6%)
    fs: ext4 dev: /dev/nvme1n1p5 maj-min: 259:7
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme1n1p11 maj-min: 259:11
  System Temperatures: cpu: 26.5 C mobo: N/A gpu: amdgpu temp: 26.0 C
  Fan Speeds (rpm): N/A
  Processes: 430 Uptime: 1h 5m wakeups: 1 Memory: total: 16 GiB note: est.
  available: 15 GiB used: 7.6 GiB (50.6%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1949 pm: pacman pkgs: 1942 libs: 440 tools: pamac,yay pm: flatpak
  pkgs: 7 Shell: fish v: 3.6.4 default: Bash v: 5.2.21 running-in: konsole
  inxi: 3.3.31
CPU 6 wird analysiert:
  driver: acpi-cpufreq
  CPUs, die mit der gleichen Hardwarefrequenz laufen: 6
  CPUs, die ihre Frequenz mit Software koordinieren müssen: 6
  Maximale Dauer eines Taktfrequenzwechsels:  Cannot determine or is not supported.
  Hardwarebegrenzungen: 1.40 GHz - 1.80 GHz
  available frequency steps:  1.80 GHz, 1.70 GHz, 1.40 GHz
  verfügbare cpufreq-Regler: conservative ondemand userspace powersave performance schedutil
  momentane Richtlinie: Frequenz sollte innerhalb 1.40 GHz und 1.80 GHz.
                    sein. Der Regler "schedutil" kann frei entscheiden,
                    welche Geschwindigkeit er in diesem Bereich verwendet.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 1.40 GHz (asserted by call to kernel)
  boost state support:
    Unterstützt: ja
    Aktiv: nein
local/dbus 1.14.10-1
    Freedesktop.org message bus system
local/dbus-glib 0.112-3
    GLib bindings for D-Bus (deprecated)
local/dbus-python 1.3.2-2
    Python bindings for D-Bus
local/lib32-dbus 1.14.10-1
    Freedesktop.org message bus system - 32-bit
local/xdg-dbus-proxy 0.1.5-1
    Filtering proxy for D-Bus connections

dbus-broker is missing
see : [Stable Update] 2024-01-13 - Kernels, Systemd, Qt5, Mesa, Dbus, Firefox, Thunderbird

can you

sudo pacman-mirrors -c all
sudo pacman -Syyu
pacman -Qs dbus

if still missing

sudo pacman -S dbus-broker dbus-broker-units
1 Like

Your / partition is on a GPT parted disk but I don’t see an ESP, how does it come? Are you booting in UEFI or BIOS mode?

If it’s legacy (BIOS) boot on GPT, surely there should be a BIOS_GRUB partition at the start? My original Manjaro installation on the T440 doesn’t have one, but as far as I know it should do.

Could it be that you boot via an other disk? You could check the boot entry in your firmware.

If you want to continue to boot in BIOS mode a GPT parted disk, I would recommend to create the required small unformatted partitiion with bios_grub flag and then to restore the boot loader, accordingly. How to do it in detail? Use a search engine of your choice or ask here.

because I have made the update via timeshift backwards! so that I can use the laptop.

sorry, i’m not familiar with it. it’s a new laptop, so i’m assuming UEFI.

I don’t know if it’s related, but I use dual boot, even though I haven’t used Windows for 2 years :slight_smile:

I added a second (small) SSD a year ago, but it’s only for data. I honestly don’t know what you actually mean here! Would you please explain it a little more simply, thank you in advance.

Please provide output of

test -d /sys/firmware/efi && echo efi || echo bios
sudo fdisk -l
sudo blkid
cat /etc/fstab
cat /etc/default/grub
❯ test -d /sys/firmware/efi && echo efi || echo bios
 sudo fdisk -l
 sudo blkid
 cat /etc/fstab
 cat /etc/default/grub
[sudo] Passwort für wael: 
Festplatte /dev/nvme0n1: 476,94 GiB, 512110190592 Bytes, 1000215216 Sektoren
Festplattenmodell: KBG50ZNT512G LS KIOXIA                  
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
Festplattenbezeichnungstyp: gpt
Festplattenbezeichner: 308BD0A0-3547-03B2-28F4-22CC518DEC00

Gerät          Anfang       Ende   Sektoren  Größe Typ
/dev/nvme0n1p1   2048 1000214527 1000212480 476,9G Linux-Dateisystem

Festplatte /dev/nvme1n1: 476,94 GiB, 512110190592 Bytes, 1000215216 Sektoren
Festplattenmodell: SKHynix_HFS512GD9TNG-L3A0B              
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
Festplattenbezeichnungstyp: gpt
Festplattenbezeichner: 3369A323-768F-449C-981A-23C6FF540641

Gerät              Anfang       Ende  Sektoren Größe Typ
/dev/nvme1n1p1       2048     534527    532480  260M EFI-System
/dev/nvme1n1p2     534528     567295     32768   16M Microsoft reserviert
/dev/nvme1n1p3     567296  210282495 209715200  100G Microsoft Basisdaten
/dev/nvme1n1p4  998166528 1000214527   2048000 1000M Windows-Wiederherstellungsumgebung
/dev/nvme1n1p5  210282496  419997695 209715200  100G Linux-Dateisystem
/dev/nvme1n1p6  419997696  524855295 104857600   50G Linux-Dateisystem
/dev/nvme1n1p8  524855296  839428095 314572800  150G Linux-Dateisystem
/dev/nvme1n1p10 839428096  981389311 141961216 67,7G Linux-Dateisystem
/dev/nvme1n1p11 981389312  998166527  16777216    8G Linux Swap

Partitionstabelleneinträge sind nicht in Festplatten-Reihenfolge.

Festplatte /dev/sda: 119,25 GiB, 128043712512 Bytes, 250085376 Sektoren
Festplattenmodell: MassStorageClass
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
Festplattenbezeichnungstyp: dos
Festplattenbezeichner: 0x7ac5c969

Gerät      Boot Anfang      Ende  Sektoren  Größe Kn Typ
/dev/sda1         2048 250083327 250081280 119,2G 83 Linux
/dev/nvme0n1p1: LABEL="SSD2" UUID="c73f8e05-15ea-4b6e-bb7f-dda205df2ba4" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="bd867749-3a12-2e43-815a-5ad539b76c28"
/dev/nvme1n1p4: LABEL="WINRE_DRV" BLOCK_SIZE="512" UUID="968C75B48C75900B" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="c345b77b-dc48-4bb4-9759-f9b0ce055d73"
/dev/nvme1n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="5c1ee7f9-f923-42c5-8084-b58807b9b85f"
/dev/nvme1n1p10: LABEL="Timeshift" UUID="831c25f6-3fbf-422c-882f-1bdd91e223aa" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="983edf7c-8b69-aa45-9503-3584266fd8ae"
/dev/nvme1n1p5: LABEL="Manjaro" UUID="bd1d44ca-91e0-4a22-b906-6d798639c31c" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="c32050f9-9595-2d43-9b71-44229d646de7"
/dev/nvme1n1p3: LABEL="Windows-SSD" BLOCK_SIZE="512" UUID="0E3674F63674E05F" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="d67bfd1a-525f-4c79-8946-951debac5e81"
/dev/nvme1n1p1: LABEL="SYSTEM_DRV" UUID="9473-F81C" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="7aea648f-de83-4199-b26e-a63022f6ef06"
/dev/nvme1n1p8: LABEL="DATA" UUID="4ea227aa-5aeb-4056-8339-ba7d638f1356" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="28305e6f-03f4-4344-bb64-dbdd519b424d"
/dev/nvme1n1p11: LABEL="swap" UUID="1e5e3666-1b53-42ab-a1fa-0c97603711c1" TYPE="swap" PARTUUID="a70bf29d-fd78-1043-8d22-f8f8ac8646a6"
/dev/nvme1n1p6: LABEL="VirtualBox" UUID="5e127960-be70-4df7-9d07-045736e2650a" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="b2800eb7-a31e-3e4e-a9a1-ad0829d3a8df"
/dev/sda1: LABEL="microSD" UUID="aa222ad6-b213-4525-9528-051ba3213931" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="7ac5c969-01"
# <file system> <mount point> <type> <options> <dump> <pass>

UUID=bd1d44ca-91e0-4a22-b906-6d798639c31c       /       ext4    noatime 0       1
UUID=aa222ad6-b213-4525-9528-051ba3213931       /home/wael/microSD      ext4    noexec  0       0
UUID=4ea227aa-5aeb-4056-8339-ba7d638f1356       /home/wael/Data ext4    defaults        0       0
GRUB_DEFAULT="Manjaro Linux"
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=LABEL=swap apparmor=1 security=apparmor udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

Have you tried this?

Is this your ESP? Why has it the label “SYSTEM DRV”?
I wonder why you don’t have an entry in /etc/fstab…
Might be needed to restore the boot loader after updating.

yes, i have read it and replied to it, i think. i have done the whole update several times, but each time i was not able to use the system afterwards, so each time i did timeshift. I did the update via the GUI, but also directly via
sudo pacman -Syu

Regarding “SYSTEM DRV”: I’m not sure, but I think it’s still from Windows. I mentioned that I use dual boot.

but i can try @stephane 's suggestion and report back afterwards. thanks in advance.

After the execution of:

sudo pacman-mirrors -c all
  sudo pacman -Syyu
  pacman -Qs dbus

I got this output:

❯ sudo pacman -Qs dbus
[sudo] Passwort für wael: 
local/bluez-qt5 5.113.0-1 (kf5)
    Qt wrapper for Bluez 5 DBus API
local/dbus 1.14.10-2
    Freedesktop.org message bus system
local/dbus-broker 35-2
    Linux D-Bus Message Broker
local/dbus-broker-units 35-2
    Linux D-Bus Message Broker - Service units
local/dbus-glib 0.112-3
    GLib bindings for D-Bus (deprecated)
local/dbus-python 1.3.2-2
    Python bindings for D-Bus
local/kdbusaddons5 5.113.0-1 (kf5)
    Addons to QtDBus
local/lib32-dbus 1.14.10-2
    Freedesktop.org message bus system - 32-bit
local/libcloudproviders 0.3.5-1
    DBus API that allows cloud storage sync clients to expose their services
local/libdbusmenu-glib 16.04.0.r498-2
    Library for passing menus over DBus
local/libdbusmenu-gtk3 16.04.0.r498-2
    Library for passing menus over DBus (GTK+ 3 library)
local/libdbusmenu-qt5 0.9.3+16.04.20160218-6
    A library that provides a Qt implementation of the DBusMenu spec
local/modemmanager-qt5 5.113.0-1 (kf5)
    Qt wrapper for ModemManager DBus API
local/python-jeepney 0.8.0-2
    Low-level, pure Python DBus protocol wrapper
local/python-secretstorage 3.3.3-2
    Securely store passwords and other private data using the SecretService DBus API
local/xdg-dbus-proxy 0.1.5-1
    Filtering proxy for D-Bus connections

After restarting I got the same problem as described above.

Tonight I’ll also try with the last command.

sudo pacman -S dbus-broker dbus-broker-units

unfortunately another attempt without success. same error message! @stephane

can you check then

 sudo find / -iname '*.pacnew' -type f -print

~ took 17s 
❯ sudo find / -iname '*.pacnew' -type f -print
[sudo] Passwort für wael: 
find: ‘/run/user/1000/doc’: Keine Berechtigung
find: ‘/run/user/1000/gvfs’: Keine Berechtigung

~ took 1m5s 

All pacnew files should be merged, but especially thins one: it’s for your display manager.

edit: Did you try to login at a tty and look at some logs why dbus would not start? dbus-broker seems to be a little less lenient when some configuring xml files are errornous…