I can not set dark theme in Unstable


I switched to unstable and I cannot set adwaita dark theme anymore by using the tweak tool. When I set adwaita dark and say ok, the adwaita light gets activated. The same problem with whitesur dark theme. Only the light version gets activated.
Otherwise, gnome 4o works fine, and I like it much better than the previous version.

Any idea how to fix this?

Hello, do you have User themes extension enabled?

I enabled it but it still does not work. It also changed other components like the top panel and the launcher. So I disabled it again to get back to the gnome 4o look and feel.

Did you select your dark theme within the extension when you’ve tested it?

I did, but it had no impact.

I also tried to change the:

gtk-application-prefer-dark-theme=0 to 1

in /home/mak/.config/gtk-3.0/settings.ini

but after reboot the system set it back to 0.

Can you provide a screenshot of the related theme tab from Gnome tweaks tool?

Ah, in Layouts, is automatic dark theme enabled?

I’ve had issues with this in the past.

1 Like

It was not enabled. I enabled it and now the dark theme works. Thanks for the help. I was not aware of this layout setting because the previous gnome did not have this.

I’ll paraphrase @Fabby : I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click on Solution to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

Hi Falav Habitué

Thanks for the help. However, I am back to square one. I updated the system and after rebooting it, the dark theme gone again and I am back to where I was before.

Just Falav.
Here are my own settings for comparison:

Gnome tweak tools

Extensions/User themes

Except Extensions that I never succeed to theme, all my system has turned dark.

Thanks a lot. I matched my settings to yours and now, it works again. In the layout settings, wayland session was on, I turned it off like in yours and now, it works. It might be that wayland caused this problem.
Now, I set the solution as you said.

The dark theme problem was solved - see the comment above.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.