I can not install the file system f2fs

#1

Hello, I read that there was a file system designed specifically for ssd called f2fs and created by Samsung and as I have a samsung ssd, because I thought reinstall and format with that file system. Because it is supposedly better, since SSDs are not mechanical and ext4, is very good but does not consider that ultimately is supposed to be better.
But as much as I try when is finishing the installation I get an error that says that you can not install the grub,
Error Boost.Python en el proceso “bootloader”.
<class ‘subprocess.CalledProcessError’>
Command
’grub-install --target=x86_64-efi --efi-directory=/boot/efi
–bootloader-id=Manjaro --force’ returned non-zero exit status 1
Traceback:
File “/usr/lib/calamares/modules/bootloader/main.py”, line 258, in run
prepare_bootloader(fw_type)

File “/usr/lib/calamares/modules/bootloader/main.py”, line 246, in prepare_bootloader
install_grub(efi_directory, fw_type)

File “/usr/lib/calamares/modules/bootloader/main.py”, line 191, in install_grub
"–force"])

File “”, line 2, in
but if formatted with ext4, it does not give me any problems. The installation performed with squid with manual partitioning option. Can somebody help me?
Thank you.

1 Like
#2

For those whowant to answer in Spanish:

#3

While it is true that f2fs is specifically designed for flash memory, ext4 is constantly being developed to catch up with other filesystems - it is simply the most tested and the most popular Linux filesystem. Also Phoronix benchmark tests don’t show much of an advantage for any filesystem which a normal user would notice in daily use.
But there might be deal-breaking features of some filesystems which can be the reason to instan that particular filesystem.

As for your particulartrouble with the bootloader: Did you check the Arch Wiki? https://wiki.archlinux.org/index.php/F2FS
If I understand correctly you need an ext2 /boot partition.

#4

yep he needs a efi partition, a boot partition that is supported by grub (so i would also choose ext2 or 4) and of course a root partition as minimum (until Grub can handle f2fs itself)

also you should do the partitioning and formatting before you try to install because (for me) its a known bug that the installers sometimes cant create f2fs systems.

my fstab looks like this:

UUID=SOMEUUID       /               f2fs    defaults,noatime,noauto,x-systemd.automount 0       1
UUID=SOMEUUID       /boot           ext2    defaults,noatime,noauto,x-systemd.automount 0       2
UUID=SOMEUUID       /boot/efi       vfat    defaults,noatime,noauto,x-systemd.automount 0       2
UUID=SOMEUUID       /home           f2fs    defaults,noatime,noauto,x-systemd.automount 0       2
tmpfs               /tmp            tmpfs   defaults,noatime,mode=1777,noauto,x-systemd.automount 0       0

it runs great on manjaro. so it’s possible :slight_smile:

1 Like
#5

Thanks for your response. The EFI partition is also fat32 and ext2’ve tried it with and in 2 cases gives me the same error. That you have installed Manjaro installer? because I’ve tried it with both graphics installers who have Manjaro, with squid and the other is not as it is called and both have received the same error.

#6

last time i installed it it was like this:

  • started the liveUSB system
  • installed and lauched gparted
  • set f2fs for my /home
  • set f2fs for /
  • set ext4 for /boot
  • apply and close gparted
  • launched thus installer (last time calamares was unable to use f2fs)
  • used the manual setup for partitioning
  • mark only /boot as re-format with ext4, all others can be used like they are
  • install
  • reboot
  • done
#7

Hi, I tried what you say and is the same. THUS also only allows me to use fat32 partition for /boot/efi, but squid if you allow ext2 for /boot/efi. I do not understand is because you have a /boot partition and a /boot/efi. I have only one partition /boot/efi in my other installation of Manjaro in ext4 and runs smoothly. I have found that in f2fs partitions in gparted I get a sign! and my look at the information either partitions f2fs says "Unable to read the contents of this file system.
Because of this, some operations may not be available.
The cause may be that a software package is missing.
The following list of software packages for system support f2fs files is needed. f2fs-tools "But I have found that the f2fs-tools package and is installed’ve tried to create f2fs partitions from terminal and then get it disappears. that sign! but still happens the same. in addition it THUS tells me you have to umount the partition / I’ve ridden from teminal, but squid is not, but it is happening the same. I also installed f2fs-tools-git package, but the same is true. I have also tried Linux Manjaro 16.08-PRE1 released but the same is true. Right now I’m stuck and no longer to do.

#8

This is required for UEFI boot. See
https://wiki.archlinux.org/index.php/EFI_System_Partition

#9

If you already know, but your comment does not give me anything new about my problem.

#10

OK, I will try to explain. /boot/efi is required to be fat32. And /boot is required to be file system supported by grub. If your root file system is supported by grub, there is no need for separate /boot partition. But if you want root file system not supported by grub, separate /boot partition is required.

#11

The last part about f2fs not available to gparted you could solve by yourself. After f2fs-tools installed it should work. Just try all over again. Create your partitions and file systems with gparted, Then run installer. I’d recommend calamares

#12

I have to install f2fs-tools, if it is already installed on the live?

#13

No need to reinstall. I thought you said it was not installed

#14

what I said is that try to install f2fs-tools-git

#15

but i try what you say, because as I f2fs-tools already installed by default when you create the partitions in gparted f2fs, gparted shows me a sign! and the following message:
"Unable to read the contents of this file system.
Because of This, some operations May not be available.
The cause May Be That a software package is missing.
The following list of software packages for system files f2fs support is needed. f2fs-tools "
but f2fs-tools is already installed. So try installing f2fs-tools-git

#16

It seems to be a problem of GParted then. Maybe switch to ustable branch and reinstall gparted.

sudo pacman-mirrors -gb unstable sudo pacman -Syy sudo pacman -S gparted

#17

I’ve just tried it myself in virtualbox. Don’t use Gparted, just use Calamares manual partitioning, it works great with f2fs.

#18

f2fs on UEFI, with KDE Partitionmanager + Calamares.

if i just use calamares to format to f2fs i just get an error that it wasnt possible and the strange thing is: it works with kde partitionmanager and both use kpmcore :smile:

#19

Hello, did you say in your video and I worked, but update the system and then update the kernel to version 4.6.4-1 and when you restart the system will not boot and appeared this message:

Restart your pc and start with the other kernel, started well and reinstall the kernel 4.6.4-1, but the same thing happened, Restart try booting with the other kernel, per the system no longer boot, only the screen remained empty and the blinking cursor. I did it again the process of your video, but this time, when I finish restart the system, but did not start again the blank screen and blinking cursor is left. I returned to install, but this time create and format the partition f2fs from THUS and restart everything worked properly. From which I deduce that problem I had at first is that it did not create the partition boot, I just created the EFI partition and was when he gave the error grub, but when installed on ext4 partitions is not neceasio create a boot partition, only with the EFI partition is sufficient. I used gparted, because my desk is xfce, but before you tell me what I install kde xfce PartitionManager on my desk and no longer appeared the signs! in f2fs partitions. Well again after installing the system from THUS Restart and update the system and kernel, but this time to version 4.7.0.0, because longer available, but the same thing happens you can see in the picture, with the other kernel Reboot , which is that I’m writing now. Algiuen know how to solve this problem?
Thank you.

Sorry for my English, is google translator

#20

Hi. If you want stable and reliable system, I would recommend to use ext4 root file system, not f2fs.