I broke my system somehow. Can't boot Manjaro, Windows, or a flash drive after a series of events

I’ve had a dual boot Windows/Linux configuration for a while. Several months ago, I replaced my Ubuntu partition with Manjaro and I have been pretty happy with it.

I’m now at a point where I can’t boot anything, after things broke, and trying to fix them made more things broke. This post is a lot of background info on how I got to this point, but if you want to look at one part… The part I need help with the most is down at the bottom of this page. – I can’t boot Manjaro, Windows, or even the Manjaro USB I made.

How this problem developed.

After installing Manjaro, my system was unable to find my previous grub.cfg, so I’ve been lazily doing

search.file /etc/manjaro-release root
configfile /boot/grub/grub.cfg

At every boot to locate my grub. TBH, I was kind of afraid of fixing it and not being able to boot into anything. So I just left it that way. I don’t even really understand those grub commands. I just typed them so many times and they worked.

So fast forward to an update/upgrade I installed absent mindedly after not logging into my system for a few weeks for unrelated reasons. It needed updates and I just hit install and went back to being busy, not thinking about it. I didn’t realize there was a problem until I shut the system down.

For a long time I would get messages

error: file `/boot/grub/grubenv` not found.
Press any key to continue

And for a long time it would do this and boot anyway. I don’t know what grubenv is. I assume its some environment variables.

So, after this upgrade, I was hanging at that error message which occurred after selecting Manjaro from the GRUB list.

I was still able to login to Windows. But I dont use Windows very often. I tried to use Rufus to make a Manjaro USB, but for some reason, it would select the drive on the GUI if you are familiar with that. I started noticing a variety of anomalies, like missing DLL errors and notifications that some script somewhere cannot be found, which is clearly some kind of exploit that infected this system.

The situation is that I don’t use the Windows, but there are people I live with who do who play games and are much less computer oriented otherwise. I’m certain there was something fishy about the Windows install. It’s irrelevant really, except that I chose to reset the Windows.

I knew that this would potentially cause trouble, the way installing Windows after installing another OS does. But I was pretty resigned to do a full system install after seeing the Windows situation.

But before that, I used an Ubuntu USB that I just happened to have available. I knew that it would not have the manjaro-chroot solution, but I thought I could probably still use it.

I mounted / and /boot/efi as well as /proc, /dev, and /sys … which it took me a while to figure out that I needed to do those things in order to use commands like lsblk and pacman from the chroot.

But I eventually did get pacman -Syu to work. I thought that maybe that would be all it needed.

In addition to trying to look at logs files and repair grub and this kind of thing, I also mounted my storage drives and began moving things to somewhere they could be backed up – my external, and my extra HDD. The SSD where both OSes live I was preparing to be wiped though, which I’m glad I did that.

After this, I logged back into Windows to do some backup there. There was much less to do, as I said. I dont use it frequently. Its mainly a game system for people who have time play them :smile: … So, I set about making a new Widows USB and a Manjaro USB and I started resetting it.

I was still able to login to Windows after doing this and the Manjaro options still had the same unresponsiveness.

Before committing to go further with the reinstall, I decided to do grub-install stuff. It probably wasn’t a good idea to do it on the Ubuntu chroot. After doing this and having grub “installed and configured without error” according to the output, my Windows was removed from the GRUB listening.

Now I can’t even get GRUB to load at all.

While I was messing with things to get it to work early on, I had commented out most of my fstab except for the system drives. If I could access that file again, I would like to double check that I didn’t comment out the /home/ partition or something important but I don’t think so.

In addition to the grubenv error/warning, it now says this too

error: `/boot/grub/fonts/unicode.pf2` not found.
Press any key to continue

the part i need help with the most

And it just doesn’t boot. The worst part is, I can’t boot from the manjaro ISO USB I made on another Linux device with sudo dd if=path/to/manjaro.iso of=/dev/sdx status=progress

It seemed to complete successfully.

But when I boot from that USB, it POSTS and immediately goes to

error: unknown filesystem
Entering rescue mode...
grub rescue>

Because of this, I remade the drive again, this time formatting it with gparted and setting the fs to fat32. I then made the install drive again using dd. Same issue.

What could I try from this grub rescue> and why would that be what happens on a Manjaro ISO, that Ive made multiple times now.

I got the file from the torrent this time and used the sha1sum to verify it.

Disk /dev/sda: 29.33 GiB, 31482445824 bytes, 61489152 sectors
Disk model: Cruzer Glide    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00153d41

This is the USB drive. I dont know why this laptop uses sda1 for its hot pluggables and has other naming schemes for the system partitions.

I’m going to try escaping into a TTY for best possible performance and doing this again

dd if=image.iso of=/dev/sda1 status=progress bs=4MB oflag=sync

Im really ouy of ideas otherwise.

I’ve so far used three different systems to get a Manjaro ISO written to a USB, I’ve used two USBs. Minimal full desktop version from http and torrent downloaded multiple times. Ive used rufus, dd, and I don’t think Etcher is going to be any better. They all don’t work, on multiple other systems.

Currently I’m writing a xubuntu image. My Windows10 image works. If all the USB drives I write except the Manjaro ones work, then I have no choice but to give up Manjaro.

I am still interested in a possible explanation for any of this.

This problem is WAY above my knowledge. But I might have an idea for a program to make a bootable USB.

I would recommend Ventoy

Then you download the package (you can choose Windows and Linux package), then you unzip it.

In Linux you will need to cd into the Ventoy folder created by the zip and then you would do
sudo sh ventoy2disk.sh -i /dev/sdX where X is the location of your USB. Then you can drag and drop the ISO into the Ventoy USB, and if your drive is large enough, you can have several ISOs there.

Hope this helps a little.


I see error in your ways.
You should write directly to disk there of=/dev/sda not to partition sda1 like you did.

since i identified ventoy, i use it and never felt to look for options.
i have two usb sticks [one compat in uefi and other legacy]