Hybrid Graphics Nvidia

bumblebee
nvidia
hybrid
graphics

#1

Hello everyone,

I’m trying to install Manjaro on my Laptop and get the hybrid graphics to work.
I have an Intel i7-6700HQ and a Nvidia GTX 970M installed.

So I installed Manjaro GNOME 17.0 on my laptop, this only worked with the free version.

Using the 4.9 Kernel I then tried to follow this wiki entry along:
https://wiki.manjaro.org/index.php?title=Configure_NVIDIA_(non-free)_settings_and_load_them_on_Startup

When trying to use Bumblebee with the video-hybrid-intel-nouveau-bumblebee driver I get the Error message
[ERROR]Cannot access secondary GPU - error: Could not load GPU driver

After installing the video-hybrid-intel-nouveau-bumblebee I could not access the nvidia-settings.
The settings opened but I got an error message that the Nvidia Driver is not in use thus the settings could not be accessed.

When I try to use bumblebee anyways I get the same error that the GPU driver could not be load.
My guess was that the driver wasnt hooked properly in the bumblebee.conf but I there everything seemed to be alright to me.

So my question is how to get the hybrid graphics to work properly with my GTX 970M?

Thank you,

gz


#2

You should use nvidia hybrid for that card, not nouveau hybrid.

sudo mhwd -r pci video-hybrid-intel-nouveau-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-bumblebee

Reboot.

Bumblebee uses the intel gpu by default, you have to use primusrun [application] to explicitly use nvidia gpu for an app. You could also use optirun, but primusrun is more recent and performs better.

To check which gpu is enabled

cat /proc/acpi/bbswitch

OFF in intel, ON is nvidia.

Check it is working

optirun -v glxgears

Check your nvidia OpenGL library mappings

optirun -v glxinfo | grep OpenGL

To configure your nvidia driver

optirun -b none nvidia-settings -c :8

HTH.


#3

Maybe this post on the Arch forum helps:
https://bbs.archlinux.org/viewtopic.php?id=214766

It says:
“I had to do the x-configuration as described in the wiki section for nvidia optimus.”

Which is here:
https://wiki.archlinux.org/index.php/NVIDIA_Optimus


#4

Thank you very much for your answers!

@sueridgepipe

Yes that was also what my internet research told me to do.
After installing the nvidia hybrid driver the system only uses the Intel GPU as it’s supposed to. But when I try to use bumblebee (optirun glxgears) I still get the error:
[ERROR]Cannot access secondary GPU - error: Could not load GPU driver

I’ll try to have a look at the nvidia settings totomorrow.

@Strit
Alright I’ll try the xserver configuration as described in the wiki tomorrow morning


#5

Aright I’m pretty confused right now;

So I set up a fresh Manjaro Gnome install and installed the nvidia-hybrid drivers.

Nevertheless when running optirun glxgears i Got the error:
[ERROR]Cannot access secondary GPU - error: Could not load GPU driver

On the Arch wiki Page about bumblebee it says:
This could be because the nvidia driver is out of sync with the Linux kernel, for example if you installed the latest nvidia driver and haven't updated the kernel in a while. A full system update might resolve the issue.

So i did an complete System upgrade and after that it actually wokred for the first time.
I tried to test the graphics performance with glmark2.
There the Intel GPU had a score of 560 while the Nvidia only scored 80 ?!

After I rebooted it actually didnt work anymore.
Running optirn glxgears resolved in the error before the upgrade.

No idea why the reboot should have broken it and why the nvidia card (since its a pretty powerful one) scored so low.


#6

It’s been a while since i had to deal with bumblebee. You sure you have all the dependencies like primus installed and bumblebee is enabled in systemd?

Run to uninstall and reduce the chances of error:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee

Then follow the wiki step by step.

To use nvidia-settings with bumblebee you have to use.

optirun -b none nvidia-settings -c :8


#7

Bumblebee can conflict with TLP, take a look at this

$ lspci | grep "NVIDIA" | cut -b -8
01:00.0

$ cat /etc/default/tlp | grep RUNTIME_PM_BLACKLIST
RUNTIME_PM_BLACKLIST="01:00.0"


#8

After running “optirun glxgears”, check output of “systemctl status bumblebeed” and last lines of “dmesg” output.


#9

pretty weird, sometimes it works and sometimes it does not…

@ezfox

Here are the outputs, after running
optirun glxgears again gave me:

[  195.380962] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
[  195.380998] [ERROR]Aborting because fallback start is disabled.

Bumblebee Status:

$ systemctl status bumblebeed
● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor p
   Active: active (running) since Sat 2017-03-25 11:16:41 CET; 39s ago
 Main PID: 402 (bumblebeed)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bumblebeed.service
           └─402 /usr/bin/bumblebeed --use-syslog

Mär 25 11:16:41 tom-pc systemd[1]: Started Bumblebee C Daemon.
Mär 25 11:16:42 tom-pc bumblebeed[402]: /usr/bin/bumblebeed 3.2.1-2017-02-27-For
Mär 25 11:16:42 tom-pc bumblebeed[402]: Unable to disable discrete card.
Mär 25 11:17:00 tom-pc bumblebeed[402]: Could not load GPU driver

dmesg:

[   22.046379] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[   22.046389] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=none,decodes=none:owns=none
[   22.046407] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:13d8)
               NVRM: installed in this system is not supported by the 375.39
               NVRM: NVIDIA Linux driver release.  Please see 'Appendix
               NVRM: A - Supported NVIDIA GPU Products' in this release's
               NVRM: README, available on the Linux driver download page
               NVRM: at www.nvidia.com.
[   22.046412] nvidia: probe of 0000:01:00.0 failed with error -1
[   22.046432] nvidia-nvlink: Nvlink Core is being initialized, major device number 243
[   22.046441] NVRM: The NVIDIA probe routine failed for 1 device(s).
[   22.046442] NVRM: None of the NVIDIA graphics adapters were initialized!
[   22.046443] nvidia-nvlink: Unregistered the Nvlink Core, major device number 243

Thank you to everyone helping me!


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.