HUION Kamvas Pro 22 drivers not available on DIGImend list


#171

Copying huion.desktop into my desktop and making

./huion.desktop
bash: ./huion.desktop: Permission non accordée

So I made it executable and still present on the desktop repository/directory and tried again:

[nameid@computerid Bureau]$ ./huion.desktop 
./huion.desktop: ligne 1: [Desktop : commande introuvable
./huion.desktop: ligne 7: -e : commande introuvable

Doing man xfce4-terminal, I can find:

-e, --command=command
           Execute command inside the terminal

So this command (i.e. xfce4-terminal -e) seems to exist but is reported to be problematic…

Should I try now to do ./huion.desktop in ~/.config/autostart?


#172

Well I guess the xfce terminal does not support the execute parameter. I know the gnome terminal does, but I’m totally unfamiliar with xfce.


#173

Killi - please don’t get confused … the *.sh file you run from terminal but the *.desktop file you run it like whatever application that you open from menu … you click/double click on it


#174

Oh, I never caught that part. :man_facepalming:


#175

It works indeed from its containing directory. If I open a new terminal windows (then being in ~) and do sudo ./start-driver.sh it does not work:
sudo: ./start-driver.sh : commande introuvable


#176

thats because your trying to run it from a terminal that defaults to /home/user/ , my point was more towards you needing to execute the desktop file or terminal command with the correct FULL directory.

./home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh
(if thats where it is actually located)
should be what the .desktop file executes when run.


#177

The *.desktop files can’t be executed from terminal … :slight_smile:


#178

just found that out myself :frowning_face:


#179

If I double click on the .desktop files present in ~/.config/autostart like the huion.desktop one or the redshift-gtk.desktop (that I know that it works), I have still have a windows that appears telling me that it is an unreliable application launcher, that it is located in a non secured place and that it is not marked as executable. I have then the option to launch despite all or to make it executable.


#180

Yes, that is why i told you to do this:

So, after is launched, does the pen works ?


#181

Making

sudo Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh

the pen then works!


#182

That means it doesn’t require a Working Directory.


#183

What happens if you change the huion.desktop to this:

[Desktop Entry]
Type=Application
TryExec=pkexec tmux -c /home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh; sleep2 & exit
Exec=pkexec tmux -c /home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh; sleep2 & exit
Terminal=false
Hidden=false

#184

If I double-click, after allowing the file huion.desktop present in the ~/.config/autostart to run as a program in the Permissions tab, how can I be sure that the huion.desktop is launched? Graphically I do not see any change and making xinput --list the pen does not appear and therefore does not function.


#185

If that doesn’t make the pen working that means the huion.desktop is not working correctly … either because has a typo somewhere, or the path to the sh file is wrong.


#186

I have not found unfortunately what is the launcher tab. Is it where my red arrow is?

It should be easy to find what it is but I do not find it… Sorry.


#187

When you right click on the huion.desktop and select Properties … But since there is no need for a Working Directory path, you can discard that.


#188

I have tried it. It does not work after the reboot but I saw a little difference namely when I double click on huion.desktop in ~/.config/autostart, a windows appeared asking me to give authentication to run /usr/bin/tmux as a super user. But giving the authorization by giving my password makes not the pen working or being listed in xinput --list

Regarding the aforementioned code of huion.desktop, if the Name=Huion is not listed, it seems to not appear anymore in xfce-settings-manager. It seems to be good to write this line again, don’t it?


#189

Well, the name with or without will not make it work, and if it doesn’t make the pen working when you ope it by click, that means is not ok … Change it to:

Type=Application
TryExec=xfce4-terminal -e sudo /home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh &
Exec=xfce4-terminal -e sudo /home/nameid/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh &
Terminal=true
Hidden=false

and see if by opening it with click makes the pen working. If it doesn’t work then probably the only way is to run it from terminal as you did, or find an alternative way for autostart.


#190

Thanks for your answer.

With [Desktop Entry] in the first line of it I suppose?