HUION Kamvas Pro 22 drivers not available on DIGImend list


#131

xfce should be able to add the script from xfce startup settings so it will run at startup, i believe you would have it run as root


#132

The last time I had someone use a startup script it worked even though it required root privileges, so it’s worth a try. Way easier than doing up a service.


#133

Should I then try what @dglt proposed?


#134

Do you know how to script?


#135

Not really. I have looked some beginners video once some weeks ago but I cannot say I know how to script…
edit but I would know how to create the enable-graphic-tab.service file and copy/paste what @dglt wrote.


#136

That example of a service file needs work.

It is far easier to script launching your driver at start up with a script at user login.


#137

if you have the option to add a script to xfce settings > startup script then just add the existing start-driver.sh right there


#138

I can not give you the exact procedure for this in Xfce. I use KDE and this is how it is done in KDE. In the KDE System Settings -> startup and shutdown ->autostart -> add script.


#139

I am sorry I do not understand.


#140

In the xfce settings, I can add an application that we run automatically after the boot. There are three apparently required fields:
name
description
command

Are the name and description just something to help me?
Should the command be sudo /home/~/HuionKamvasGT220v2LinuxDriver/start-driver.sh ? Or should I before that store this driver at another place in my directories/repertories?

edit: I do not know if this xfce-settings-manager regarding the application that should work after the boot works good, since skype is still coming back (yes, I am sorry to use it) if I use skype and I boot, skype opens after the boot. I can remove skype from this list of application that will open after every boot, but skype reappears if I run this software.


#141
~/HuionKamvasGT220v2LinuxDriver/start-driver.sh

#142

Thanks for your quick answer but I do not understand what you really mean since the current location is: /home/~/Documents/…/HuionKamvasGT220v2LinuxDriver/start-driver.sh


#143

You are probably using the “restore sessions” option. That is why skype is continuing to start up even after removal.

It is not /home/~
it is simply ~/

so

~/Documents/HuionKamvasGT220v2LinuxDriver/start-driver.sh

#144

Thanks once again. So you agree with the command:
sudo ~/Documents/.../HuionKamvasGT220v2LinuxDriver/start-driver.sh

edit: or you prefer it without sudo?

The description and the name are information just necessary for me, aren’t they?


#145

No I do not.

do this

cd ~/Documents
ls -l

post outputs


#146

mmm, why should I post the list of the personal files and directories that I have… :thinking:
If you want to know the directory of the file it is: Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh
edit : drwxr-xr-x 3 nameid nameid 4096 14 déc. 19:03 pilote_tablette_graphique


#147

I had to ask you to output you Documents directory because you located it in your Documents folder (of all places), and you have not been able to once give me the correct path up until this very moment.

Command to input:

~/Documents/pilote_tablette_graphique/HuionKamvasGT220v2LinuxDriver/start-driver.sh

I’m done for now.


#148

Excuse me if I interpreted it incorrectly and thanks a lot for your help!


#149

I have created it in xfce-settings-manager but it does not work. Should I try adding with sudo before that or should I put this script (with its complete repertory) in /usr/bin for example? @dglt have you an idea?


#150

had to water the plants (feed kids), im back now. with things like this, trial and error is ok, your trying to get a script to run at startup, if it doesnt work one way, try another. in this case where it needs to run as root/sudo im not sure if it needs different permissions and be located in a system folder. search for “run script at startup xfce” and see what you come up with. im taking a look now but i have the same resources you do.