HUION Kamvas Pro 22 drivers not available on DIGImend list


#107

That would be true, but you will not have the power of the terminal at your fingertips if you disown the process and close down the terminal. :smile:

Test it out and see how it works. If you don’t want a terminal running that’s fine. Do as you please.


#108

if you want to isolate what works and what doesnt without the possibility of them conflicting with each other, yes.

i edited that command to
sudo ./start-driver.sh; sleep 2 & exit
so you can visually see the output from the command before the terminal closed.

thats ok, once we know for sure exactly what works, we can use a systemd service to run at startup to automate said commands so you wont need to enter them manually.


#109

Alright thanks for the explanation.


#110

Okay that’s great!! I thought that I have still to do manually after every reboot! Thanks!!!


#111

He might even be able to get away with a simple start up script rather than having to write a service file.


#112

just for now, and as bogdan said, @tbg is great with those, i made my first one with his assistance.
for right now lets try this, in this order:

  • reboot
  • sudo ./start-driver.sh; sleep 2 & exit
  • wizardpen-calibrate
  • test

thats why your the man for the job :grin:


#115

With sudo? Because @bogdancovaciu wrote:

I have begun after rebooting withsudo ./start-driver.sh; sleep 2 & exit

and the terminal windows does not close, is it normal?

Incredible! This time it seems that I just need to make sudo ./start-driver.sh; sleep 2 & exit and the pen worked on the graphic pad!!! This time I have not needed wizardpen-calibrate nor sleeping/awaking nor opening Krita and pressing ctrl+shift+t!


#116

You need to add the disown commands to the end of your script if you want it to close the terminal after executing.

Great news. :clap:


#118

Thanks. It means that I should write
sudo ./start-driver.sh; sleep 2 & exit & disown ?

I still do not understand why before it seemed so complicated and now it seems to work properly just with one command…


#119

No , what I mean is that in your start-driver.sh script you need to add:

 > /dev/null 2>&1 & disown; sleep 2; exit

at the end of the contents in the start-driver.sh script.

It’s hard for me to say exactly which commands you will need because I’m not able to test out your setup. You’ll just have to play with different options till you get the result you want.


#121

That means that this script would be like it? (I am not sure to know where is the end of the contents):

#!/usr/bin/env bash
# Adjust this as needed
DRIVER="kamvas.py"

T="256c:006e"
BUS=$(lsusb | grep "$T" | sed -e 's|Bus \([0-9]*\) Device \([0-9]*\):.*$|\1|g')
DEV=$(lsusb | grep "$T" | sed -e 's|Bus \([0-9]*\) Device \([0-9]*\):.*$|\2|g')

sudo rmmod hid_uclogic
sudo modprobe uinput
sudo /usr/local/bin/uclogic-probe $BUS $DEV | /usr/local/bin/uclogic-decode
sudo python3 $DRIVER
> /dev/null 2>&1 & disown; sleep 2; exit

Which options?
Thanks again you 3!!


#122

Try this:

#!/usr/bin/env bash
# Adjust this as needed
DRIVER="kamvas.py"

T="256c:006e"
BUS=$(lsusb | grep "$T" | sed -e 's|Bus \([0-9]*\) Device \([0-9]*\):.*$|\1|g')
DEV=$(lsusb | grep "$T" | sed -e 's|Bus \([0-9]*\) Device \([0-9]*\):.*$|\2|g')

sudo rmmod hid_uclogic
sudo modprobe uinput
sudo /usr/local/bin/uclogic-probe $BUS $DEV | /usr/local/bin/uclogic-decode
sudo python3 $DRIVER > /dev/null 2>&1 & disown; sleep 2; exit


#123

no problem, try the script the way you just edited it and if it works, your good.
edit: the way @tbg changed it looks much better

@tbg would this be how the startup script would go since it needs sudo?
sudo nano /etc/systemd/system/enable-graphic-tab.service

[Unit]
After=pick-some-service-to-start-after.service

[Service]
User=root
ExecStart=/path/to/start-driver.sh

[Install]
WantedBy=default.target

save/exit

or is there a simpler way of running a startup script, in kde i just use “auto start” in settings but im not familiar with xfce


#124

Second time in a row! After rebooting it is working perfectly and easily!


#125

If he’s using KDE simply adding it as a start up script should be sufficient.


#126

xfce i believe


#127

I am using indeed XFCE


#128

As you, I am unfamiliar with the method of adding a start up script in Xfce, but I would think they use something similar to KDE.


#129

Thanks, it works perfectly.


#130

Maybe it is also important that the graphic screen is connected and on during the boot / reboot. That could be a difference which what I have made before… but I am not sure, it could be something different.