HUION Kamvas Pro 22 drivers not available on DIGImend list


#86

Then don’t install it as it might not be the best mix. I can’t predict if will conflict or not.
Make sure you “record” somehow the steps you did to get it working. If you say that after putting the machine to sleep mode the pen works, then there must be something related to that that triggers the pen to get active. I can’t say i understand what that could be …

Nice work @dglt :clap::clap:


#87

when all else fails, shoot blindly until you hit something. this was a combined effort of yours, mine, killi, and tbg . and @killi great job not giving up, most would have by now. at the very least as far as i know your the first documented case of getting this particular graphical tablet working on any linux distro, not just manjaro so :partying_face::champagne::+1:


#88

If you manage to gather all the good information, the entire how to, made as a wiki and added to the existing one, even more people will benefit from it.


#89

Thanks a lot to all of you @dglt, @bogdancovaciu and @tbg, thanks for your patience with a newbie like me.

I have now tested it without rebooting or changing anything. I have seen that it works quite well when what is on the graphic tablet is the exact mirror of what I have on my screen. It does not work quite well if use the graphic tablet as a second workspace what could be more practical but in a first step, I do not want to have all working perfectly, just having the pen and tablet good working is almost enough for me. Regarding the different keys around the tablet, when I click on it the pointer is almost always directed on the top of the graphic tablet screen.

How can figure out what is the good combination? I am now “afraid” to reboot my computer and not to manage to make the pen work once again…

Do you think that the driver start-driver.sh is still running or is working? Can I make something to see if this is the case? Or can we know if it had helped to make it run and then make ctrl+Z in the terminal?


#90

I did nothing of consequence, it was all @dglt and @bogdancovaciu who solved it for you. Be sure to give one of them credit for the solve.

Congrats, and glad you got it working.


#91

How can I do that?


#92

you may not want to but you know you have to. wouldnt you rather do it now while everything is still semi-fresh?

i think you can safely get rid of one of those, either start-driver.sh can be removed entirely, the only difference between it and uclogic-probe-run.sh is the sleep 3 line. also i dont know if there are 2 kamvas.py but only 1 is needed


#93

you cant yet, its not completely solved and we dont know yet exactly what combination of “things” have made it work.


#94

My computer rebooted by itself (since I am working without battery as @dglt told me and since the power distribution has stopped).
I made

wizardpen-calibrate
usage: wizardpen-calibrate event-device - probably /dev/input/event0

and then xinput --list the pen does not appear in the list

then I made sudo ./start-driver.sh

then xinput --list the pen appears in the list but does not function.

Then I have put it into sleep mode and awake but the pen is not list into the sudo evtest list I obtain…


#95

:roll_eyes: i meant to shut down, remove battery, hold power button for 10-15 seconds, replace battery, turn on. it helps with hardware related issues sometimes.


#97

It is not your fault. Sorry for having bad read/understood.

You prefer the probe driver even if it has worked today with the start one?
There is just one kamvas.py.


#98

so lets work within the variables you so far have introduced and see if powering down tablet only and powering back on with help it be detected, possible unplug the usb and plug it back in and check detection again, then suspend again after that and wake and see if its detected then, process of elimination isnt fun but has to be done.

if by that you mean power was cut off abruptly, reboot properly right now, you need control the working environment to that of what would be considered “normal use”, and abrupt power loss is not that.
after reboot, lets skip the wizardpen. check detection right from the start without running anything.
nothing?
stop when you see a change.

  • unplug usb and plug it back in? test.
  • sleep/wake . test
  • sudo ./start-driver.sh; sleep 2 & exit
  • test
  • sleep/wake . test
  • wizardpen-calibrate
  • test
  • sleep/wake
  • test

another thing, using sudo evtest select your mouse/touchpad and use it, you should see output instantly and constantly for every movement/click. if you dont something more is wrong. same goes for the graphic tab, once its detected you should see output on evtest in real time, if there is no output, its not reading it.


#99

I manage to make it work another time (!) but I don’t understand how to make it work every time.

After that, I had a problem by disconnect and putting the computer into sleep. Something happened and the pen did not appear in the xinput --list anymore. So I ran sudo ./start-driver.sh and it happened again in this list but also in the sudo evtest one I could not draw on the graphic tablet. After that I close the two terminal windows I had, and I tested the pen to see if it this by chance recognised and it was the case. Could it be linked by clothing/opening the terminal. I have also before that opened/closed krita and press ctrl+shift+t.

The mystery is not solved…

Should I reboot and try what @dglt said lastly (see below) ?


#100

I have rebooted and I have only made sudo ./uclogic-probe-run.sh and I can see now the pen both in the xinput --list and the sudo evtest one, whereas the pen was absent of the xinput --list before the sudo ./uclogic-probe-run.sh` command.

After that I have tried to do that:

I can still not draw with the pen.

I have tried to open/close Krita and press ctrl+shift+t and to make the computer into sleep /awake. It does not work.

I have tried to close a terminal windows where sudo ./uclogic-probe-run.shwas still running and the other terminal windows which was running sudo evtest` tells suddently “no such device”, cf. below:

Select the device event number [0-16]: 16      
Input driver version is 1.0.1
Input device ID: bus 0x3 vendor 0x1 product 0x1 version 0x3
Input device name: "kamvas-pen"
Supported events:
  Event type 0 (EV_SYN)
  Event type 1 (EV_KEY)
    Event code 320 (BTN_TOOL_PEN)
    Event code 330 (BTN_TOUCH)
    Event code 331 (BTN_STYLUS)
    Event code 332 (BTN_STYLUS2)
  Event type 3 (EV_ABS)
    Event code 0 (ABS_X)
      Value      0
      Min        0
      Max    95352
    Event code 1 (ABS_Y)
      Value      0
      Min        0
      Max    53645
    Event code 24 (ABS_PRESSURE)
      Value      0
      Min        0
      Max     8192
  Event type 21 (EV_FF)
Properties:
Testing ... (interrupt to exit)
expected 24 bytes, got -1


evtest: error reading: No such device

Making again sudo ./uclogic-probe-run.sh and I can see now the pen both in the xinput --list and the sudo evtest one as I said in the beginning of this post.

Then I made wizardpen-calibrate, sleep/wake and it works again ! Without wizardpen-calibrate and sudo ./uclogic-probe-run.sh it seems that it cannot work if I correctly understand!


#101

100 post topic button. :smile:


#102

héhé!

Should I reboot to test once again?
I find not so practical to have a terminal windows running. For that is sudo ./uclogic-probe-run.sh > /dev/null 2>&1 & disown; sleep 2; exit sufficient?


#103

Ok, what i gathered so far:

  1. You have the start-driver.sh that needs to be started using sudo or you can run it as your user too, or you did not tested that? If the pen works after running the command and closing the terminal, then that’s it
  2. That means you can run it at boot either in systemd unit as @tbg knows how to create them and can explain better, or as startup desktop file that can be created easily.

Question: where the *.sh files reside on your HDD, are in your home directory or somewhere in /usr/bin ?


#104

You should always have a drop down terminal running. Yakuake is my favorite. Test the commands I gave you to see how they work.


#105

The start-driver.sh and uclogic-probe-run.sh are in my home directory on my HDD.

Should I move then to /usr/bin ?

Should I test to run start-driver.sh located in the home directory without “sudo” as a “prefix”?

Sorry I do not understand what you are talking about exactly but it is because of the lack of my knowledge in informatics.


#106

I just wanted to say that with a command like maybe sudo ./uclogic-probe-run.sh > /dev/null 2>&1 & disown; sleep 2; (or a similar one that I would like to find) I need maybe not to have a terminal windows opened.